Jump to content

Urgent help, please


7 posts in this topic

Recommended Posts

need help please. the only way i can boot leopard is when i insert the toh dvd and wait until countdown timer finishes. otherwise i only see a underscore in the upper left corner blinking. i installed it and ran the script already. can't boot windows too. thanks

Link to comment
Share on other sites

hardware please?


it is always a good idea to put your hardware in your signature. Also, it would be nice to put your level of expertise so others know what level to write to (i.e. can I say "Wipe your drive, install efi, and do a clean install", or do I need to link to a tutorial).


if your hardware is compatible, you can try to install efi.


see, if you had included your hardware in your original post (which is the standard thing to do when asking for help) I could be providing you with a solution right now!


Use this OSx86 search engine to search for stuff.


Here an excerpt from a full install guide I wrote (for brazilmac, efi + GUID, on the GA P35-DS3P motherboard). Use this to install efi, assuming your motherboard and CPU are new enough (CPU should have "core" in the name ie "core 2 duo"), even if you formatted your drive with MBR instead of GUID, and even though you used ToH instead of Brazilmac:



-download EFI Pack from http://rapidshare.com/files/75234066/EFI_Pack.zip.html

-copy EFI Pack and brazilmac patch to thumbdrive (but keep thumbdrive plugged in to the old (working) computer


boot into dvd, and open disk utility


find the name you chose for your leopard hard drive(Mac OS X Leopard for me) in the sidebar and select it, then click info. write down the Disk Identifier (mine is disk1s2)




**go back to the old computer (let the new one be) and open up EFI.sh on thumbdrive/EFI Pack


Find this line, and change to this: Patch="/Volumes/thumbdrivename/EFI Pack/pc_efi_v80" (change thumbdrivename to the name of your thumbdrive, duh)


find this: EFI="/dev/rdiskXsY" and replace X and Y with what you got from the disk identifier from disk utility on the new computer (so i put /dev/rdisk1s2)


find this: DRIVE="/dev/diskX" and change X to the number you got from disk identifier (so i put /dev/disk1)


now copy brazilmac patch to thumbdrive, open up 9a581PostPatch.sh


change to Patch="/Volumes/thumbdrivename/brazilmac patch/leopatch"


change to Leo="/Volumes/leopardvolumename"


--be smart (by changing "leopardvolumename" to the name of your leopard hard drive, same for thumbdrivename)


now save the files and eject the thumbdrive


**go to new computer


in sidebar of disk utility, click on your volume and click unmount


quit disk utility


now plug the thumbdrive into the new computer


go to Utilities -> Terminal


cd /Volumes <press enter>


cd thumbdrivename <press enter> (put a forward slash [ \ ] before all spaces, apostrophes, and other symbols)


cd EFI\ Pack <press enter>


./EFI.sh <press enter>


It should say stuff, but no errors. this is important. read through what it tells you, and make sure there are no errors. if you get something like "file does not exist" then check the path names. This is bad


if its all good, continue. if not, fix it.


i said "N" to the reboot so i could check for errors. now that there are none:


reboot <press enter>


wait a little while for it to reboot(maybe 3-4 minutes if it appears to freeze, and then pull the plug (no harm done, it will still work))


at bios post, choose boot disk (means pressing F12), and choose the volume with leopard on it


if everything is as it should be, OS X should start to boot up. This is GOOD! if you get "verifying DMI Pool Data" and it hangs, you are in bad shape. make sure you didn't miss any steps, or screw them up. Use common sense, i MAY have missed something (lol haha). if your good, move on.


Hope that helps!

Link to comment
Share on other sites

i think i might be medium level in terms of informatic knowledge (still dont know wht efi is but know how to format, do partition, etc). i decided to run linux (ubuntu) and now i'm able to run linux and windows and i could install acronis os boot selector, but it don't recognizes mac. i ran the script (/usr/misc/script.sh Leopard) 4 times +/- (saw some posts where some people had the same problem). I have a Asus f3jc with 1 gb ram, nvidia go 7300 512mb, 1,66 core duo (Intel T5500) and 100 gb hard disk . thanks :hysterical:

Link to comment
Share on other sites

ok your hardware should be compatible with efi


The main reason why you can't simply install OS X (unmodified) on a regular Pc is that macs use EFI to initialize the hardware at startup, and PCs use BIOS. Use google if you want to learn more. pc_efi is this magical thing that replaces the darwin bootloader, and uses bios calls to initialize the hardware and pass correct addresses of hardware to the operating system. If you install pc_efi, you can use Software Update to update your OS without it breaking your install, and you can use the vanilla (normal, unmodified, retail) kernel, and most vanilla kexts (kernel extensions, provide driver support for stuff).


Follow the instructions I gave you, and you should be able to boot without the dvd. I have already had one person follow them, and they did well (and they were in your position).


I have heard that anacronis has massive problems in terms of reliablility. I think grub (2, not legacy) is better.

Link to comment
Share on other sites

this : didn't understand one thing. what is the old computer and new computer? and by the way i am using grub on ubuntu and tried


   title OSX_X86
  rootnoverify (hd0,8)
  chainloader +1


but doesn't work. my partition is disk0s8 named Leopard :D thanks

Link to comment
Share on other sites


  • Create New...