Jump to content

G4 mac won't work


8 posts in this topic

Recommended Posts

So we have this computer. It's MAC hardware and I'm a PC guy 110% so I am not at all familiar with ways to test things on this Mac to help pinpoint a problem, so I've come here to ask you guys.


Okay so when we press the power button the fan comes on inside, in the power supply that is.

But thats all it does..


Attached to this Mac is a wide-screen LCD studio display. When u press the power button on the monitor it lights up momentarily but just fades back off. As if the monitor WORKS but it's not receiving any video signal so it just goes back off.


I don't have any converters to test the monitor on a PC, which all we have for miles. I also am not sure if I can safely put any old AGP card into the AGP Slot in this computer to see if the video card is to blame or something.


This Mac does not beep any error codes or anything like a PC might. I've tried it w/ and without it's ram installed. Still no difference. It will just sit there w/ it's fan running until I decided to turn it off, and to do that i must press and hold the power button for a number of seconds.


I really would like to get this thing to work; It has a nice display and I'm sure is still more than useful even today. If anyone could give me any information or pointers on troubleshooting this unit I'd greatly appreciate it!!

Link to comment
Share on other sites

1. Thank you for responding

2. The display is not built in.

3. Replace the small purple battery on the motherboard? That small thing could cause this machine to not boot?

4. How does removing the ram harm it? It's not like I'm taking it out while it's on or something.

5. Please see the attached picture so that we're on the same page as to what system I'm talking about, I'm not sure we are but maybe. I think the proper title for it is a "Apple Power Mac G4".


Please advise, thank you.


Link to comment
Share on other sites

Try a few of these when you press the power button:


Startup Keystroke Description

Press X during startup Force Mac OS X startup

Press Option-Command-Shift-Delete

during startup Bypass primary startup volume and seek a different startup volume (such as a CD or external disk)

Press C during startup Start up from a CD that has a system folder

Press N during startup Attempt to start up from a compatible network server (NetBoot)

Press R during startup Force PowerBook screen reset

Press T during startup Start up in FireWire Target Disk mode

Press Shift during startup start up in Safe Boot mode and temporarily disable login items and non-essential kernel extension files (Mac OS X 10.2 and later)

Press Command-V during startup Start up in Verbose mode.

Press Command-S during startup Start up in Single-User mode (command line)

Link to comment
Share on other sites

Yes, replace the small purple battery and see if it will boot up.

Okay sweet I'll look into that.


Also, other suggestions are still greatly appreciated so if I can't fix it I can atleast find the problem or declare the thing trash.


Link to comment
Share on other sites

  • 2 weeks later...

You can super reset the computer by Zapping the PRAM 3 times in a row (Command - Option - P - R) . Then move your fingers from the P R keys to the O F keys (in other words Command - Option - O - F). This will bring up a machine language screen.

At the prompt type the following:


reset-nvram <return>

set-defaults <return>

reset-all <return>


If that doestn work you could try to resetting by holding the CUDA switch (inside the machine, somewere the on the motherboard. The location differs for every model) down for 15 seconds and run through zapping the pram sequence listed above.

Link to comment
Share on other sites


  • Create New...