Jump to content

Leo sound glitches with AC97, random crashes


4 posts in this topic

Recommended Posts



I got Leo (brazilmac + SSE2 kernel) installed on the following System


P4 2,8 (SSE2 only), 865PE, sound is C-Media 9739A (recognized by tiger and leo as AC97), Geforce 7800 GS AGP

Network: D-link DGE-530 ethernet, fully working with skge.kext


My greatest problem in leo right now is audio. In Tiger audio was never a problem and worked flawlessly from the first moment on. In Leo, it generally works, but systemsounds (ie if you use a corner of the screen for expose with no windows open or empty the trash) are completely scrambled. Also if i play a track in itunes, the first 2 seconds are completely scambled, then everythings normal, but i got the feeling that it generally sounds worse than it should.


My plan to solve that problem is to use the kexts and frameworks from tiger, which worked pretty well, but i don't really know what i should look for. I already played around with AppleAC97.kext and some other more or less audio related kexts from tiger, but with no result, so it might be more framework related.


I'll appreciate any advice in this matter.


Other things to mention are those random crashes i have, but i think those are not really solveable, as i had those with tiger too, so i think thats a matter of my old SSE2 system not really meant to run this OS.


a small sidenote: i tried to edit the wiki on http://wiki.osx86project.org/wiki/index.php/HCL_10.5.0 to add my DGE-530 and 7800GS AGP as fully working and how to install , so i registered and got following message:

"This page has been locked to prevent editing.


You can view and copy the source of this page "


Not a good idea to lock the HCL, ey ?



Any help's appreciated

Link to comment
Share on other sites

Now i managed to update my SSE2 machine to 10.5.1, but unfortunately the problems still remain. I played around with the frameworks by replacing some audio related ones with the ones from tiger, but it seems like frameworks arent so easy to exchange like kexts, bec i couldn't boot up anymore with them. Any advices here ?

Link to comment
Share on other sites

  • 7 months later...

I have a simular system but have not gotten leo on mine yet. Can you share how you got it to install? OR if anyone reading this can help me my details are below.


My specs are:

Gigabyte GA-8IP900 p4 titan Intel 865P chipset Link: http://www.giga-byte.com.tw/Products/Mothe...?ProductID=1641


AGP- BFG Geforce 7600GS 512mb DDR2 ram


Realtek ethernet card. unsure of the model but it is 10/100 works in tiger should in leopard.


Onboard realtek sound works in tiger, should in leopard


My problem is:


I am completely lost here. I get an instant reboot with both kalyway 10.5.2 and leo4allv3 10.5.2. I have tried -v and -x together with no luck. Hyper threading is disabled. There is no AHCI mode in my bios. I have tiger 10.4.11 installed on this system and it works perfect. The only difference is I am using a radeon 9600 agp card. The drivers I am using with that card are castelio v3 and they are old and no updated for leopard. So I got this geforce 7600GS card in hopes of getting leopard on this system.


Can anyone help? THANK YOU!!!!!!!

Link to comment
Share on other sites


  • Create New...