Jump to content

Intel D945GCCR and Leopard


9 posts in this topic

Recommended Posts

After finally upgrading my trusty ADP 10.4.6 box (see sig below) to 10.4.10, I've decided to test out Leopard! Bad move... now I've caught that hacking bug once again! I went shopping and this is what my new setup will be:


Desktop: Apple MacPro

MoBo: Intel D945GCCR S775

CPU: Intel Pentium Dual-Core E2160 1.80GHz FSB800 1MB Cache

Cooler: Intel Box Cooler

RAM: 2GB (2x1GB) Corsair Value Select DDR2 667MHz

DVD: LG GSA 4167B Dual Layer

HD: SATA2 300GB Samsung HD300LJ 8MB Cache UDMA/100 7200RPM

Video: Intel Graphics Media Accelerator 950

Video2: Silicon Image Orion PCI-Express x16 ADD2 DVI

Audio: Intel HD Audio Azalia 883

Speakers: Creative Inspire 2.1 2400

Case: Goldship Cool Case (Silver) with 500W PSU

Monitor: DELL FP2001 LCD 20.1" @ 1600x1200x32

Monitor2: Apple 23" Cinema HD Display @ 1920x1440x32 using DVI-D

Webcam: Apple iSight

Firewire: Orange Micro OrangeLink Firewire PCI Board


I will be installing BrazilMac's 10.5 Oct31 DVD using the built-in GMA950 video. The new MoBo now gives access to EFI and a PCI-e 16x slot for further video card upgrading if I need to and a Leopard friendly GMA950 to start on (Yea, I gave up on GMA900). A nice cool (literally) Dual-Core will lower the temperature, lower the noise, and run blazingly fast! Faster memory will also help my XBench score! And finally, Apple's 23" Cinema HD Display is orgasmically hot! EFI, normal updates is good!


The fun begins tonight!

  • Like 1
Link to comment
Share on other sites

Created 3 partitions: 80GB for Tiger, 80GB for Leopard, and 120GB for Data. Installed mac.nub's 10.4.10 v1r5. GMA950 packaged worked fine but audio and network did not. I searched the forum and found working packages.


Solved the audio problem using a the generic AzaliaAudio.pkg which provides 2-ch stereo audio.

Link to comment
Share on other sites

Solved the network problem using the AppleIntel8255x.kext


Xbench 1.3 yields 117.09 (10.4.10)


System Profiler does not display the correct amount of RAM installed (says only 1GB), but 'top' says there is 2GB. I thought System Profiler was fixed...Will install Leopard now... stay tuned!

Link to comment
Share on other sites

Installed Leopard successfully using Onetrack's tutorial! Leopard 10.5.1 running with vanilla kernel and pc_efi v5. Network and Audio patch above worked just the same. GMA950 detected with QE/CI enabled but only 1024x768 resolution. System Profiler correctly identified both memory sticks and 2GB total. Detects my machine as a MacPro :censored2:

Link to comment
Share on other sites

Fixed graphics mode by adding:


<key>Kernel Flags</key>

<string>"Graphics Mode"="1600x1200x32"</string>


to /Library/Preferences/SystemConfiguration/com.apple.Boot.plist


Obviously I have overridden the detection of my DELL LCD and may have implications on the monitor's energy saver sleep function.


Xbench 1.3 yields 117.90 (10.5.1)


Too bad I can't overclock on this MoBo!

Link to comment
Share on other sites

  • 2 years later...

  • Create New...