Jump to content

Grub Error 22 - when loading OSX

5 posts in this topic

Recommended Posts

Hey all;


I have been having fun running OSX 10.4.10 on my vmware server as a virtual machine, and have decided to take the plunge and go native. I followed the Magnificent 7 tutorial, but as soon and I start the VM Machine I hit a major snag.


Tried with both VMware server 1 and Workstation 6.


I have tried both alocohol 120% and daemon tools.


If I create a virtual disk it works just fine, no issues at all.



If I select use a physical disk, regardless of using full disk or partitions I get the following error as soon as I start the VM.


Grub Loading Stage 1.5.

Grub Loading, Please wait...

Error 22


Then nothing it just sits, there.

Any thoughts?

Link to comment
Share on other sites

14.3 Errors reported by the Stage 2: Error 22

22 : No such partition

This error is returned if a partition is requested in the device part of a device- or full file name which isn't on the selected disk.


Give us more details on what is your configuration: what disks, what's on them, where are the partitions (eg osx partition), etc.

Also, give us your menu.lst.

Link to comment
Share on other sites

I have no idea what a menu.lst is


I have drive 1, which has 2 NTFS partitions on it. Part 1 is XP Pro, part 2 holds files.


Disk 2 is empty, this is what I want to install OSX to.


I have tried it with disk 2, no partitions, and with fat 32 partitions.


Same error.

Link to comment
Share on other sites

  • 8 months later...

  • Create New...