Jump to content

Does EFI bootloader not work with flat image?

Doug the Impaler

2 posts in this topic

Recommended Posts

Stupid, albeit quick question:Has anybody else successfully used the EFI loader (v4) with the Leopard flat image? I'm all Intel, all the time:


Pentium E2140

2GB DDR2-800 RAM


nVidia 7600GS


When I install the image, it works great out of the box (aside from LAN, but I use tulip.kext with a Linksys 10/100 card). Then I saw all the successful reports with 10.5.1 working with the EFI loader, so I used these instructions to get it going (replacing the vanilla cp command with cp -R since so many of the copied files are directories). The first time I did the bit with using the vanilla kernel and when it'd start up, it'd reboot. I decided to get my stuff off that drive (using Mac Drive and XP) and re-do the install. This time, I just installed the EFI boot loader and skipped the kernel, thinking it'd load either way if the boot loader was right. Now I get the multi-lingual restart message (kernel panic). So I gave up and went to bed. Before I went to bed, however, I started downloading the ToH 10.5 image. I guess I'll burn that and try again when I get home from work.


But I want to know - shouldn't the EFI bootloader have worked with that flat image? And yes, I copied the included kexts and repaired permissions both times. Maybe starting with a minimally-modified Leopard install will do the trick...


edit: Hmm, I might be on to something...I saw this post about not using patched kexts with the vanilla kernel, so I must have something patched that shouldn't be.


Weird, when you reply to your own post it combines them (fine with me) but it also takes out all the carriage returns (which makes it ugly)

Link to comment
Share on other sites



I just installed EFI for 5 mins over flat image, and it works very well.

I only replaced the kernel and the smbios files, all other still the same as from flat.


For the 1st time , my time machine works.


Only issue left: about this mac shows a core2 solo and i got a core 2 duo.

Geekbench says 2 logical cpu, 1 hardware cpu..

Link to comment
Share on other sites


  • Create New...