Jump to content

10.5.1 Working with EFI v4 and Vanilla Kexts.


3 posts in this topic

Recommended Posts

Hey All,


I wanted to post my experience updating to 10.5.1 on my ECS 945GZT-M w/E2160 cpu. This is exactly how I did this. Do not take this as a "How-TO".


Please Note - I would only attempt Vanilla on Core family processors. If you are using any other CPU you may want to try a different method/kernel.


1.) I installed with the Brazil mac method from last month. Had been running this without any issues except for time machine patch.

2.) Backed up all my 10.5 extensions to root in a directory called "/Brazil-Extensions"

3.) Backed up my current kernel to /old (you can never be too careful)

4.) Downloaded the files and printed this article (I PUT THIS TO THE SIDE - DID NOT UPDATE YET) - http://www.digitmemo.com/articles/734/howt...-in-hackintosh/



At this point I was going to update to 10.5.1 and after reboot run the EFI Patch.



5.) Copied the EFI Files to a spare drive (USB Flash disk will work)

6.) Downloaded and Installed MacOS 10.5.1 Update from Apple.

7.) Rebooted my Mac without the EFI update (Hoping to install EFI patch in single user more). After reboot I discovered I could not boot my system into any mode. Three Seconds after the Darwin Bootloader the system would reboot.... endlessly.



Uh-oh I can't boot into Leopard! - All is not lost, I have my Install DVD



8.) Popped in the Original Brazil Patched Leopard DVD and booted.

9.) After the welcome screen, I Launched Terminal and ran the EFI Update from my flash drive installing both the dsmos.kext and AppleSMBIOS.kext (Note you must cleanly unmount your Volume to patch it from the install DVD. You can unmount the Volume from CLI or Disk Utility.)

10.) While I was at it, I repaired my permissions from Leopard Install Disk.


Rebooted and Viola! Working Leopard 10.5.1 Vanilla ... as Vanilla I can get it...


Note: Time Machine is working Vanilla with a GUID formated disk. I have not tested MBR yet.



Link to comment
Share on other sites

Bravo my good man Bravo!


This should be stickied.


I am a complete noob and this worked for me!!!!


Now my resolution is stuck with 1024x768 but I heard that's common.

OMG. I can't believe this worked!!!



Perfecto! I am glad it is working for you.


I forgot to add that I am not using the onboard GMA 950 for my Video Display. The onboard video is disabled so that I could use a dual-monitor setup with a PCI-E PNY Nvidia 7600. The NATIT kexts were not touched during the 10.5.1 update so everything seems to be the same as with 10.5.0.


If I am not mistaken, I believe the NATIT/NVInject came as part of Brazil-Mac patch because everything "just worked" after I originally installed Leopard... I will need to clarify this when I get a chance.

Link to comment
Share on other sites


  • Create New...