Jump to content

Leopard and MSI P965 Platinum Running, but...


2 posts in this topic

Recommended Posts

I managed to get Leopard mostly running on my system.


MSI P965 Platinum

C2D E660

PCI Wireless Linksys WMP54G


Here's what I had to do.


1. Use Make Leopard Bootable Disk from Koolkal to Partition and install bootloader (F8, -v -f)

2. Use ToH RC2(2) disk to install leopard (F8, -v -f), I did NOT run the /usr/misc/script.sh because the previous step handles that.


After it installed I ran into the Welcome video loop, I fixed that my enabling my Firewire in the BIOS.

Also I should note, IOACPI must be enabled and Virtualization must be disabled. SATA drives set to AHCI.


I installed Natit .2 and that gave me QE/CI/CA/res.


Used the Ralink Drivers (1.4 I think) and my WMP54G wouldn't get DHCP, I messed around and found out that in Preferences-->Network, If you click the Setting (*) Icon and change the order of the devices it will work. Firewire was taking priority over my actual network card, but after I did that it worked great.


I've found that AppleAzailia sound works, but just the two channel and no inputs.

I've tried using AppleHDApatcher, the other channels show up, but there is no sound. All I need to do is drag the codecs to the icon right?


My Questions:


1. Is there a way to get the WMP54G v4.1 (RT2500) to use native airport by changing device ids or something? Or at the very least, how can I make the WirelessPCIUtility application to automatically close or not startup when the system boots?


2. Has any gotten their ALC883 to fully work or at least get 2 channel out with Mic in to work? My board has 6 analog, coax, and toslink.


Thanks a bunch

Link to comment
Share on other sites

  • 1 month later...

the WMP54G v4.1 never worked with Tiger... so i wouldn't expect leopard to be any different.


the ralink drivers are only for ppc.

Link to comment
Share on other sites


  • Create New...