Jump to content

Realtek Ac97 Audio issue


kiksy
 Share

3 posts in this topic

Recommended Posts

Hi ,

 

Ive been trying to install OSX on my Pc. Used Uphucks 10.4.9, everthing perfect first go execpt Audio. I have onboard Realtek AC97, and also a Soundblaster PCI card (which Ive read will never work in OSX)

 

If any one could spare a few minutes to help , id be very grateful!

 

I read and the AC97 tutorial on the Wiki , and edited the AppleAC97Audio.kext

 

I also tried installing Jas 10.4.8 ,no luck , and again edited the kext.

 

this is what my .plist looks like :

 

?xml version="1.0" encoding="UTF-8"?>



       CFBundleDevelopmentRegion
       English
       CFBundleExecutable
       AppleAC97AudioIntelICH
       CFBundleGetInfoString
       1.0.0, Copyright Apple Computer, Inc. 2004
       CFBundleIdentifier
       com.apple.driver.AppleAC97AudioIntelICH
       CFBundleInfoDictionaryVersion
       6.0
       CFBundleName
       Intel ICHx AC97 Audio Driver
       CFBundlePackageType
       KEXT
       CFBundleShortVersionString
CFBundleShortVersionString
       1.0.0
       CFBundleSignature
       ????
       CFBundleVersion
       1.0.0
       IOKitPersonalities

               ICH2 AC97 Audio

                       CFBundleIdentifier

 CFBundleIdentifier
                       com.apple.driver.AppleAC97AudioIntelICH
                       ICH Type
                       2
                       IOClass
                       AppleAC97AudioIntelICH
                       IOPCIPrimaryMatch
                       0x24458086 0x243580860 0x70121039
                       IOProbeScore
                       10000
                       IOProviderClass
                       IOPCIDevice

               ICH3 AC97 Audio

                       CFBundleIdentifier
com.apple.driver.AppleAC97AudioIntelICH
                       ICH Type
                       3
                       IOClass
                       AppleAC97AudioIntelICH
                       IOPCIPrimaryMatch
                       0x24858086 0x70121039
                       IOProbeScore
                       10000
                       IOProviderClass
                       IOPCIDevice

               ICH4 AC97 Audio

                       CFBundleIdentifier
                       com.apple.driver.AppleAC97AudioIntelICH
                       ICH Type
                       4
                       IOClass
                       AppleAC97AudioIntelICH
                       IOPCIPrimaryMatch
                       0x24c58086 0x70121039
IOProbeScore
                       10000
                       IOProviderClass
                       IOPCIDevice

               ICH5 AC97 Audio

                       CFBundleIdentifier
                       com.apple.driver.AppleAC97AudioIntelICH
                       ICH Type
                       5
IOClass
                       AppleAC97AudioIntelICH
                       IOPCIPrimaryMatch
                       0x24d58086 0x70121039
                       IOProbeScore
                       10000
                       IOProviderClass
                       IOPCIDevice

               ICH6 AC97 Audio

CFBundleIdentifier
                       com.apple.driver.AppleAC97AudioIntelICH
                       ICH Type
                       6
                       IOClass
                       AppleAC97AudioIntelICH
                       IOPCIPrimaryMatch
                       0x266e8086 0x70121039
                       IOProbeScore
                       10000
                       IOProviderClass
  IOPCIDevice

               NVIDIA AC97 Audio

                       CFBundleIdentifier
                       com.apple.driver.AppleAC97AudioIntelICH
                       ICH Type
                       99
                       IOClass
                       AppleAC97AudioIntelICH
                       IOPCIPrimaryMatch
0x026b10de 0x005910de 0x00ea10de 0x00da10de 0x008a10de 0x006a10de 0x003a10de 0x01b110de 0x70121039
                       IOProbeScore
                       1000
                       IOProviderClass
                       IOPCIDevice


       OSBundleLibraries

               com.apple.driver.AppleAC97Audio
               1.0.0
com.apple.iokit.IOPCIFamily
               1.1







 

my device ID is:

 

PCI\VEN_1039&DEV_7012&SUBSYS_70311462&REV_A0\3&61AAA01&0&17

 

 

 

so

 

ven 1039

 

dev 7012

 

 

 

When I dont edit the kext, no audio device is found, after I edit it, I can adjust volume (but no sound) , run "sound" and the OS freezes, mouse still moves, but can do nothing.

 

When I run "Audio Midi Options" I can see that the OS has found the AC97 device for both input and output, i can adjust volumes, but as soon as I cause an event to make a sound, (such as "configue Speakers") , it freezes.

 

Thanks in advance.

Link to comment
Share on other sites

I have that same onboard audio. I only got Output working, and I didn't have to do anything for that. I am using v1.3, are you? I gave up on input, and got an external sound card.The Griffin iMic works great and is cheap (<$35). I don't know about modifying Kexts, does anyone alse know if it will work?

Link to comment
Share on other sites

I have that same onboard audio. I only got Output working, and I didn't have to do anything for that. I am using v1.3, are you? I gave up on input, and got an external sound card.The Griffin iMic works great and is cheap (<$35). I don't know about modifying Kexts, does anyone alse know if it will work?

 

 

Im using 1.4r3 . ill give 1.3 a try.

 

thanks!

Link to comment
Share on other sites

 Share

×
×
  • Create New...