Jump to content

Various Leopard Driver Issues

4 posts in this topic

Recommended Posts

After installing leopard on my vaio, there is still much to do.

Out of the box my audio does not work. It claims to be detected as Apple HD Audio with AppleAzaliaAudio.kext (edited or non), but that's not working. AppleHDA.kext with the AppleHDAPatcher does not seem to work, even though I found a dump file posted here for my audio card.


Wifi does not work natively or with the iwi9465 driver (crashes on load). I read here[/u] that it works automatically on 10.4.8.


Marvell 88e8055 is not being detected despite there being an entry for it in AppleYukon2.kext!


And also, it would cool if macinject worked with the Nvidia 8400.


EDIT3: I might just use some Tiger kexts for the moment. I will try replacing IO80211Family.kext, AppleHDA.kext, AppleYukon.kext, or AppleAzaliaAudio.kext.

Link to comment
Share on other sites

I have tried replacing various leopard drivers with tiger ones, to no avail.


I have come the the conclusion that AppleAzaliaAudio may have worked for my laptops optical output (not sure how to use this) but not for the built-in speakers/headphone jack output.

AppleHDA.kext seems to not work at all (neither tiger nor leoopard versions).


Also, replacing AppleYukon2.kext with a renamed + altered tiger AppleYukon.kext does not work for my ethernet.


Wifi also doesn't work despite claims that the 4965 works in Tiger.


I haven't ever run tiger on this laptop natively so I can't be sure what may or may not work.

Link to comment
Share on other sites

Ok, after repairing permissions I reliazed that ethernet is detected with my modified tiger Appleyukon.kext, unfortunately it always tells me that the ethernet cable is unplugged, even if i turn the laptop on with it plugged in!


Oh well, at least it's getting closer to working. Maybe networking is different in Leopard than Tiger...

Link to comment
Share on other sites


  • Create New...