Jump to content

Compaq v2000 ehci error


2 posts in this topic

Recommended Posts

ok heres the issue. i have to load an older version of iousbfamily.kext to keep my computer from booting so slowly its not funny. I once left it running the bot with the standard iousbfamily.kext version 2.6.1 for kernel 8.8.1 and then left the computer to see if it would boot something like 5 hours later it was still going a line at a time. Also if i don't load the older and edited i i think (it was a fix i found) the built in keyboard and track pad dont work. an external one will but its a laptop and that would suck. The problem is upon loading i get a yellow line in darwin that says :

Failed to load extension com.apple.driver.appleUSBEHCI

i have tried replacing it with the EHCI fix but it slowed the computer down again the keyboard and mouse stopped working again. This is really getting on my nerves. I cant load my external hard drive because of this. One other thing in about this mac under usb it says No information found, but a standard usb mouse and keyboard will work. but nothing else that i have tried will.


The only other major problem i have is that anytime i unplu or plug in the power while its on the system freezes. I have tried the powermangement.bundle and that did fix the batter icon not being present bt not the power cord freezing problem


Thanks in advance for any help



the version of IOUSBFamily.kext that works is 2.4.6


system specs:

compaq presario v2000 (v2575us)

AMD turion 64

ATI Radeon xpress 200M

light scribe DVD-rw

Link to comment
Share on other sites


  • Create New...