Jump to content

Uh oh I think I broke my MBR


3 posts in this topic

Recommended Posts

So I installed 10.4.8 onto my Mac with an external 8GB USB key (worked like a trick!).

Mine is Asus M2N32-SLI Deluxe with the WiFi antenna, 8800 GTS (working at 800 x 600), Vista Home Premium is the other OS. Oh, and a 500GB Maxtor SATA-2 drive, which is the reason why I needed the external key.


I put on the SIL3132 (I think?) driver, plus the realtek 8187 wireless driver (I think?) That stuff all works good. Plus, AppleNForceATA.kext and the Azalia audio (it detects my MCP55 SATA controller with the SATA DVD recorder, gives me stereo sound, but no on-board network yet).


ANYWAY, the trouble is, I had left an open partition on the Maxtor; and I used Macintosh Disk Utility to "Restore" the partition from the USB Key. And guess what, it worked perfectly: I am running Mac OSX from my Maxtor right now! This all happened yesterday.


Well anyway, I thought "ho hum lets see how Vista likes it" and it DOESN'T. It tells me the installation is corrupt. I mean, ALL my files are available from within Mac OSX (volume is "Untitled"): it's all there, Windows, Users, lots of other files and folders I never knew about before, but it's all there.


The trouble is, I tried the Vista DVD and "Repair Installation" but it cannot find the OS! I tried hooking up the Maxtor back to the original MCP55 SATA, didn't work (Mac OSX didn't like it either, I had to put it back onto the SIL3132 -- no worries).


Any help will be much appreciated, not a super huge panic but would like to get dual boot capability back online sometime or other!


Take care,

Jokmar (aka Grunchy)

Link to comment
Share on other sites

It kinda sounds like your MBR is screwed up or that Vista partition is not active. Use Gparted or try the ultimate boot cd and boot it up then make partition active. Once Vista is bootable you then either use the chain0 or get a boot manager to control what OS to boot.




Link to comment
Share on other sites

I am so pleased to be responding from within a fully operational dual-boot system!


I thought I was hooped for sure, but the actual situation turned out not nearly so bad. I got both Gparted and Ultimate Windows Boot CD, they helped me out but mainly as a temporary environment to get more info.


Main problem was that using OSX Disk Utility recover command to copy the working OSX installation from USB key to partition, made that partition active. New concept for me... next, I had the Maxtor SATA-2 hard drive hooked up to the SIL3132 controller not the MCP55 controller. OSX seems to demand the SIL3132, that has one plug and is basically a RAID controller. The MCP55 controller has 6 plugs and I had installed Vista with both hard drive & SATA DVD burner on two plugs of the MCP55 controller and nothing on SIL3132; so, Vista had no SIL3132 driver loaded (and thereby could not access SIL3132 connected device). Two simultaneous problems, it took awhile to figure it out. So I used MbrFix on UBCD4WIN to make the Vista partition "active", then plugged it back onto a MCP55 plug (and plugged the DVD burner onto the SIL3132 controller -- that forced Vista to install the SIL3132 driver, and permitted it to boot). Ahh!!


Well then I updated the Windows Bootloader with the BCDEDIT commands, you know, to add Chain0 to the boot menu. I Forgot To Copy Chain0 Into The Root Directory!!! That was another "gotcha" that took awhile to figure out.


Current status: Vista bootloader successfully permits me to pick whether Vista or OSX to boot up; both work perfectly. If I pick OSX it puts me into the Darwin Bootloader, which will simply go back to the Windows Bootloader if I don't press a key. So I have to scroll down & choose the Mac partition to boot (nobody has figured out a good solution for setting the default partition in Darwin Bootloader evidently). But I'm in the dual-boot club now!!


I got the SIL3132 driver loaded onto the USB key, that let me boot OSX from my SATA-2 hard drive on the SIL3132 contoller and no longer need the USB key.

I got the Realtek 8187 wireless driver & have successfully connected to my wireless router, that permits me to access the internet that I may gloat here :)

I have AppleNForceATA.kext loaded, that permits MCP55 controller (still will not allow me to boot from MCP55, no prob, I convinced Vista to work with SIL3132). Basically gives me the other SATA ports, nothing else.

I got the Azalia Audio installed & have full stereo output, no microphone input.

-Still have to figure out how to activate the on-board gigabit NIC, I read somewhere to try Marvell Yukon but that didn't work.

-Still have to figure out how to activate the 8800 GTS, it sorta sucks to be stuck in 800x600 mode and cannot even run the chess program! Trying to figure out exactly what happened to MacVidia.



Grunchy a.k.a. Jokmar

Link to comment
Share on other sites


  • Create New...