Jump to content

Apple Keyboard Software 1.1


da8ter
 Share

11 posts in this topic

Recommended Posts

Well, I decided to try it anyway and I got the same result as da8ter, blue screen with mouse pointer and the desktop never loaded. I saw something during boot that said "appleHIDKeyboard.kext no kernel dependancy" or something to that effect. Dunno if that helps anyone.

Link to comment
Share on other sites

I am having a similar problem; hoever I have updated to 10.4.10 incldung the kernel and the 1.1 keyboard update. Booting with the new keyboard connected results in a hang right before loading AppleYukon.kext. I see some IOResource XML as the last printline. If I boot with the previous Apple kbd and swith once I log in, the new one works including the media keys. Any ideas would be welcome.

Link to comment
Share on other sites

As an update to my earlier post, it turns out that I can boot with the aluminum Apple keyboard using the following workaround on my dual-boot system:

 

1. With the new AKB plugged in, boot and select my OSX boot.

2. While the 5 sec timeout I have set for options runs, unplug the cable

3. Once the login screen appears, plug in the cable and log in

 

Everything works at that point.

Link to comment
Share on other sites

  • 4 months later...
As an update to my earlier post, it turns out that I can boot with the aluminum Apple keyboard using the following workaround on my dual-boot system:

 

1. With the new AKB plugged in, boot and select my OSX boot.

2. While the 5 sec timeout I have set for options runs, unplug the cable

3. Once the login screen appears, plug in the cable and log in

 

Everything works at that point.

 

 

It seems AKB doesn't support the BIOS option "USB Legacy Support".

I disable it and it start to work without plug/unplug, but if you have to dual-boot system with darwin, you must have this option anabled to select the OS.

Link to comment
Share on other sites

 Share

×
×
  • Create New...