Jump to content

OSx86 Installation on Acer Aspire 3680


11 posts in this topic

Recommended Posts

Hello everyone, I have finished reading the rules and also finished looking through 24 pages of searched pages on the forums.


Currently I am using the "Mac OS X 10.4.9 Intel SSE3 [JaS 10.4.8 AMD-Intel-SSE2-SSE3 with PPF1 & PPF2.iso + JaS.10.4.9.Combo.Update.Intel.SSE3.zip" iso.


I burned the iso image on a Princo 4X dvd. I burned it using ImgBurn at 4x speed. The image works fine since I installed it on my desktop's VMWare.


The problem is that im trying to install it on my Acer Aspire 3680 laptop and after it displays the following error messages, it displays the light blue screen, then it shows the language selector. I choose english and after that it says "Preparing Installation" after that it just says system halt and powers off. The first time I tried the DVD it just said system halt. Then the second time I tried the DVD it went up to the light blue screen and after 30-40 minutes of just being there and the rainbow cursor spinning , it said system halt. Then the third time I connected a external display ( my LCD ) and the Mac OS X language selector came out, then after preparing installation , it said system halted. The same thing happens if I don't use the external display but I boot using the -x parameter.


Error Messages


BSD Root: disk1s3 major 14, minor 5


Warning: 256 sector(s) in last cylinder unallocated disk 3 256 sectors in 1 cylinder of 16 tracks, 32 sectors 0.1 mb in 1 cylinder groups ( 16 l/gi) 4.00 mb/g, 32 i/g)


Crash Reporter


SAM Multimedia: Read or Write Failed, ASC = 0x11 , ASCQ = 0x00

disk1s3: I/O Error

Aug 6 10:35:35 localhost configd[31]: No airport driver found


SAM Multimedia error again 6x displays then disk 1s3 error happens..

this keeps reapeating then it says :

Aug 6 10:37:08 localhost diskarbitration [33] : unable to mount /dev/diskos/ status code ( 0x00000047 )

disk1s3: I/O Error

/private/var/tmp: optimization changed from time to space

Aug 6 10:37:29 localhost configd[31]: Error: copyAirportsprefs ref can't commit preferences: No such key


Then the SAM Multi.. comes up 7x then disk1s3 again , then SAM Multi.. 5x more then it repeats same thing with disk1s3 and SAM then light blue screen with the cursor comes, the cursor is a arrow and its black, few minutes pass then it turns to a spinning rainbow ball, then turns to a black cursor then starts spinning, then language selector appears, then preparing installation appears, then it halts and powers off.


I also tried to remove the atheros card and start the installation with the VGA attached and it still failed.


System Specs


Pasted from the wiki ...


Aspire 3680

  • OS: JaS 10.4.8 SSE3 with (Jas Patch 10.4.8 from 10.4.6 Goat)
  • Intel Celeron M 1.46ghz (shows unknown processor), 512mb DDR2, 60GB ATA
  • Intel GMA 950 shared mem @ 1280x800x32@60. QE/CI Working with GMA patch
  • Lan Atheros wireless fully working as Airport after changing to en1 from en0
  • Sound ALC 883 working with kext edit 2ch output only. Full software control of volume
  • All USB + trackpad working
  • PowerBundle.kext to enable battery meter + management
  • Dual Boot OSX+XP using Darwin loader
  • Not working: 5in1 card reader (use XP to access)



  • OS version: JaS 10.4.8 ppf patched - select Intel SSE3, 10.4.4 login window app, GMA 950 drivers, powermgmt bundle
  • CPU: Celeron M 430 / 1.73 GHz (detected by CPU-Z as Yonah core)
    • was advertised by Microcenter & on the box as a Celeron M 420, 1.6 GHz - got an extra 133 MHz for free!
    • detected as Core Solo in JaS 10.4.6 & Core Duo in JaS 10.4.8

    [*]MoBo chipset: Intel 945GM Express - all the basics like USB, SATA, keyboard, trackpad, etc. work fine

    [*]Video: GMA 950 - works like a charm (1280x800 on a 14.1" screen), minor color correction under pref panes

    [*]Sound: Realtek ALC883 - works after installing Azalia driver for 2-ch speaker out only

    • Taruga's HDA driver adds more ports but doesn't play out the built-in speakers

    [*]Lan: Marvell Yukon 88E8038 - not working, though others have gotten it working on different laptops (???)

    [*]WiFi: Atheros AR5005G - working after some hacking in the terminal {see/search forums}

    [*]PCMCIA: Texas Instruments chipset PCIxx12 - working after installing hacked driver + glitchman 10.4.8 kexts {see/search forums}

    [*]5-in-1 card reader: does not work, Windows device manager shows it as part of the PCMCIA chipset/interface

    [*]PowerManagement: works fine

    [*]Deep Sleep: like most hackintoshes, does not work (though someone claimed it working in 10.4.7 updated version)

    [*]Dual Boot: kinda tricky - work in progress (lots of guides available on this one)

    • Overall Impression: Can't beat the deal! Paid $450 and could get $50 back if I get around to mailing in the rebate. Everything either works fine out the box or can be gotten to work, except for built-in ethernet--but that can be gotten around by using a USB-to-ethernet adapter or probably PCMCIA card. Deep sleep is being worked on by others more technical than I. The laptop came with Vista basic, but ran like molasses. After installing Tiger x86, it pounces like a monster feline. Battery life seems to be about 3 hrs, depending on Energy Saver settings.

Link to comment
Share on other sites

I have Acer Aspire 3680 (Aspire 3684NWXMi). I installed Mac OS X 10.4.8 using the same ISO image like you.

The error message (refering to your post) before the light blue screen is considered normal. But if after you choose Language and "Preparing installation..." message appear, your system shutdown/halt, I don't know what happen. Maybe there is a faulty at your RAM. Because that time the installation program is trying to copy the installation software/image to your RAM.


I successfully installed at my Acer without any problem.


My spec is:-

Intel Celeron M processor 440

- 1.86 GHz

Mobile Intel 940 GML Express Chipset



1.5 GB DDR2

Atheros AR5007EG (AR5BXB63 chipset) - wireless device

Marvell Yukon 88E8028 Fast Ethernet - lan


My Atheros wireless and fast ethernet is still not working. I'm using USB wireless device right now for temporary solution.

Link to comment
Share on other sites

Nope, It can't be my ram because this RAM is brand new. The ram that I use are 2x identical DDR2 RAM. Maybe it's my dvd.. but that would be weird since I installed it successfully on vmware.



Emmm... Just a suggestion, maybe you can try boot your installation DVD with just one DDR2 module.

Just see how it goes. I also don't think your RAM is faulty. Acer sometime give different result when you're using OS other than windows.

Link to comment
Share on other sites

Alright after I removed 1 512 RAM it worked, but it wasn't working well with the JAS cd. At first it went quickly through the verbose mode , entered the installation.. when i clicked disk utility it opened up and said "gathering disk information" and then it closed... so I tried the uphuck cd that I burned, and after several tries with the uphuck , it worked :). The laptop has sound through the speakers but if i plug in the headphones it doesn't work. It has usb support. It doesn't have internet support. Thanks.

Link to comment
Share on other sites

My spec is:- Intel Celeron M processor 440 - 1.86 GHz, Mobile Intel 940 GML Express Chipset, 80GB SATA HDD, DVD-RAM/RW, 1.5 GB DDR2, Atheros AR5007EG (AR5BXB63 chipset) - wireless device, Marvell Yukon 88E8028 Fast Ethernet - lan

To kizwan: I was just wondering how you are running 1.5GB of ram, are they 768MB chips, cuz I couldn't find any?


To everyone:

Also, if I install this on my 3680 with 1GB(2)512MB chips- memory, will I have to remove one to properly install and after install can I put the other 512MB back in & will it run with the full 1GB?

Link to comment
Share on other sites

To kizwan: I was just wondering how you are running 1.5GB of ram, are they 768MB chips, cuz I couldn't find any?


To everyone:

Also, if I install this on my 3680 with 1GB(2)512MB chips- memory, will I have to remove one to properly install and after install can I put the other 512MB back in & will it run with the full 1GB?


I use two DDR2 modules. One is 512MB, another one is 1GB. You can try to put back the another DDR module after you succesfully installed OSX, just see how it goes. My installation DVD is Sony DVD+RW. Emmm.... you said, when you use just one module (512MB), it has problem with diskutility right? Try switch that module with another one, and boot with your installation DVD (JaS). Just to see if you can execute Diskutility.


Edit: Did you try audio driver for ALC883 from this thread:-



Since we have same laptop model and same spec, try above driver. Install with 6 port (the one without digital). Don't forget to untick all option, just tick ALCinject & ALC883_6ports package. You should got built-in speaker, headphone and line-in (external mic).


However, you need to manually switch to either headphone or built-in speaker in Sound Preferences. Troublesome, but it work.

Link to comment
Share on other sites


  • Create New...