Jump to content

Mac OS X 10.4.8 on HP NX6125 ...


25 posts in this topic

Recommended Posts



I try to install Mac OS X 10.4.8 on my laptop (HP NX 6125 - AMD Turion 64 - ATI IXP MotherBoard - BroadCom Wifi 4318 - BroadCom Ethernet 5788 - ATI Radeon 200M).


The installation is Ok and Mac OS X boot perfectly after some customization (http://wiki.osx86project.org/wiki/index.php/HCL_10.4.8/Portables#NX6125).


But i have some problems.

- my wifi card is recognized (interface en0) but MacOS GUI don't recognized ... The wifi card works, on first boot he find some SSID. But now, i can't configure it ... have you a idea ?


- my ethernet card isn't recognized... I try to install a driver : AppleBCM5701Ethernet but i have a error :

AppleBCM5701Ethernet: 0 0 start - getAdapterInfo failed, giving up

IOCommandGate::disable() called when not gated

Backtrace 0x397824 0x23f4f64a 0x3bc49c 0x3bc56b 0x38beff 0x38b703 0x38ce48

Kernel loadable modules in backtrace (with dependencies):


dependency: com.apple.iokit.IONetworkingFamily(1.5.0)@0x23a34000

dependency: com.apple.iokit.IOPCIFamily(2.1)@0x1f707000


Dependency is ok ... but it dont work :-(


- Concerning ACPI and Battery, on installation Mac OS find sector and level of battery but after reboot, it don't find this information ... :-(


I search all information, documentation, examples and any idea ... Thanks for help :-)

Link to comment
Share on other sites



Maybe we can work together... trying to convert my nx6125 to a HackMacBook as well...


Right now I am stuck before even getting it on the disk: when installing from a 10.4.8 Combo-DVD, no suitable HD partition is recognized... any idea how to get past that step??

Link to comment
Share on other sites



OK, you have a free partition on your disk ?

If you have a Linux or Windows, try to use fdisk command to create a partition and use "AF" for type of partition.


Or you can use a assistant during the installation (Partition or Disk Utilities, I think), you can find it in top menu.



Link to comment
Share on other sites

Thanks mate!


used an old hd, and for some reason mackie did not like it...

Worked with a different one.


Now it is running, but quite some stuff does not work and overall the speed is horrible....

Its a rather fast machine under XP and Linux ( I have the Turion model), but seemingly I will have to work through a lot of forum posts, hints and tweaks before the performance is ok under OSX.... will post results as I get them.

Link to comment
Share on other sites

OK - some updates, perhaps useful for someone else trying to convert this notebook...


Using 10.4.9 AMD from Corvinus (http://x86-hackmac.foren-city.de/forum,15,-filebase.html)


runs smoothly, wireless just needs the dev id added, boots from USB or internal, even the special keys for volume/mute etc. work, but so far no luck with:



Broadcom Gigabit Ethernet ( I have a 57xx, Vendor ID 14e4, Device ID 159c): worked through some of the Broadcom threads here, added the dev id to Info.plist, but nothing at all happens...


Cardreader (SD/MMC): just does not anything at all...


PCCard/ExpressCard-Slot: no PCMCIA Cards are recognized at all...


Fingerprint Reader: it is listed in the profiler - but is there any Mac app that can make use of this toy?? And does it actually work or is it just reported as existing USB device?


Biggest problem for me: looks like ACPI / fan control / CPU speed control does not work. The fan is ALWAYS on, air is hot, so the CPU (Turion 64 ML 34) is running at full 1.8 Ghz... Are there any Mac tools like RMClock under Windoze to regulate the CPU speed? Or WHERE should I look on the Mac.... I am used to Linux stuff, where the fan stuff is in /proc/acpi/fan/Cxxx/state and can be switched manually by writing 3 or 0 in there, but where is this kind of stuff on OSX ????


Any hints appreciated.

Link to comment
Share on other sites



Concerning the problem of Ethernet driver :


>sudo -s

> cd /System/Library/Extensions/

>ln -s IONetworkingFamily.kext com.apple.iokit.IONetworkingFamily.kext

>rm /System/Library/Extensions.kextcache

>rm /System/Library/Extensions.mkext

>chown -R root:wheel /System/Library/Extensions

>kextcache -k /System/Library/Extensions

>and reboot.


Patching with Hexeditor : (file : BCM5701 in folder ressources)


> Find: "66 81 FA 59 16" /Replace with: "66 81 FA 9C 15"

> Patch on hex line 37336 from "66 81 FA 59 16" to "66 81 FA 9C 15".


Finally reboot ... Normaly it works ! :-)



About CPU & Fan problem, after adding a extension Mac OS recognize battery but that's all ... He didn't manage CPU throttling ... I have found a software (SpeedIT) but doesn't work ...

Perhaps a solution exists ...


Concerning Cardreader, PCCard and Finger Print, i have no idea ....

Link to comment
Share on other sites

Ah, I see, together we will convert this good ole HP lappy... *lol*

Thanks for your support!!


In exchange I have a hint as well:


Speedstep/ACPI solved - kind of...

This one really helps:




Problem is: with the AMD version there is a known bug that (sometimes - not always) causes stuttering on audio playback or videos - depends on your config.

But working is possible and much more quiet. Battery lasts longer as well. There is also a tool to change the speed manually.



Will try your HowTo on Ethernet, I just gave up on the 746 messy old threads on that topic... ;-)


I found some kext for the Texas Instruments bridge (PCCard), but - well - Kernel Panic... next try. Probably wrong memory range or something like that...


We keep trying... ;-)



P.S.: did you manage to get Quartz / 3D / OpenGL working on this crippled ATI that we poor suckers have??

Link to comment
Share on other sites

hmmm.... resolution is fine already, I have the XGA display anyway... but need OpenGL support, otherwise OS X is dead for me....



Network did not work out - looks like the file has changed since 10.4.8 ( I have 10.4.9 running here), so the string was not on the line that you told me - I just replaced them all, *lol* - and he still tells me about an unknown card... *grrnnnmpf*


OK - for today I will power down notebook and myself... ;-)

Enough trial&error for one day...

Link to comment
Share on other sites

Hey there. I'm running the same machine (nx6125) and would like to try to get a copy of osx86 loaded. I'm not used to patching and hexediting things... i don't even use linux, but I thought that since all of you were trying to accomplish the same thing, maybe one of you could summarize what you've done thus far so that I can get the most amount of features working properly. Presumably I need to burn out only the MACOSX 10.4.9 files located here: http://x86-hackmac.foren-city.de/forum,15,-filebase.html right? I tried on old copy of JAS 10.4.6 but I couldn't get past the mac installation screen. When and how should i modify resource files? Thanks ahead of time! -SD

Link to comment
Share on other sites

Hi David,


I have installed with JaS version 10.4.8. It works but you need to patch the ATI IXP ATA driver at least ...

Perhaps, Uphuck releases include more drivers ... and is more usable for newbie...


Good cheer ! :unsure:

Link to comment
Share on other sites

-evanlugh - Thanks for the reply. I've downloaded the image and was wondering which patch selections to make in the custom install? Presumably AMD10.4.9, AMDSSE3 need to be installed, but which other options need to be selected? Thanks for doing your part to help out the n00bs.

Link to comment
Share on other sites

Well, the 10.4.9 uphuck v1.3 worked very well. I got everything to sorted with the patches provided in this release. The wifi, usb, audio card(azalia) w/ volume controls and even a nice 1400X1050 (Callisto 3) work very consistently. Have any of you tried the DCPU manager to speed step the processor? The fan was driving me crazy, so now that's fixed, but the performance is sluggish. Itunes skips and it's frustrating. Have any of you guys any tips on improving my speed? I'm maxed out on ram (2gb at the moment). Also, have you guys any idea on how to adjust the color profiles or calibrate the monitor? These features aren't working.

Link to comment
Share on other sites

  • 3 weeks later...

This question goes for those who are using the Uphuck release.


Can you post a detail of wich items wehre selected at the install?



I have the same notebook and i really can't manage to get working the LAN.



Thank you.



I have tried the kexts posted here but the system don`t recognize it.

Link to comment
Share on other sites


  • Create New...