Jump to content

Bootcamp Apple Drivers installation errors


2 posts in this topic

Recommended Posts

I originally had bootcamp v. 1.1 installed on a windows partition.

recently I wiped my windows half, and reinstalled it with windows XP SP2.

Now I want to install the latest version of the drivers, v. 1.3


However, whenever I try to instal the drivers, halfway through I get the following error message:



Cannot instal this Hardware



There was a problem installing this hardware

Apple Trackpad


An error occured during the installation of this device

Fatal error during installation.



Click Finish to close the wizard


Here is a screenshot http://img257.imageshack.us/img257/6168/bootcampbugqv2.png (desktop blurred for privacy)

The same thing hapenes to me with the Apple keyboard driver, and the apple remote.


Also at the beginning of the installation it gives me the 'found new hardware wizard' window for the isight, which I close, and then I get the same error message for the isight camera.


not surprisingly, the keyboar's special features like the eject key or the function-brightness etc. keys don't work, as well as the isight, or the trackpad's scrolling/right click abilities.


Could you please tell me if there is some file I could delete or manually copy/edit so that these installations, of the keyboard and the trackpad, would work?


I've tried Uninstalling with add/remove programs and i've used the bootcamp drivers CD to remove all the drivers, but every time I try installing the drivers again, it gives me the exact same errors.


I use a 1.83GHz 15 in. Mac Book Pro


Also, I use Parallels 3.0 on my mac side, running my bootcamp partition. could this have anything to do with the driver installation errors?



Link to comment
Share on other sites

Even with parallels, you would still need the drivers from Apple via boot camp 1.x (now 1.3). I don't know of any other way to get the correct drivers to XP. When you install your XP system in parallels, I assume after you come up with XP, you would run the boot camp 1.3 drivers CD you created on the mac side.


I also don't know why you would get the errors you have unless somehow XP got corrupted during the install. You might try blowing away the entire parallels install, create a new one and laydown XP again or Vista. Before the 1.3 bootcamp there were always come pieces of the hardware that XP saw but Apple didn't have a driver for and you would get errors in device manager yellow! by them. With the 1.3 version of boot camp from what I can tell, all of these yellow!'s are gone, there are a few pieces of the hardware in the System Devices tab of device manager (ACPI listings) you have to enable after reboot. I enabled these and for the first time have a clean listing in Device Manager. I am running the 1st gen MBP, 2.13 from July of 2006.


Paul C

Link to comment
Share on other sites


  • Create New...