Jump to content

WLAN USb dongle ZD1211 drivers? [FIXED]

2 posts in this topic

Recommended Posts

Hey, I'm new here...I've kinda searched abit but I can't find a specific answer to my problem, though I saw an old thread with a similar issue so I thought I'd ask here!



So I just bought a replacement router (Philips SNB5600 :)) which happens to be wireless and came with a WLAN USB dongle (SNU5600). I've been thinking about going wireless with my mac mini (G4 ppc) so I can move it to my room, but I didn't want to fork out on an airport card just yet as I'm a poor student!


The wired network is all fine and dandy (as I'm obviously using it now), and I can see the wireless station from my Dad's XP laptop and Dell PDA. The laptop connects to the network and internet, but the PDA doesn't, though I haven't had time to mess around with any settings there. So I know that the wireless part is functioning ok. The network is unsecured at the moment while I get things set up.


Ok, so I googled and found that the chipset in my dongle was the Zydas ZD1211, which luckily was the widest supported chip. Downloaded the driver and followed This site to get it set up. Pretty easy to follow, although when I replaced the product and vendor Id's, there weren't any similar values, so I just replaced the last one. Also, the id for my device read 0471:1236 from the list, which I converted to decimal as per the instructions. However, most of the other vendor id's were clearly hex, whereas mine could be either. Could it be possible that my device happened to already be in decimal, or is that silly?

I got the information from the link on that site with the list of supported drivers btw.


Right so, restarted, plugged in the device and opened system prefs: new device found! This was much easier than I thought it'd be...


the WLAN setup program launched and...no networks found :)I later found out that there's a bug with PPCs where if you unplug the device it won't function


Turned on today and it picked up my network easily and would connect to the network, but in network settings in system preferences I can't acquire an IP using DHCP and I can't actually access the network. On the router setup page it only list one dchp client at the minute, and that's my mac through the ethernet port. Could there possibly be a conflict when I'm trying to connect twice? The screenshot attached shows what I can see, which isn't right when compared to this:




which I found in a different thread here.


It may even be the router's fault, not the mac! I don't know enough about wireless networking to really troubleshoot my settings yet!


Cheers, hope I can find some help!



edit: the PDA works fine now too, so it's most probably a problem with the driver :S


edit2: Ok, I fixed it now! Sorry if anyone posts a long reply! I reinstalled but put both the value that I thought was hex, and the converted values in and it worked first time :D I also updated to 10.4.10 at the same time, so could be either :)


Link to comment
Share on other sites

You should install driver then plug in the network dongle and then goto preferences network

and a popup should come up tellin you new network adaptor en1 set that

and to get ya ip i unplug then restart machine reset ya modem router even

Link to comment
Share on other sites


  • Create New...