Jump to content

Cloned osx does not boto correctly


armandckj
 Share

3 posts in this topic

Recommended Posts

Hi all,

IDE disk (hda) single partition 10GB with OSX as master works. And i mean everything works.

Sata disk 80GB with Linux.

Sata disk 80GB partitioned (linux terms) sdb1=3GB home, sbd2=extended (sdb5=1gb (outer rim of disk) swap, sdb6=60gb linux raid), sdb3=10GB (inner rim of disk, low cilinders) OSX.

The system boots with Lilo as a boot manager.

 

IDE OSX runs 10.4.6 as only then i have QE/CI for my ATI 9600SE AGP and P4P800 E Deluxe (Intel chipset).

When i dd tiger-x86-flat.img from Linux to sdb3 i have a working 10.4.6 6GB setup which i can select through Lilo.

So my hardware/software combination is compatible.

 

sdb3 is 10GB large and i want to clone IDE OSX to that disk as a test installation

I installed Opendarwin (10.4.0) on sdb3. I can boot it with Lilo.

I deleted all files on sdb3 (rm -r).

Cloned IDE OSX with various tools (ditto, Hatchery, CCC, superduper) and that proces goes ok.

 

When i boot of sdb3 10GB i get stuck in the grey screen with apple but no spinning logo.

Using -v to see what is happening i notice that the sdb3 boots, start loading kext in vga mode and when it moves to svga (still in text mode but with smaller letters) it stops. No hard disk activity but the screen is active but black. Strange as this software setup works on IDE OSX and the hardware works with tiger-x86-flat.img.

I removed Callisto, AGPGart, ATIRadeon9700* but still get the same problem.

 

Got a hint how to get this working?

It amazes me that is does not as the partition (sdb3) is ok through dd and OpenDarwin and the software/hardware combination is ok.

 

Regards

Link to comment
Share on other sites

i tried with Hatchery method, and it worked perfectly for me.

make sure to select "bless" option otherwise your clone will not be bootable.

after cloning, go to sys prefs and see if you have more than one boot disks listed in "startup disk".

 

repeat, Hatchery method works, but you have to download the newest version and the "hackintosh script" made by the author.

also, you have to choose "hackintosh" on the drop-down menu inside the Hatchery program.

Link to comment
Share on other sites

Thanks,

As i said it boots but does not complete the booting. So the folders are blessed.

10.4.6 does not have a good "startup disk". Nothing shows in that setting.

 

The only difference is the Darwin boot loader. IDE OSX has version *.0.132 and OpenDarwin (sdb3) has *.0.122.

 

Any new clues?

 

Regards

Link to comment
Share on other sites

 Share

×
×
  • Create New...