Jump to content

Need help on removing Geforce.kext


4 posts in this topic

Recommended Posts

I have been having a lot of trouble getting OSX86 to work on my Asrock 939Dual-sata2, more specifically I can't get the OS to boot all the way into the login window after installing. Jas 10.4.6 worked on my machine, but Titan only works with 10.4.8. I've tried both Jas 10.4.8 and uphuck 10.4.9 v1.3 and keep getting stuck at the point where the OS is loading the login window. I'm pretty sure that this is related to Geforce.kext and NVDAresman.kext because these seem to load only in versions of OSX86 after 10.4.6. I think that If I can just disable these kexts i can get OSX86 to boot.


My graphics adapter is a Geforce 7900GS PCI-E and my CPU is an Athlon 64 3200+. If you need more info, just ask. Thank you anyone who can help.

Link to comment
Share on other sites

I had the same problem with JaS 10.4.8 and uphuck 10.4.9 v1.2


Im now using uphuck 10.4.9 v1.2 (not 1.3 but i guess it will work also with 1.3)

At first: get the correct dev-id for your card (mine is 00c1, GF6800)

during install: choose TITAN and install osx.

when the installation finished and the system reboots for the first time, dont boot into aqua but boot into single user mode (-s).


you will need to edit 3 files and put your dev-id into them: GeForce.kext, NVDAResman.kext and NVDANV40Hal.kext .

To do this: navigate to /System/Library/Extensions


nano /GeForce.kext/Contents/Info.plist


navigate to <key>IOPCIMatch</key>

<string>0xXXXX10de&0x0000ffff</string> where XXXX should be 4 numbers.


Replace that numbers with your Dev-Id,


Strg+O to save changes,

Strg+X to exit nano


Do the same with the other 2 kexts,




Now you should be able to get into normal osx and have a full supported Graphic Card with QE/CI enabled. You can change the resolution in System Preferences.


NOTE: my card has 256mb RAM, i don't know if this works with cards of 512mb because there are problems with cards with 512mb or more RAM.

But if you have less than 512mb you should give it a try.


Hope that helps,





Link to comment
Share on other sites

Awesome, that did the trick. I'm posting from my 10.4.9 now. I've got CI and QE at 1440x900 resolution. I've just got to get the sound and ATA working and I'll have a fully working installation. Thank you so much for your help.

Link to comment
Share on other sites


  • Create New...