Jump to content

install JaS 10.4.7


24 posts in this topic

Recommended Posts

hope someone can enlighten me with this installation procedure. let me list out my hardaware list:


mobo : Gigabyte 965P-DS3P

onboard: firewire, marvell lan card, audio realtek

proc : intel core2duo code name conroe E6320

ram : patriot 2GB dual channel

vga : Nvidia 7600GS

dvd-drive: asus 1608P2S

wireless: Linksys WG5411

hd: IDE 20GB Seagate


got my dvd installation 10.4.7, first thing first is when the installation start i should select costumize. i skip the language translation and there are option 10.4.7 patch also SSE2 patch option and SSE3 patch option.


- should i select the SSE3 patch option ? or just skip it ? or skip it both SSE option ?

- i read somewhere in the forum that IDE harddisk wont run with 965P-DS3 series. can I use IDE to USB converter ?

- my dvd-rom also have PATA interface, again should i use IDE to USB converter ?

- what about audio on-board ? is some people manage to work with it ?

- is Marvel LAN on-board working good as well ?

Link to comment
Share on other sites

since no one is anwer, then i have to digging...


here's what i found : http://forum.insanelymac.com/index.php?sho...=28439&st=0



physical hardware set up:

connect your SATA HD to purple SATA on your mainboard

connect your DVD using USB enclosure for HDD (use your creativity :) ) connect the wide ribbon wire to the DVD and hook up the USB to your PC

edit your BIOS :

go to “Integrated Peripherals”

Set “Sata Port0-3 Native Mode” to “Disabled”

Set “Onboard SATA/IDE Device” to “Enabled”

Set “Onboard SATA/IDE Ctrl Mode” to “AHCI”


power on

press F12

choose USB-CDROM

press F8 when you see it text on your screen with countdown message

type -v [enter]

install using customize (dont just press next, next, next)

choose JaS Patch Update, SSE3 support. the rest is up to you


to be continue...

Link to comment
Share on other sites

after you successfully see the mac screen and ended up on Desktop, do this :


credit to -> thedguy, ConroeMac, SABR and finally the (I assume with a name like Diego)



sudo rm -rf /System/Library/Extensions/AppleHDA.kext
sudo rm -rf /System/Library/Extensions.mkext
sudo rm -rf /System/Library/Extensions.kextcache
sudo perl -pi -e 's/0x31491106/0x2363197B 0x31491106/g' /System/Library/Extensions/AppleVIAATA.kext/Contents/Info.plist
sudo perl -pi -e 's/0x01060100/0x2363197B/g' /System/Library/Extensions/AppleAHCIPort.kext/Contents/Info.plist
sudo perl -pi -e 's/0x10ec0880/0x10ec0883/g' /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/Info.plist
sudo perl -pi -e 's/0x26688086/0x284b8086/g' /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist
printf '\260\376\346\144' | sudo dd if=/dev/stdin of=/mach_kernel bs=1 count=4 oseek=578235 conv=notrunc
sudo diskutil repairpermissions /
sudo kextload /System/Library/Extensions/AppleAzaliaAudio.kext
kextcache -k /System/Library/Extensions/


Open a terminal, and type "nano audio-restart-fix" and paste the above code into it.

Press "ctrl+o" and then yes.

type "chmod a+rwx audio-restart-fix" and then type "./audio-restart-fix"


The restart fix won't work until the osx has rebooted. So finish anything else you want to do (like install video) and then shutdown, and turn the system back on, you should be running fine.


You should now have full functioning IDE support. (haven't tested yet and it will be my next issue)


I still using the 1st hardware setup


Next is setting up your Marvel LAN card...

credit to -> Zulu.Walker


open Terminal (again)


sudo nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon.kext/Contents/Info.plist
search for "8053" (no quotes) and replace with "8056" (no quotes)
search for "4362" (no quotes) and replace with "4364" (no quotes)



Link to comment
Share on other sites

is the code up there just for IDE or is it something else too? because it says "audio-restart-fix";


audio is exactly what im looking for right now; do u have any suggestions where to get realtek audio drivers and/or radeon video drivers from (the one im using only supports 1024x768 and i want some more ^^);


my sound is onboard; the audio utility that was included with the JaS extras didnt do the job as it seems;




Link to comment
Share on other sites



in this article, I only talk related to the hardware listed from my 1st post. try to dig this forum related to your mainboard and you'll be fine. the code that i listed is combined fixing the auido, ide, and restart issue. i'll try to look it for you while i dig. just check in this thread, hopefully i'm lucky enough


found it !



Link to comment
Share on other sites

hmm... im giving up installing 10.4.7

got JaS 10.4.8 installer with 8.8.1 semthex kernel i'm able to install and run my osx86.


got problem after twice boot after install and what I do is just press the magic button, reset and still put the installer inside the dvd drive.


my screen looks nice :)

no audio, no ethernet yet, and no wireless yet. this gonna be my next issue. btw, i blew up 1 80GB SATA disk :(

Link to comment
Share on other sites

so far so good now. I manage to get the ethernet working. using the method that i was posted previously in this thread. the next thing, i dont need to fix the restart problem. after all installed, i put my hdd to the orange SATA port on my mainboard.


audio fixing is mostly no brainer. just use the method posted by Rammjet in here http://forum.insanelymac.com/index.php?showtopic=18642


download the .mpkg given by skippy and install with an option 6 port-no digital and restart. hmm i also deleted the AppleHDA files.


as a summary :

installation is done with properly Nvidia driver, Ethernet driver by modifying it, Audio by skippy driver.

thanks to all ( i cant mention all of em) for your hardwork in making my pc works like a real mac


next issue is my PCI Linksys WG5411 (it works once with JaS 10.4.7 with Wireless Solution Option) and I will post some screen s capture

Link to comment
Share on other sites

okay now! i have mis type the WG5411 it should be WMP54GV2 (version 2) with a broadcom chipset in it. what i do is follow the step-by-step from DrJohn at Omigili Forum


but i skip change the /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and wow! its working fine ! maybe this is the time to post some picture.


about my mac



Link to comment
Share on other sites

very very cool; i downloaded 10.4.8 as well; although i got 7 working once; downloading 9 through apple update ruined everything agen :P


so now im in 8 running the installation at the moment and its taking ages; the JaS hardware support list seems quite promising;


keep the issues coming :D


p.s.: no dock in the screenshot wtf? ^^



Link to comment
Share on other sites



JaS 10.4.8 SSE2 SSE3 is working very good with my spec. also im hiding the dock and using a genie effect. btw, my IBM PS/2 keyboard also work out of the box. will post some of the screenshot.


next issue to be resolve is slow SATA disk performance

Link to comment
Share on other sites

finally got the SATA working and its incredibly different!


here some of pics of my osx86 that proof the different




this next pic is to show the audio with 6 port enable (not sure with the digital port)




pic that show 2 available network on my osx86 (connecting to the outside world... :wacko: )




last is the display properties in system preferences



Link to comment
Share on other sites

well basically i cant share any photo material but the circumstances are simple; i installed it multiple times; i either get an epileptic colorful screen right after the boot screen


(first i installed both nvidia and ati drivers which i thought was not such a good idea so i repeated it with just the ati drivers but no change)


that would make every single human being go mad after looking at it for too long or i just get a black screen without anything going on but still the HD-LED is on all the time;


so i cant do any diagnostics of course because the only thing i could do differently would be changing the setup of the checkboxes before the installation but it always takes so long to finish the progress it drives me nuts ^^


any suggestions? as i said i have an ati radeon (9000 id say) and a pentium 4 and i think it already supports sse3 (maybe u cud give me a hint how to find out; there have been two models of pentium 4 with 2.66 Ghz whereas one did have sse3 and the other didnt)


so thats my story; hope u have a good laugh :P




Link to comment
Share on other sites

yea thats the major problem ^^ i could get the specs more easily if i had windows on it;


i found one on the net i think it matches:


- Intel® Pentium® 4 Processor, 2.66 GHz

- 512 MB-DDR-RAM

- 80.0 GB Hard Drive (IDE)


- Stereo Sound (duh ^^)

- 16x DVD-ROM

- 32x CD-RW

- 10/100 MBit Ethernet, 56k Modem

- 2x FireWire, 2x USB 2.0, 4xUSB 1.1, SPDIF out


i got it as a gift because everybody knows i can make use of nearly any computer ^^


wud it be a big problem if i dont have sse3? / is there another way to find out if my cpu has sse3?


thanks so far


Link to comment
Share on other sites

sorry for the late reply. the forum has been down for couple of days :-(

to find out what is your cpu capability and also your motherboard type, you can use cpu-z.


you need also to find out what is your LAN chipsets, audio, and graphic (obviously you have that now).


see this image cpuztb6.png

By juragan at 2007-06-28

Link to comment
Share on other sites

almost a match to my spec... i use asus p4se (via chipset)...

except for sound and vga troubles (artifact, can't choose resolution) everything works...


epileptic color screen during boot?

that's what happened to me too. fortunately i have 2 cheap graphic cards one is geforce400 and one is ati 9600xt vivo.

i just swapped the geforce with ati9600xt and then voila!...

Link to comment
Share on other sites

  • 2 weeks later...

hey there once again;


guess what; i finally got bored of vista on my main pc and since i have 2 physical hard drives in there i decided to get rid of XP and put JaS 10.4.8 on it (update to 9 might follow) and all the basics worked right out of the box ^_^


heres a first taste of my personal mac experience: Picture1_0.png


its quite a powerful pc with an AMD 64 X2 which i might get even more out of if i ever wana grab myself a hold of leopard since its 64bit


for now i can only say this: it took me a bit less than an afternoon to find an nvidia driver for me (MacVidia is the keyword if ur interested) and install it including all the terminal commands for the .kext files to get the full 1280x1024 and as i said everything else just worked (thanks to JaS of course for the sound and the amd support itself which both didnt bug me a second)

but it doesnt stop there; im sure my pc is not as good as a mac pro (duh) but i have a total boot time of just a bit above 30 seconds and the shutdown time isnt even worth mentioning; my bluetooth usb dongle just worked (using a sony ericsson as a remote control without any setup problems, wasnt in use on the screenshot though); even my cardreader on the front panel worked so every time i put a card in one of the slots it just shows up.

im sure u can imagine the rest, the only thing thats bugging me is samba support; i have an external hard drive on my network that can only spread its data on the network through samba but i cant access any samba servers on my network; not even xp computers etc. it says something about a broken alias as if it can find the servers and their shares names but as soon as u want to access them its gone


maybe someone has an idea

i wish u all the best with your PC OS X machines



Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...