Jump to content

Final Cut Studio 2 on a Macbook


6 posts in this topic

Recommended Posts

About a week ago, I got my copy of Final Cut Studio 2. I have been playing around with it on my iMac since then, but I was wondering if it would work on a macbook? In the System requirements page on the apple website, it said Final Cut Studio 2 is not supported by integrated intel graphics processors, but is their any workaround?


P.S Any help would be greatly appreciated!

Link to comment
Share on other sites

I didn't try it, maybe it works, this is the explanation taken from Serial Box v06-2007


Good luck!


For those having less than the minimum requirements, here is a hack to install and use after:


To install:


- mount the "Final Cut Studio" disk

- right-click the alias "Install Final Cut Studio" to show original

- on your HD, drag & drop "FinalCutStudio.mpkg" + "Packages" in the same folder on your HD (to be able to make modifications)

- find the 6 occurences of "minsys.plist"

- modify all these 6 with TextEdit. Examples:

AELMinimumCPUSMP + AELMinimumCPUSpeedSingle = 500 replaced with 1

(make all changes required by your config: CPU, RAM, ...)


After install:


- Dig into all installed applications giving a hardware error

- modify the following file:





Replace with:





if serial is not sticking:

look in the /library/application support/proapps...


there should be one or more files named "Final Cut Pro System ID"

and "Final Cut Studio System ID"...


make a backup of those files and deleted them...


after that launch one of the applications and insert your data and the serial again...

the problem should be solved...

Link to comment
Share on other sites

  • 4 months later...

Installing FCP without minimum requirements!


I have a 450mhz G4 Sawtooth mac which I have installed a Sonnet 1GHz upgrade CPU onto (and an ATI Radeon 9800 Pro videoCard)

I installed Final Cut Studio 2 ok, but it wouldnt let me Run Final Cut Pro. It gave me a warning saying I did not meet the reccomended requirements, and then would quit after I said to run it anyway. Motion would work however.


Playing with the Info.plist didnt work for me, so I went into the MRCheck Pro and edited out some code, which worked!. Anyway here what I did.



- After install, Right-click & show package contents of Final Cut Pro Application

- open the following file with TextEdit:



Do a search for and delete the following:

The foum doesnt seem to let me post the string of text... but it starts with:






Link to comment
Share on other sites

  • 2 months later...
  • 10 months later...

So I had the same problem with my new Macbook

I have a 2.1G Processor with 2GB ram. I installed only final cut and DVD studio pro.

When I tried to launch the app, I got this message:

Final Cut Pro reccomends that you have a quartz extreme capable video card.


After reading Chrismo's post above, I went looking for this string of code to edit.

It was perfect until I got to the MRCheckPro.bundle.

I didn't know how to open it (now i realize i should have opened it with text edit)

so I removed it from that place and dropped the whole thing on the desktop


Now launch Final cut and all should be well with the world.

I am about to update from 6.0.1 to 6.0.4 or whatever the newest ver. is.

by keeping the file and not trashing it, if I have trouble updating the app. I can put it back for the update, then remove it again later.

Hope this helps someone as much as it helped me.




OKAY after updating to 6.0.5, it installs another MRCheckPro.Bundle file in the same location.

Remove it and your good to go.

DO NOT DELETE THIS FILE, you will probably need it for udating later.

Link to comment
Share on other sites


  • Create New...