Jump to content

Please Help, ACPI problem


4 posts in this topic

Recommended Posts

My Hardware specs:


intel D946GZIS mobo with GMA3000

pentium dual core 945 3.4ghz

seagate 160GB harddisk



OSX86 doesn't boot(i tried all versions), it hangs after waiting for boot uuid line


I tried all boot options , bios settings but no use.


It is showing " ACPI state [s0 s4 s5] (s3)" . ACPI state is s0 on systems that boot correctly, but here it is "s3" which is suspend to ram . I think problem is here for hangup.



when i booted with " -v debug=0x144 io=0xffffffff" , it hangs at "Registerng IOservice ....(AppleACPIPCI).." on PCI bus.


It always hanging at AppleACPIPCI operations.


So, disabled AppleACPIPCI.kext in AppleACPIPCIPlatform.kext/Contents/Plugins then


osx enumerated device tree correctly (DT plane) but since i disabled the AppleACPIPCI, drivers


for pci bus devices are not loaded in service plane.


hence no driver is loaded for hard drive (and PCI bus devices) so " Still Waiting for root device" error.


I think patching AppleACPIPCI may solve this problem.


please help me , i think solution to this problem will help many people who are reporting


hangup after "ACPI State" line.



please help , thank you very much.

Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...