Jump to content

-iCE!HACKER-

Members
  • Content count

    70
  • Joined

  • Last visited

About -iCE!HACKER-

  • Rank
    InsanelyMac Protégé

Contact Methods

  • MSN
    Grrr
  • Yahoo
    deepakramkumar

Profile Information

  • Gender
    Male
  • Location
    Earth
  1. @muitommy @blackosx just got a copy of Lion GM would like to install it can i get some directions pls. TIA
  2. What model make are you using can you post your files. also remove caches sudo -s rm -r -v /System/Library/Caches/com.apple.kext.caches/* @helob What version / trunk are you trying to compile
  3. @tetris101 use efi string for you graphics card in com.apple.boot.plist <key>device-properties</key> <string>6c0200000100000001000000600200000d00000002010c00d041030a010000000101060000010101060000007fff04001e00000072006f006d002d007200650076006900730069006f006e0000002e0000006e5669646961204765466f7263652038353030204754204f70656e474c20456e67696e65205b4546495d22000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000004e00560043004100500000001800000004000000000003000c00000000000007000000000e0000006e0061006d00650000000b000000646973706c617914000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f00640065006c0000001a0000006e5669646961204765466f72636520383530302047540e0000004e00560050004d000000200000000100000000000000000000000000000000000000000000000000000014000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a0065000000080000000000001020000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616322000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c61791c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656e74</string> also add your resolution <key>Graphics Mode</key> <string>1920x1080x32@60</string>
  4. @bigpoppa206 thanks for the input but thats what i am doing => for the error below first install itunes 10.2.2 / or whatever version and then update to 10.6.7 boot from your install usb or original mac dvd and repair disk/permissions Apr 27 00:25:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x101800390-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 Apr 27 00:26:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x10030ec20-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 Apr 27 00:27:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x10030ec20-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 Apr 27 00:28:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x101813ab0-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 => for fixing error below. Navigate to: System>Library>LaunchAgents>com.apple.ReportCrash.Self.Plist . Copy the file: com.apple.ReportCrash.Self.Plist . Navigate to: Users/Home/Library . Create a new folder in Library titled: LaunchAgents . Paste: com.apple.ReportCrash.Self.Plist in LaunchAgents . Delete the original: System>Library>LaunchAgents>com.apple.ReportCrash.Self.Plist 08/05/11 9:06:48 PM com.apple.launchd.peruser.501[99] (com.apple.ReportCrash) Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self => for fixing error msg below boot from your install usb or Mac OS X dvd select your startup disk and reboot kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
  5. Hey there Blackosx here is what i did. My setup Chameleon RC5 750 Compiled by blackosx GA-EP-45-DS3L f11 Cartri Bios 4GB - DDR2 RAM 1GB x 4 500GB WD Blue HDD Sata DL-DVD Sony USB Keyboard + Mouse + nVidia 8500 GT 256 VRAM + RTL-8139/8139C/8139C+ (rev 10) Bios Settings are as per Cartri's PDF (Find in Attachments below) My com.apple.Boot.plist , dsdt.aml/dsdt.dsl , SMBIOS.plist , SSDT-0-6.aml.zip/SSDT-0-6.dsl.zip are attached below. /Extra contains IONetworkingFamily.kext , PCGenRTL8139Ethernet.kext , OrangeIconFix.kext , PlatformUUID.kext i have removed all other .kexts from /S/L/E/IONetworkingFamily.kext/Plugins directory -> i use PCGenRTL8139Ethernet.kext cause i have a PCI RTL 8139 card if i use the original /S/L/E/IONetworkingFamily.kext i get { 2490 6e644f74} RTL8139::receiverInterrupt - Rx restart { 2fa4 8d0c2848} RTL8139::receiverInterrupt - error detected -> For this error the solution is to reset nvram and pram since we have none i have no idea to fix it but if you go into System Preferences->Startup Disk and make sure you have the correct volume selected. it seems to disappear for a while kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged. -> sleep works just fine and can wake from usb keyb/mouse make sure you Tick the 'Startup Automatically after Power Failure' checkbox in System Prefs / Energy saver -> for this error com.apple.launchd.peruser.501[80] (com.apple.ReportCrash): Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self Navigate to: System>Library>LaunchAgents>com.apple.ReportCrash.Self.Plist Copy the file: com.apple.ReportCrash.Self.Plist Navigate to: Users/Home/Library Create a new folder in Library titled: LaunchAgents Paste: com.apple.ReportCrash.Self.Plist in LaunchAgents Delete the original: System>Library>LaunchAgents>com.apple.ReportCrash.Self.Plist -> for this error warmd[17]: [fetcher_open_file:936] open("/var/db/dyld/dyld_shared_cache_x86_64") => -1 (errno: 2) i downloaded OnyX > Automation > Rebuilding > Launch Services and dyld shared cache I have four problems. ============== 1st this stupid error. Apr 27 00:25:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x101800390-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 Apr 27 00:26:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x10030ec20-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 Apr 27 00:27:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x10030ec20-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 Apr 27 00:28:26 iCEHACKERs-Mac-Pro com.apple.usbmuxd[22]: HandleUSBMuxDictionary client 0x101813ab0-iTunes/com.apple.iTunes using library usbmuxd-211 built on Mar 23 2011 at 23:17:06, running usbmuxd-211 built on Mar 23 2011 at 23:27:39 2nd i dont see my boot log from the start in console "All Messages" or when i do "sudo dmesg" it starts like 27/04/11 8:20:34 PM kernel RT0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/WDC WD5000AAKX-001CA0 Media/IOGUIDPartitionScheme/Mac OS X@3 27/04/11 8:20:34 PM kernel BSD root: disk0s3, major 14, minor 3 27/04/11 8:20:34 PM kernel RealtekRTL81xxx.kext: NIC identified as RTL8168C/8111C (mcfg=14) 27/04/11 8:20:31 PM com.apple.launchd[1] *** launchd[1] has started up. *** 27/04/11 8:20:35 PM kernel com_lnx2mac_RealtekRTL81xx: Ethernet address 00:1f:d0:8b:ca:0c 27/04/11 8:20:35 PM kernel com_orByte_driver_RTL8139: Ethernet address 00:80:48:53:d4:e5 27/04/11 8:20:35 PM kernel systemShutdown false 27/04/11 8:20:41 PM bootlog[41] BOOT_TIME: 1303915831 0 27/04/11 8:20:45 PM com.apple.SecurityServer[24] Session 0x5fbff962 created 27/04/11 8:20:46 PM blued[42] Apple Bluetooth daemon started 27/04/11 8:20:46 PM VMware Fusion 332101[56] Starting VMware Fusion: and no i am not booting with -v 3rd i am not sure wether speedstep / throteling is working. i am using CPU-i and it shows only one core i tried booting with dsdt=cartri and dsdt=dsdt.aml no diffrence can someone please check my dsdt.aml/dsl file andcom.apple.Boot.plist to just ensure everything is alright 4th would be nice to get a kext for my RTL 8139 PCI card which supports 64-bit kernel Cartri_Mac_Edition_Bios_Manual_v07m_888.pdf com.apple.Boot.plist.zip 2dsdt.aml.zip SSDT_0_6.aml.zip SSDT_0_6.dsl.zip dsdt.dsl.zip
  6. Having some trouble after a fresh installation of OS X SL 10.6.7... made changes in com.apple.Boot.plist and tried the new FakeSMC.kext but my rig did not boot now using the old FakeSMC.kext i am getting these errors. searched but could not find much may be i need a new version of chameleon or/and FakeSMC.kext ps:- hey there blackosx gr8 job 17/04/11 7:30:11 PM kernel ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed 17/04/11 7:30:11 PM kernel ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed 17/04/11 7:30:11 PM kernel ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized
  7. hey blackosx its been long... hope you are doing good... just updated my bios to cartri 0.8 my network is gone on the on board lan. plugged the cable to my pci 8139 and gave me this error 22/10/10 11:26:32 PM kernel { 50 643a6169} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:32 PM kernel { 6dc 3b0057f9} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:32 PM kernel { 6dc 3b0057f9} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:32 PM kernel { 6dc 3b0057f9} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:32 PM kernel { 12c 652e6964} RTL8139::receiverInterrupt - error detected 22/10/10 11:26:32 PM kernel { 12c 652e6964} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:32 PM kernel { 15c 6e657265} RTL8139::receiverInterrupt - error detected 22/10/10 11:26:32 PM kernel { 15c 6e647265} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:32 PM kernel { 150 d0455040} RTL8139::receiverInterrupt - error detected 22/10/10 11:26:32 PM kernel { 150 d0445040} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:33 PM kernel { 6dc 3b0057f9} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:33 PM kernel { 6dc 3b0057f9} RTL8139::receiverInterrupt - Rx restart 22/10/10 11:26:33 PM kernel { 50 312e3220} RTL8139::receiverInterrupt - error detected 22/10/10 11:26:33 PM kernel { 50 312e3220} RTL8139::receiverInterrupt - Rx restart tried this To solve this I've replaced /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleRTL8139Ethernet.kext with PCGenRTL8139Ethernet.kext, repaired permissions with Kext Utility and after reboot got 100% working card. http://www.insanelymac.com/forum/index.php?act=attach&type=post&id=57215 didnt work will try to update it to 10.6.4 Update 1: okay whatever i do i still get the same errors. and i did update to 10.6.4 Update 2: followed ur guide . awesome fixed the ethernet issue. altho using onboard lan if i plug the cable in to my pci lan card gives me same errors Update 3: followed ur guide . Sound card not working. dled ur "10.6.4 Amended AppleHDA for ALC888 v2" guess its LegacyHDA.kext in /E/E or AppleHDA.kext /S/L/E can u post urs here Update 4: Fixed audio 10.6.4 used this for /E/E and this for /S/L/E everything working perfectly. did not try this
  8. @blackosx thanks for the update will check it out as soon as i reach home. still getting perm errors with AppleHDA.kext in /S/L/E folder. havnt much idea on how to fix it. will keep trying. can u please try doing a repair perms on ur SL install if u dont get any erros i would like to have a copy of your AppleHDA.kext from /S/L/E folder too -iCE-
  9. thanks for sharing. btw i removed "NullCPUPowerManagement.kext" and "SleepEnabler.kext" sleep works just fine, shutdown works too but reboot takes about 2 sec extra(can live with that). just have to sort out the rest of errors. it would be nice if you could let me know if arch=i386 ie 32bit gets rid of the .kext errors. thanks again -iCE- NB:- fix for Apr 7 23:30:21 ICEHACKERs-Mac-Pro com.apple.launchd.peruser.501[101] (com.apple.ReportCrash): Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self http://www.insanelymac.com/forum/index.php?showtopic=192563
  10. @blackosx For this Apr 6 22:53:12 BlackSnow com.apple.kextd[10]: Can't load /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/InternalModemSupport.kext - no code for running kernel's architecture. ok if i am not mistaken please try disabling serial/parallel ports in bios to avoid this error. the rest of the errors can be corrected by adding <key>Kernel Flags</key> <string>DSDT=cartri arch=i386</string> HTH
  11. @blackosx Yes my system used to sleep shutdown and reboot perfectly. now i am using SleepEnabler.kext, NullCPUPowerManagement.kext & OpenHaltRestart.kext. the system shutsdown and restarts okay but will not wakeup from sleep. both installations (2xSL) are clean i have 1x1TB and 1x250GB(which i use as tm disk). all i did was install "Realtek Bonjour enabler". after i use "DSDT=cartri arch=i386" i am not getting "no code for running kernel's architecture." Yes i have double triple checked will check again. Cartri's pdf states that serial/com and parallel ports will not be working atm so i have disabled it and have stopped getting the relevant messages. are you running on 32 or 64 bit mode. when i run in 32bit i don't get any of the three errors. With the AppleHDA.kext orignally from 10.6.3 i had no sound at all and patched it with the one in your support files. I followed instructions to the dot in your guide ( which by the way i got me till here) i did try trashing /S/L/Ca* rebooted checked perms still the same problem. If its not toomuch to ask ; our systems are similar except for the graphics card, ram, cpu and hdds. all that matters is the graphics card the one i have is 8500GT 256 MB VRAM. can you please send me your /Extra folder and AppleHDA.kext. i shall try and redo the whole setup again if nothing works out. thanks for all the help this is what i have currently in my /V/C/E/E folder i would like to mention a couple of issues 1. i had when i was installing 10.6 (used 1.07 loader cd and booted with 10.6 retail dvd my 1tb showed up ad disk0 now it shows up as disk1 2. i have some files in /Volumes/Data which have the ownership of user:staff i am not able to access some of them 3. thease are some o/p i am concerned about can u please take a look and tell me if everything is okay -iCE-
  12. ok no matter how many times i repair permissions i still get the same error
  13. ok got it to work 10.6.3 1. used cartri's bios file to update my bios to f11c beta 2. got display string from efistudio and used it in com.apple.Boot.plist 3. used /E/E Disabler.kext, fakesmc.kext, LegacyHDA.kext 4. Got orange icons used OrangeIconFix.kext 5. not able to sleep, reboot or shutdown properly. (will try using SleepEnabler.kext & NullCPUPowerManagement.kext ) getting these errors. no idea on what to do to fix them for this i guess disabling the serial/com port should fix it again no idea on how to fix this finally this is not an error but says it created a prelinked kernel do i have to add this arg~ mac seems to be running a little faster for now except these problems bonjoure seems to be working just fine. thanks for the guide and all the help.
  14. check ur ram do a memtest and see if u are getting any disk i/o errors
×