Jump to content

Quad boot.


4 posts in this topic

Recommended Posts

Hi all,


last time I spend a lot of time trying to make quad boot working on my machine. I thought I can share with this 'pain' with you :) Below you can find what I've done.


At the beginning I've had 4 primary partitions on my HDD:

1. Windows XP

2. Debian GNU/Linux (unstable)

3. NTFS data partition

4. MacOSX


So I've decided to install Vista on 3rd partition. After this I was only able to boot Vista. Darwin BootLoader has gone.


Here are the steps before installing Vista (based on my disk setup, modify to your needs). I assume you have four primary partitions, 1st is Windows XP, 2nd Linux. 3rd clean NTFS, 4th OSX:



- make partition 3 active

- install Vista on 3rd partition

- when installation is finished, boot using i.e. Acronis Disk Director BootCD

- make part 4 active

- boot from linux CD

- reinstall lilo in first block of 2nd partition (boot=/dev/sda2 root=/dev/sda2, I assume you've done this before),

- make part 3 active (fdisk,cfdisk, Acronis...)

- boot from Vista Install CD,

- when installer is ready, choose [Next], [Repair Computer], [Repair and restart]

- boot from Mac OS X Install DVD ('F8' at boot, '-s')

- type 'fdisk -e /dev/rdisk0', 'flag 4', 'setpid 4', 'AF', 'quit','reboot'


System should reboot with brand new Darwin BootLloader with four options :hysterical:


I've used following resources to make it happen:




Thanks to all the good people who keep the ball rolling!



Sometimes it happens that Vista changes its drive letter to D: so there are problems with OS. You have to login to Vista, run regedit and swap C with D in HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices than reboot. After this Vista should be up and runnig again.



Sorry for my english :hysterical:


Good luck to all !!!

Link to comment
Share on other sites

  • 1 year later...

I wanted to let everybody know that I've successfully installed a quad boot system on my Sony Vaio VGN-C140g. Quad Boot includes XP Pro, Vista Ult. OSX 10.4.8, and Ubuntu 8.1.


I used this guide to start off with. http://wiki.osx86project.org/wiki/index.php/Quad_booting



I partitioned like

1 NTFS Primary Partition, (for WinXP) 1 NTFS Primary Partition, (for Vista) 1 FAT32 Primary Partition, (for OSx86) 1 Extended Partition (with the rest of the unallocated space on the drive

I have a 120 gig hard drive which I partitioned


40 gig for xp

40 gig for vista

30 gig for OSX

10 gig for Ubuntu


and installed in that order.


Xp and vista both think they are C: however when you are in xp, vista drive is D: and when you are in vista, Xp drive is D: very nice they way that worked out.


In the extended partition I created a 3 gig swap file for ubuntu with the remainder of the space for the space for ubuntu to use for whatever.


Laptop Boots using Ubuntu 8.1 Grub Bootloader. Grub Automatically found XP and Vista, and I added the OSX option into grub through terminal command line. The entry the works for me is.


title Max OS X

root (hd0,2)


chainloader +1


I also put the chain0 file into my linux document directory, and on the root C: and D: drive, however I can't be certain it had any effect because OS X loaded once I got the menu.lst file correct, and I never mentioned the chain0 file in menu.lst


OSX runs great, I had to use the realtek file located on the forums for the sound. Still no networking capabities of any kind. ( Intel Pro/Wireless 3945ABG/Marvell Yukon 88E8036)

I've not really worked on it too much due to a high load of schoolwork.


I hope this helps some people with their install, feel free to suggest how to fix my network, I've tried the appleyukon kext with no luck (maybe I'm doing it wrong) and I know that my wireless issue is being worked on.

Link to comment
Share on other sites


  • Create New...