Jump to content

Dell XPS M1710 Laptop (Problem with several hardware devices)

11 posts in this topic

Recommended Posts

Hi All,


I have installed MAC OS X 10.4.8 JAS on my Dell XPS M1710 Laptop.

I select the Sigmatel 9220 audio driver under most comon hardware.

The install runs without any problems and I reboot into OS X. I run through the wizard and setup builtin ethernet etc, but when I try to use Safari, I get the message that my network card has no cable inserted. Controlling the MAC address of the ethernet adapter I discover, that it's my Intel Pro Wireless 3945ABG card thats used.

However this is not the only anomaly I have. These are the hardware devices, that are not working:


1. Nvidia GeForce 7900 GTX 512mb ram (ID: 0x029910de)

The card is detected, but will run with a max resolution of 1024X768 and Core animation disabled. the kext file is NVDResman.kext


2. Broadcom 57XX Gigabit ethernet controller (Vendor: 14E4, Device: 1600)

The card is not detected at all, and I have tried all solutions found on various forums, but no luck.


3. Sigmatel 92XX audio card (Vendor: 8384, Device: 7690)

The card is not detected at all. I have tried different solutions from the forums, but no luck.


4. Intel Pro Wireless 3945ABG (Vendor: 8086, Device: 4222)

The device is deteched as abuilt in ethernet, but does not work properly.


As you see I am running OS X, but without sound, network and with limited graphic performance. Not that cool :( .


So if somebody could point me into the right direction, I would be really happy.






Laptop specs:

Dell XPS M1710

Core Duo 2,16 ghz

17" display 1920X1200

2048 mb ram

100 gb hardisk

Nvidia GeForce 7900 GTX 512 mb ram

Broadcom 57XX Gigabit ethernet

Intel Pro Wireless 3945ABG

Sigmatel 92XX audio card

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...



I also own an M1710, and i just cant get it right. Ive tried everything, and still stuck without ethernet(rather important), no wireless(even ordered a so called "working out of the box" dell 1390 wireless card, but not on the M1710), no sound (every version of the HDA patcher locks up my system) and no card reader. Well the last I can do without, but the rest...


so now i've given up hope and moved on to ubuntu (linux)...and guess what... wow everything works out of the box. maybe its a bit more user-unfriendly than osx, but hey at least it works :D .

My next laptop will definitely be an Apple, but for now... :D

Link to comment
Share on other sites

  • 1 month later...

Funny.... :P I have the m1210. Manage to get the NIC, Sound and video to work (no external yet). Wireless...replace with 1390. We Tried installing on Dell Inspiron 6400, no luck...black screen...external monitor reads huge resolutions. I guess some models just give more problems that others. Check this forum maybe it will help...http://forum.insanelymac.com/index.php?showtopic=41775

Good luck bro

Link to comment
Share on other sites

  • 4 months later...
Am I the only one who ever tried to install OS X on a Dell XPS M1710 Laptop??????????????????





I have it on my XPS. Not Wifi, not ethernet. Got ethernet working changing some binary data, but crashes after sometime. So I bought a usb wifi dongle, they will eventually get the Intel 3945abg driver working. No sound at the beginning, got the AppleHDAPattcher1.20 and the codec for Sigmatel 9200, and now I have sound. Graphic card got working out of the box. Also, you can check the Ninvject project. Something else, I used IAtkos, 10.5.1


My Configuration:

Dell XPS m1710

4gb ram

160 HDD 7200

Wifi, Ethernet, Sigmatel HDAudio

NVidia 7900GS, 256mb

Link to comment
Share on other sites

  • 6 months later...

I've got an XPS M170.


I used iAtkos v2i with Kalyway 10.5.3 combo update.


I got my Intel Pro Wireless 3945ABG working by using the iwi2200 driver (install this only after update to 10.5.3 or it won't work). It should show up as an airport card.


Unfortunately that's the only piece of your puzzle that I can solve....


I'm using an nVidia 6800 GO Ultra and I haven't found a way to get it to give me any other resolution other than 1024x768.

Link to comment
Share on other sites

  • 2 weeks later...

The 7900GTX in the M1710 by default does not report the bootstrap (or something) that OS X uses to determine the amount of memory on the card. Windows looks in a different place for the information so the other (oS X used) location was depreciated; you have to flash the card to a different BIOS to put in the missing information and then you'll be able to use Natit after adding your device ID.


The audio patcher works with the correct patch file, that was no problem.


The wireless will just work if you change en1 to en0 in the networking plist.


Sorry for the sparse details but I've been running a real mac for about a year and I don't have all these plist files and such any more. Hopefully this is enough to at least point the Google's in the correct direction...

Link to comment
Share on other sites

  • 5 weeks later...

I have an M1710 and successfully installed 10.4.4 about a year ago, but had the same problems with Intel 3945ABG WiFi, Ethernet and Sigmatel Sound all not working; and so I uninstalled the OS.


It was a real shame as it ran beautifully in all other aspects, felt a lot crisper and quicker than the macs I was using in Uni at the time.


Although I'm going to get an external hd soon and attempt a second go as it seems some of the creases have been ironed out by now.

Link to comment
Share on other sites


  • Create New...