Jump to content

Apple TV acting as a router


10 posts in this topic

Recommended Posts

  • 2 weeks later...

Ok,Maybe I've found what happens.

Tonight I will try this simple hack.

If I plug the cable, the Kernel Event Manager notifies to Kicker that Airport interface is going to turn off itself.

So, the only way that I know is forcing the airport interface to re-turn on.

To do this, I found a tool that is called networksetup and is located here /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/, so, once that the airport is re-turned on, we have to configure, and we can do this, using the same tool with a little help given from this other command /System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources


At this point I should have 2 interfaces up and running, so the only thing that remains is the configuration of the internet sharing. To do this, simply copy System Preferences.app and enable internet sharing in the apple style.


Paper Late, tomorrow, after the ordeal.


Link to comment
Share on other sites

  • 3 weeks later...

any luck??? I just ordered a refubished airport express ($79) after giving up myself. I am an electrical engineer, but don't know mac os x all that well, so coding a hack is really out for me. But i would love to get the apple tv acting as an airport extreme! I'd love to help or test things for you...

Link to comment
Share on other sites

sorry mac-mini, we are talking about the back row OS without OS X on the aTV.


aole: I installed ARD 3 but get this error still:


-bash: /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/networksetup: No such file or directory

Link to comment
Share on other sites

Did anyone have success using:



I tried: networksetup -setairportpower on

And get: You cannot set AirPort power because all AirPort network services are disabled.

I even tried:

networksetup -setnetworkserviceenabled Airport on

But it does not let me setairportpower on afterwards.

At the moment as it seems there is no way to activate Airport, if an ethernet cable is plugged in.


Any hints??

Link to comment
Share on other sites

why do i get "command not found" when I type:


cd /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/networksetup


and then enter:


networksetup -setairportpower on


any help??

Link to comment
Share on other sites


  • Create New...