Jump to content

Intel D945GTP and sleep issue ?!?!


11 posts in this topic

Recommended Posts

Hi, I have an Intel D945GTP motherboard and a P4 945 Core Duo Cpu , since 10.4.8 I have an issue with "deep sleep"!!!, computer don't wake up or freeze, same problem with 10.4.9 so,

I tried many différents kernels and search the forum for a solution but found nothing which help...

some people seems to have this trouble but

Did someone knows where this trouble come from ? and perhaps gets a solution ?

other than desactivate "sleep" on system prefs....


I saw errors messages on boot screen talking about


HPET (activated on bios)


this issue seems to have something with USB or Display...


Thanks for your help ...

Link to comment
Share on other sites

It's a problem in the kernel due to the SSE2 emulator. If you want to get sleep to work then you need to get the latest netkas SSE3 kernel and make sure you graphics card is supported.

Link to comment
Share on other sites

I have the exact same board and have never had sleep/wake working with my ATI X1800XL PCI-E card. Under 10.4.4 - 10.4.7 the onboard GMA950 allowed sleep/wake to varying degrees. I've yet to have any joy with 10.4.8 or 10.4.9 kernel.


See the link in my sig for my efforts to fix this issue.


Finally, give this 10.4.9 kernel a try and see if it helps at all: http://www.hostclip.com/dl/e1f5facfa6fc0e90f00c48538c3fbecb


(I'd put it in as mach_kernel.test or something, and supply that name at the F8 boot menu - dont blame me if your machine explodes).


Please report back your results - having the same mobo i'd be interested to know if it helps. I havent had time to test it myself (too busy with work).

Link to comment
Share on other sites

Thanks munky (and docmac), I have already try this kernel and read your own topic for this issue (with paulicat helps....),

this don't change anything at all on my system, for the moment the only thing I can do is bypass the system sleep to never... my graphic card is the built in GMA950....


do you tried the "fsb=xxx" to see what happend ?


and didn't have this issue with intel 915 based board from 10.4.3 to 10.4.6

Link to comment
Share on other sites

My HTPC Hackintosh (see sig) has GMA900 and runs 10.4.7 - sleeps and wakes perfectly.


I have tried fsb, a million different Natit configs, various combinations of kexts and frameworks... I cant get sleep/wake to work. :)

Link to comment
Share on other sites

did someone try this ? thanks Ahmad !




could someone give me a link outside irc ?


my Cpu is a HEPT, NX and SSE3 if I don't make a mistake (intel d945 dual core)


thanks a lot...


NB; for me system don't wake up after leaving it some minutes, it enter in sleep mode ...not even tried to put it manually in sleep mode...



New kernel and sleep.

by netkas @ 07.05.2007 09:06 CEST

After some researchment, we found that some sse2 modifications result in kernel don't resume

so, I made 2 kernels now - universal(sse2+sse3) with no sleep support and sse3-only, with sleep support (need additional kext, can be found on #appleacpi romm , on our irc network)

Finaly fixed that cpu cores number reading, made some cleanup in this way.

!!! sleep works only on intel-speedstep/amd-powernow cpus !!!


10.4.9 with 8.9.1 update guide.

by netkas @ 18.03.2007 14:20 CEST

you need to have sse3 system for it

1) download kernel, got to irc channel #1049 at irc.osx86.hu

read topic, choose sse3 or sse2 kernel, depends on your cpu. 2) download apple update (for intels) or tubgirl update form thepiratebay (for amds)

3) no more need this step

4) backup you /System/Library/Extensions folder(cp -r /System/Library/Extensions /1048/) , backup your current kernel - cp /mach_kernel /mach_kernel_old , install update, do NOT PRESS RESTART button after it

5) replace kernel with one dloaded before (cp /where/you/unpack/kernel /mach_kernel)

6) recover applesmbios.kext - cp -R /1048/Extensions/AppleSMBios.kext /System/Library/Extensions/ and remove /System/Library/Extensions/AppleIntelCPUPowerManagment.kext . Warning amd users if you have such errors - "using 5242 buffer headers and 4096 cluster IO buffer headers", so you need to use 10.4.8 ACPIPlatform.kext.

7) no more need this step

8) delete kext - rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext - if you will ask that question on irc, i'll kick you.

9) repair kexts permissions -

chmod -R 755 /System/Library/Extensions

chown -R 0:0 /System/Library/Extensions

10) reboot and pray

11) if you have diskarb errors, than boot with -s , mount -uw /, rm /etc/rc.installer_cleanup

12) pray a lot

13) no more need this step for newest kernels, but maybe sometime usable(vmware e.g.) General

Link to comment
Share on other sites


  • Create New...