Jump to content

Sound working, but no 5.1

3 posts in this topic

Recommended Posts

I'm running an ASUS A8N-SLI Premium. Onboard sound is:


Realtek ALC850, 8-ch High-Definition Audio CODEC


Upon JaS 10.4.8 install, with no additional drivers for "common hardware" (just the OS files), my sound worked right away when plugged into onboard sound. I have a 5.1 speaker setup though and I noticed I am only getting stereo.


Is there a driver for this audio that I can install to add 5.1 support? Or a software control panel? I wasn't sure and I don't want to install anything and break my sound.


Please let me know if there is something I should install to get better sound support. Thanks!

Link to comment
Share on other sites

go to /Applications/Utilities/Audio-MIDI-Setup and click "Configure Speakers".

There you should be able to setup your multichannel speakers.


This worked for me with a Soundblaster USB 24bit,

C2D 1,86Ghz - 2GB DDR667

Asus EN7300GT (CI/QE with Titan drivers) - RTL8139c

"Jas 10.4.8 Intel SSE3 Only" update to 10.4.9 - 8.9.1 using

Link to comment
Share on other sites

As far as I know, theres no 5.1 support for ALC850 by now. Looking for it myself for a long time but without any success :whistle:

Trick with Audio-MIDI Setup doesn't work for me. It tries to enable 5.1 but it works weird - channels order changing randomly by itself.

Link to comment
Share on other sites


  • Create New...