Jump to content

No QE/CI on Geforce 7600GT

9 posts in this topic

Recommended Posts

Firstly, hardware specs:

Athlon 64 3200+ (SSE2 only)

Asus K8V-VM mobo (onboard LAN and Audio)

Nvidia 7600GT/256MB PCIe graphics.


I've installed OSX using the JaS 10.4.8 AMD-Intel SSE2 SSE3 iso, and it worked initially but had no support for any of my hardware.


I installed the Via Rhine drivers from this forum (pinxue I think was the name) which got the network going, and installed the AppleAzalia drivers to get the sound (Realtek ALC660) going. Both worked great although I can't change the system volume (unimportant as I have speakrs with a volume dial anyway)


I then installed first the Titan drivers, which did nothing, and then Natit 0.2 using the Diabolik installer. I have not yet upgraded to 10.4.9


The problem is, while I can now with the Natit drivers change resolutions and refresh rates from System Preferences, I can't get Quartz Extreme or Core Image to work. I have seen plenty of other posts in this forum indicating that it does work on a 7600GT, so if someone could let me know what I'm doing wrong or where my next thing to look at might be, I'd greatly appreciate it. Do I just need to update to 10.4.9?



Link to comment
Share on other sites

I had a thought that with all my installing of titan and natit and diabolik and stuff that I might have overdone it and had a ton of busted up kext's stopping it from working, so I reinstalled OSX, and ran only the Natit 1.0 beta installer as macbrush suggested.


It got me the ability to change resolution/refresh, but still no CI/QE. Here's a paste from my system profiler :-(


Chipset Model: nVidia GeForce 7600 GT

Type: Display

Bus: PCIe

VRAM (Total): 256 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0391

Revision ID: 0x00a1


Philips 170S:

Resolution: 1280 x 1024 @ 75 Hz

Depth: 32-bit Color

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported


Status: No display connected



I don't have SSE3, but I am sure that the JaS 10.4.8 DVD already has the kernel patch as I can run itunes and rosetta fine and those seem (from forums etc) to be the things that indicate SSE3 not working.


I'm now going to try messing with the kext's as per MCL2k6's instructions.

Thanks guys for helping.

Link to comment
Share on other sites

Tried hacking the kext's - I didn't have GeForce.kext, only NVDAResman and NVDANV40HAL. At any rate I modified the other 2 and put the device ID of 0x039110de in. This caused the PC to reboot where the normal grey screen with the Apple in the middle shows.

I was able to boot into safe mode and fix the drivers by running the Natit uninstall script, however I'm still no closer to getting QE/CI to work.


I might try update to 10.4.9 when I have more time.

Link to comment
Share on other sites

Borland, here is again how I get it to work:


Fresh 10.4.7 Jas DVD. Upgrade to 10.4.9 Jas Combo. Install USB driver for Intel (no keyb/mouse otherwise). reboot. Install Diabolik Nvidia for 10.4.9!!. reboot. I get garbled screen at this point. reboot in safe mode. install natit uni 1.0. move NVDAResman and NVDANV40HAL from disable extensions back to extensions. Put device ID in Geforce.kext, nvdaresman and nvdanv40.hal. I deleted the old values from there, just left my device ID. fix file permissions. reboot. got strange resolution (1024x1280), without mouse cursor. plug TFT to other DVI. worked. reboot again. worked again.

Link to comment
Share on other sites




What does dmesg say? Did NV40HAL loaded correctly? I had to edit Info.plist to add device ID for it to load, as well as Natit. But 7600GT shouldn't be so hard, and certainly doesn't need extra driver, its one of the cards supported by Apple's driver, you just need Natit to get around the EFI.

Link to comment
Share on other sites


  • Create New...