Jump to content

What is the correct FSB for AMD processors ?


zombidik
 Share

11 posts in this topic

Recommended Posts

Laptop ASUS A6Km.

My CPU is Mobile AMD Sempron™ Processor 3000+ (Low Power 25Watt).

I have different reading for CPU core on different CPU checking programs. Weird ?)

Central Brain Identifier says it is Roma 1.200v.

CPU-Z says Albany 1.075v.

Tune Up System Info says Victoria.

I heard some people saying Sempron 3000+ doesn't have SSE3, only 64bit Semprons have SSE3.

But mine is 32bit and has SSE3. I have no problem under OsX. It also shows SSE3.

--------------------------------------------------------------------------------------------

 

Details should be equal to Turion Socket 754's. I mean not CPU details, FSB details since Turions work on my A6Km using the same mainboard. I bought this laptop around 2 years ago very cheap, because of the Sempron I think and planning to upgrade the CPU to Turion if I can find a mobile CPU seller. But this is not the question here.

 

Osx 10.4.1 says 200Mhz FSB & 1800 Mhz CPU Clock

Osx 10.4.8 says 400 Mhz FSB & 1800 Mhz CPU Clock

Under Vmware(Suse 10.2) I see 100 Mhz FSB and around 1500Mhz CPU Clock

XP says 200.01 Mhz FSB & 1800.06 Mhz CPU Clock (Central Brain Identifier & CPU-Z)

SiSoft Sandra says Chipset1: 2x800 Mhz & Chipset2: 2x800 Mhz -- Max:2x100 Mhz for FSB and 2x200 for Max Memory Speed.

I also found 2x163 for normal memory speed in Sandra.

 

In the light of above comments;

What does the system profiler show under CPU tab ? I mean which value ?

Chipset Speed ? Memory Speed ? What does FSB refer to ?

 

I saw in the forum that I can set it under boot.plist. Does it work ? Anybody tried ?

I am not sure what value to set it up.

I am having a bif fan noise with 400Mhz FSB.

Sound output is also very bad. I saw that it can be corrected with the FSB value.

 

What is your FSB and CPU ? (especially Low power AMD CPU Sempron/Turion users)

 

Please help me to set correct value for FSB.

Thanks,

Link to comment
Share on other sites

Thanks for your reply lord_muad_dib !

I don't have any video issues with 10.4.8.

Itunes, quicktime, VLC and DVD player works fine.

I haven't try any DVD but just ran DVD player and I saw that it started.

I mean video is OK without any glitches.

Also have QE/CI support.

 

But I have a problem with sound. Mine is sis7012 based on sis964/sis755x.

I have some output on line out through the driver I installed for sis7012.

But it is so garbled. For 4-5 seconds no sound then something like a crack and some sound of the song for less than 1 second then it goes dead again for 4-5 seconds.

I saw on the forum that it may be related to the FSB for timing issues of sound chip.

 

And the fan is blowing like a typhoon.

 

I know that they are really different. 10.4.1 and 10.4.8

But everything seems OK when I run 10.4.1

Fan is OK. Triggering in intervals as the system gets hot.Also FSB is shown 200Mhz on 10.4.1

But 400 Mhz on 10.4.8 JAS

I didn't install any sound or video driver on 10.4.1

They would most probably not work.

 

If I just had enough sound to supress the fan's noise, everything would be OK for me :)

But only silence with a hurricane sound through the fan. :)

Any ideas?

Link to comment
Share on other sites

it shuld be something like (200/3)*yourrealcpuclock

 

anyways, just update your kernel.. with autofsb detection

 

I was looking for an update package for 10.4.8 JaS AMD SSE2/SSE3 --> 10.4.9

But confused on which one to get?

I heard that an update package for Intel won't work on AMD.

 

Where shall I consult to see which pack is good for me?

Link to comment
Share on other sites

I just got the latest kernel from #1049 and I'm stoked to see the FSB reported by the System Profiler is 800

 

Hardware Overview:

 

Machine Name: Apple Development Platform

Machine Model: ADP2,1

Processor Name: AMD Athlon 64 Processor 3000+

Processor Speed: 1.81 GHz

Total Number Of Cores: 1

L2 Cache (per CPU): 512 KB

CPU Features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH MMX FXSR SSE SSE2

Memory: 2.5 GB

Bus Speed: 800 MHz

 

I'm still running a 10.4.8 system on AMD SSE2 as you can see above.

Anything I should worry about? Sound/image is good in VLC.

Link to comment
Share on other sites

Hi Guys !

I just updated to 1049.

It was painful though. I was stuck at using 5242 buffer headers......

Then I copied back the 1048 acpi.kext and it booted.

Now I see 800MHz fsb.

But I am not sure which bus is that bus.

This AMD 1800 has 2x800(2x1000) for processor bus and (9x200) for cpu speed. Memory bus is 333mhz (166x2)

 

Though it shows an increase on bus speed my xbench has gone below 60. It was 66.something with 400MHz.

Well, it is because of harddisk performance... :whistle:

I didn't sense anything on performance through OSX.

Video is OK as before but I am having big problems with sound. It just doesn't play correctly.

 

EDIT:

The fan sounds little bit noisier than before. Well, actually can't distinguish the difference because it was already noisy...

 

EDIT2:

"About this mac" crashes the computer if I click it.

Link to comment
Share on other sites

 

Thanks Ramm for the link.

I see that I need to set my bus speed in boot.plist or directly at boot screen.

Now on XP.I ran CPU-Z.

 

Clocks:

---------------------------------------------

On speedstep low speed --- On Full speed

Core speed: 802.5 Mhz --- 1806.5

Multiplier : x4.0 --- x 9.0

Bus Speed : 200.7 Mhz --- 200.7

HT link : 802.8 Mhz --- 802.8

 

So shall I set it 200/4 = 50 ?

I will try and edit this post when I boot up.

 

 

{--EDIT--}

I tried to pass the value 50 using boot.plist and direct from boot prompt, but when booted it showed 800 Mhz on System profiler again. I am using 10.4.9/8.9.1 with autofsb now. So it doesn't seem to have an effect passing values neither by boot.plist nor at boot prompt. So nothing to do with fsb for now, I think.

There should be something different affecting my sound output and I have no idea for the fan noise for now.

I tried speedstep pack from the IRC, but it also didn't seem to have an effect.

 

I have already posted under Sis7012 thread about the sound but it seems that it is a dead thread anymore.

 

Anyway,

Thanks for all your help.

Best wishes.

Link to comment
Share on other sites

 Share

×
×
  • Create New...