Jump to content

Is there somebody running only one OS on his PC? OS X?


10 posts in this topic

Recommended Posts



I dont know what more I can do. Four days of browsing the forum - when somebody has booting problem I can find no answer - i mean nearly - to solving the problem of booting WITHOUT DVD.

I simply dont know what to try next. I even installed the OSX on two disks for experiments. Bless, GTP, fdisk, Windows 98 floppy, fdisk /mbr - what? Two times JaS 10.4.8 with semtex on D975XBX, dual pentium D940 - SATA 120, 160, and additional SATA of 250 GB. everything works but the booting sequence. Sometimes it starts one, sometimes another OSX. (I need only one OSX, the other is for experiments) The partitions are both active. This is the output of my second OSX HD:


xys-computer:~ xy$ sudo gpt show /dev/disk2


start size index contents

0 1 MBR

1 62

63 31457280 1 MBR part 175

31457343 6

31457349 202984299 2 MBR part 175


This is how the DiskUtility formats the disk when installing osx86. But:

when i partitioned this disk from Mac OS, previously i got:


start size index contents

0 1 PMBR

1 1 Pri GPT header

2 32 Pri GPT table

34 6

40 409600 1 GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

409640 20709376 2 GPT part - 48465300-0000-11AA-AA11-00306543ECAC

21119016 262144

21381160 125566976 3 GPT part - 48465300-0000-11AA-AA11-00306543ECAC

146948136 262144

147210280 165109344 4 GPT part - 48465300-0000-11AA-AA11-00306543ECAC

312319624 262151

312581775 32 Sec GPT table

312581807 1 Sec GPT header


I left it this way to install OSX without partitioning, just went next to installation. But i cannot start it even with the DVD inserted. The darwin bootloader from DVD says it cannot find mac.boot.plist or something. And i do not have the boot1h file to bless or dd from. Nowhere. Am I missing something?


Can somebody take a look on http://www.opensource.apple.com/darwinsour...winInstaller-1/ maybe is this the right place to look for something?

If im able to put it on CD/DVD, then it must work on Hard disk too..what is going on? Heeeeeeeeeeelp.....somebody...Thanx

Link to comment
Share on other sites



Firstly having it installed on two hard drives probably doesn't improve matters with the bootloader! If you want to use both for Mac OS X install one and simply format the other in HFS+ Journalised format so you can store files on it.


As for your problem, am I right in thinking that you have Installed it, it boots once then doesn't work again?

If so you may well need to install the USB Drivers for 10.4.8, as if you don't after the first boot it tends to kill your PC! (Or at least does on mine)


You can download it here - but let me know when you have so I can delete it from my server please.




Link to comment
Share on other sites

Thanks to all for answering. Everything works fine except booting from HD. My another HD with OSX86 on it is plugged off and is there to be prepared to boot after I figure out (with Your help :)) how to boot without DVD inserted, So its a simply backup and we can forget it. Related to my setup, the CI/QE and extended desktop work fine, THX to natit. The problem with booting from HD remains unsolved for me. I will try maybe with grub. I tried last week with XOSL boot loader, no positive results.

Link to comment
Share on other sites

Partition inspector from rEFIt package says:



*** Report for internal hard disk ***

Current GPT partition table:
No GPT partition table present!

Current MBR partition table:
# A    Start LBA      End LBA  Type
1 *            1    312581807  af  Mac OS X HFS+

MBR contents:
Boot Code: None

Partition at LBA 1:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in MBR as partition 1, type af  Mac OS X HFS+, active



No Boot code? no boot loader? I tried to start with BootMagic--sucks.

Link to comment
Share on other sites


  • Create New...