Jump to content

USB not working anymore

3 posts in this topic

Recommended Posts

Hi guys!


Well, after my PC went bust, I decided to reinstall OSX. This time, though, I found the generic 10.4.1 DVD that says it was patched to let it install on more machines. "Great!" I thought - full partition size, and I can finally get rid of the image from my PC.


With the deadmoo image I had before, things were working OK. At first, OSX didn't recognise my Playstation 2 USB Keyboard or Playstation 2 USB Mouse, but I did something (with an IO USB kext), replacing it with one from the darwin x86 CD... I think. In any case, I somehow managed to get the things working (although the USB thing had a problem that if I had the IO USB kext activated, my keyboard wouldn't work, but sound would. If it was deactivated, sound didn't work, but kb did).


Anyhow, now I've reinstalled OSX, I find myself with the same problem: OSX tells me the keyboard "isn't recnognised", and gives me a button to click (ironically, my mouse is apparently unrecognised as well, so I'm stuck there). I've booted it up in VMWare using the physical disk mode, and it doesn't see ANY keyboard. Also, after searching, I found that a USB BIOS setting needed to be deactivated to get OSX to accept it. After disabling "USB Keyboard Support" and "USB Mouse Support" in my BIOS, OSX told me no keyboard was present - just like it did with VMWare.


I'm not sure how well you guys accept talking about the install dvd or deadmoo image, but I'd just like to draw everyone who replies' attention to the fact that this thread isn't about HOW I got it installed: it's about my USB Keyboard being recognised but "not recognised", and the mouse being unable to move. If any moderators have a problem with me mentioning anything, I'm sure they'll edit it out.


I've also tried a USB->PS2 adaptor for my mouse, but to no avail. Strangely enough, the PS2->USB adaptor also makes the thing not work under Windows XP (?). I usually have my mouse hooked up to the USB hub built into the keyboard (which was recognised under my previous OSX86 installation), but plugging it right into the PC didn't change anything.


My USB controller was recognised by OSX before (its an Intel 82801EB - dev.ID=24D2), and the keyboard appears to be recnognised as a keyboard of some type by OSX (since removing it makes the "no keyboard connected" screen come).


Any help would be very much appreciated. I'm going to try replacing all the kext files with the ones from deadmoo's image, but as I remember, there was something else that had to be done. Since I remember deadmoo's image gave me the same problem, and I remember I didn't do any BIOS stuff last time, could anyone help at all?


Thanks a lot,


Link to comment
Share on other sites

I think USB support is the biggest problem with OSX86 (well, other than graphics cards and wireless lan)


I just removed AppleAC97Audio.kext, and OSX booted up (albeit only with -x -v, and after a long time writing zero blocks), oh, and I'd replaced IOUSBFamily and IOUSBMassStorage kexts with the darwin 8.0.1 versions


booting normally tells me IOUSBFamily.kext has a problem, and I should ocntact the vendor for an update (hmmm....)


-x shows the apple screen for a long time, then reboots. No idea what's happening, but there you go. I tried putting the ATA patch in there to stop the zero block writing... to no avail.


Once I get 10.4.3 I think this'll be better. New IOUSBFamily.kext version.... (actually, I lost the original ones in that I can't tell them apart from the darwin ones - I didn't organise them :S)

Link to comment
Share on other sites


  • Create New...