Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Midral

[GUIDA] DUAL BOOT WINDOWS / MACOS (MBR)

93 posts in this topic

Recommended Posts

LA GUIDA SERVE SOLO PER CHI HA VISTA E MAC INSTALLATI SULLO STESSO HARDDISK
SE LI AVETE SU DUE HARD DISK DIFFERENTI LA GUIDA CAMBIA LEGGERMENTE

installate prima macos poi windows (in realtà è indifferente ma windows ormai chiede sempre la partizione ripristino di sistema)* <----update in fondo

 

esempio hardisk con due partizioni

1-Windows

2-MacOS

Procedura per MBR

-inserisco il cd di macos, F8 per fermare il timeout digitare -s
(il cd partira' in single user mode modalita' con prompt dei comandi)

 

-attendiamo il caricamento fino a quando si interromperà e scriviamo:

- fdisk -e /dev/rdiskx

( x sta per il numero dell'harddisk dove avete installato vista e mac facendo attenzione che se l'harddisk e' il primo x sara' uguale a  0, se l'hardisk e' il secondo x sara 1 e cosi via...) solitamente è 0

- flag y

(serve per attivare una partizione y sta per il numero della partizione, nel mio caso volendo attivare la partizione di mac scrivero' flag 2)

- update

- write

- quit

- reboot

il pc si riavvia fate ripartire di nuovo il dvd di mac in sigle user mode ora si passera a  riscrivere l'mbr della partizione di vista attenti quindi a cambiare i valori di x e y

-fdisk -e /dev/rdiskx

- flag y
(in questo caso y sara uguale a 1)

- quit

- reboot

il pc si riavvia ora fate partire il dvd di vista...

premere un tasto per avviare da dvd/cd rom...

continuate la procedura di startup dell'installazione fino a quando non vi trovate alla schermata 'INSTALLA' piu' in basso ci sara' 'RIPRISTINA' eseguite la procedura di ripristino del boot (la procedura viene eseguita in 10 secondi al massimo)

riavviate

rinserite il dvd di macos ancora una volta ripartiamo in single user mode (riattiviamo la partizione di mac..)

- fdisk -e /dev/rdiskx

- flag y

- quit

- reboot

riavviate

 

entrati in macos consiglio di aggiornare all'ultimo bootloader (esempio usare chameleon wizard per chi usa chameleon)

si ringrazia la sezione internazionale per l'aiuto

 

UPDATE PER CHI HA AVUTO PROBLEMI (confermo ancora che la guida funziona perfettamente anche per w8.1+mavericks)
quando create due partizioni da utility disco: (non vale dal partizionatore di windows perche' creerà sempre la partizione ''RISERVATO PER IL SISTEMA'')

 

1- quando andrete a installare windows se formattate solamente vi installerà il bootloader nella stessa partizione del sistema operativo (il C: per intendersi)
2- se in fase di installazione fate una nuova partizione prima di formattare vi creerà la partizione ''RISERVATO PER IL SISTEMA''

 

nel primo caso il comando ''flag'' va dato sulla partizione C: che seguendo l'esempio riportato all'inizio della guida sarebbe la partizione 1

 

nel secondo caso il comando "flag" va dato sulla partizione RISERVATO PER IL SISTEMA e li dipende da come avete installato il sistema operativo

se in questo caso date "flag" alla partizione di windows potreste avere problemi di boot o non bootare affatto perche' nella fattispecie attivate una partizione che non ha bootloader...

Share this post


Link to post
Share on other sites

Ho fatto tutto quello che c'è scritto nella guida ma nel mio prompt mi dice che il comando flag nn esiste....quindi nn posso andare avanti!!! Cosa faccio??

Share this post


Link to post
Share on other sites

oppure al massimo se volete potete usare acronis gira anche su vista vi darà una serie di errori voi ignorateli e andate avanti

Share this post


Link to post
Share on other sites
-fdisk -e /dev/rdiskx ( x sta per il numero dell'harddisk dove avete installato vista e mac facendo attenzione che se l'harddisk è il primo x sarà 0, se l'hardisk è il secondo x sara 1 e cosi via...)

 

ok considerando che ho un solo HD a me x=0

 

 

- flag y (serve per attivare una partizione y sta per il numero della partizione, nel mio caso volendo attivare la partizione di mac scrivero' flag 2)

 

come si fa a verificare y a cosa è uguale?

c'è un comando per capirlo?

Share this post


Link to post
Share on other sites
...y sta per il numero della partizione, nel mio caso volendo attivare la partizione di mac scrivero' flag 2)

 

 

 

e menomale ke ho scritto passo passo :thumbsdown_anim:

Share this post


Link to post
Share on other sites

si tu hai scritto passo passo ma hai indicato il tuo caso! Dato che io posso anche avere le partizioni al contrario, volevo sapere se c'è un modo per verificare realmente qual'è la partizione interessata.

Cmq grazie ho risolto diversamente.

Ciao ciao

Share this post


Link to post
Share on other sites

purtroppo questa procedura a me non funziona. La mia situazione è la seguente:

Un solo disco, le partizioni sono:

 

1-Vista

2-personale

3-Macos

 

avviato il dvd di macos con -s:

 

fdisk -e /dev/rdisk0

flag 3

update

write

quit

reboot

 

riavvato il dvd con -s

 

fdisk -e /dev/rdisk0

flag 3

quit

reboot

 

riavviato con il dvd di windows vista, cliccato su ripristina ma appare la finestrella che chiede quale sustema operativo si vuole ripristinare ed è vuota!

Ho rifatto la procedura più volte ma sempre lo stesso. Riavviando a questo punto, senza dvd, naturalmente mi parte MacOs.

Riavvio il sistema con il DVD di Mac e -s, rimetto attiva la partizione 1 e ripartendo con il dvd di windows vista a quel punto il ripristino mi trova e ripristina la partizione di Vista.

 

Può dipendere dal fatto che il mio portatile (Dell Inspiron 9400) ha un disco SATA? Anche se credo la mia domanda sia inutile perchè il south bridge ha i driver già compresi e quindi non servono driver per farlo riconoscere.

Bhooo....questo windows Vista incasina un bel po le cose.

Share this post


Link to post
Share on other sites
ACRONIS LO DOVETE BUTTARE DALLA FINESTRA!!

 

QUOTO ALLA GRANDE!!! Installato ACRONIS su un Vista/Mac: Mac partiva, Vista no. Disinstallato ACRONIS: Vista partiva, Mac no... :o

Share this post


Link to post
Share on other sites

C'è un modo per avere un boot grafico di darwin ? XD ( magari simile a quello che usa botcamp per lo switch tra windows e osx )

Edited by DeadSinn

Share this post


Link to post
Share on other sites
purtroppo questa procedura a me non funziona. La mia situazione è la seguente:

Un solo disco, le partizioni sono:

 

1-Vista

2-personale

3-Macos

 

avviato il dvd di macos con -s:

 

fdisk -e /dev/rdisk0

flag 3

update

write

quit

reboot

 

riavvato il dvd con -s

 

fdisk -e /dev/rdisk0

flag 3

quit

reboot

 

riavviato con il dvd di windows vista, cliccato su ripristina ma appare la finestrella che chiede quale sustema operativo si vuole ripristinare ed è vuota!

Ho rifatto la procedura più volte ma sempre lo stesso. Riavviando a questo punto, senza dvd, naturalmente mi parte MacOs.

Riavvio il sistema con il DVD di Mac e -s, rimetto attiva la partizione 1 e ripartendo con il dvd di windows vista a quel punto il ripristino mi trova e ripristina la partizione di Vista.

 

Può dipendere dal fatto che il mio portatile (Dell Inspiron 9400) ha un disco SATA? Anche se credo la mia domanda sia inutile perchè il south bridge ha i driver già compresi e quindi non servono driver per farlo riconoscere.

Bhooo....questo windows Vista incasina un bel po le cose.

 

penso che nel secondo passol il flag da mettere è quello di vista..difatti ho fatto così e me lo ha visto, solo che mi parte mac ma poi c'p una schermata che in 4 lingue mi dice di riavviare...

Share this post


Link to post
Share on other sites

Avevo installato mac osx nella partizione secondaria del disco qialche giorno fa avendo vista sulal primaria, da allora mi si avviava direttamente il mac, ieri poi ho deciso di ripristinare vista e fare un dual boot ma ancora non ci sono riuscito. In pratica prima di leggere questa guida avevo ripristinato vista col dvd, la lista dei sistemi operativi era vuota ma andando avanti mi ha fatto ripristinare il boot, risultato vista partito regolarmente. Poi ho seguito passo passo la guida, risultato: parte vista e non c'è nessun dual boot, non è che il ripristino mi ha incasinato/cancellato la partizione di mac osx? c'è modo di vederle dato che windows mi fa vedere solo i dischi con fs ntfs?

Share this post


Link to post
Share on other sites
ACRONIS LO DOVETE BUTTARE DALLA FINESTRA!!

 

Concordo pienamente :) Anche se è l' unico che sono riuscito ad usare :P

 

Adesso ho sullo stesso HD SATA diviso in due partizioni WinXp e OSX

e Acronis per il dual boot

 

Ma non mi piace spesso simpalla e sopratutto se

scordo l' ipod o una penna usb collegata acronis di suo tenta

di partire a queste impallando il tutto :(

 

Come faccio per levarlo e usare questo metodo che tu citi?

 

Grazie

Share this post


Link to post
Share on other sites
disinstallalo.... -.-'

 

Si ma poi non ho capito come installare uno differente ;)

 

Cmq a giorni dovrebbe arrivare il nuovo HD visto che la nuova

schedamadre lo supporta levo attale ide e monto una STA II credo da 500Gb

Forse levo anche il mast e ne prendo una STA cosi levo tutti gli ide dimezzo

E lascio il SATA normale da 320 per scarico e dati.

Mentre il SATAII 500Gb lo vorrei dividere in due partizioni OSX o Winzozz

 

Che ne dici come soluzione?

Share this post


Link to post
Share on other sites

troppi sata vengono digeriti male da osx ma penso ke tra un po' con leopard vada tutto ok poi

Share this post


Link to post
Share on other sites
troppi sata vengono digeriti male da osx ma penso ke tra un po' con leopard vada tutto ok poi

 

Umm quindi mi sconsigli di passare tutto a SATA?

 

E la lasciare il mast e il secondo HD in IDE

e aggiungere solo il SATA II per l' instalalzione degli SO?

 

Mi resta sempre il dubbio sul sual Boot se è complesso faccio cosi:

 

SATA II Mac OSX e partizione per scambio Dati

 

Poi secondo hd da scegliere se uno dei due che gia ho dentro

l' ide o sata 1 da 320 per winzozz.

 

Ma speriamo che il Leopardo di farà sempre installare su un PC Normale :rolleyes:

Share this post


Link to post
Share on other sites

Ok Upgrade effetuato ieri.

Ora manca solo il monitor ma quello tanto non influenza i benck e config SO

 

Allora montato

HD SATA II 500Gb Seagate diviso in Due parizioni uguali

sulla seconda ho installato OSX Senza problemi.

 

Ho messo come secondo HD il SATA1 Maxstor da 320Gb che avevo

per adesso nessun problema poi se è provo anche con il Mast SATA

 

Montato il proco E6600 va una meraviglia :D

adesso totalizzo 113,17 come benk

credo il tutto sminuito dalla Skvedeo integrata esatto?

 

Sul vecchio STA da 320Gb avevo provato un dualboot ma niente :P

 

Avevo fatto cosi:

 

Prima partizione winzozz

Seconda OSX

 

Partiva solo winzozz che ho installato dopo OSX

Ho messo da winzzoz su hd per visualizzare files e cartelle nascoste e di sistema

copiato il files chain0 dal dvd dove installo osx sul HD

Poi con l' edit ho aggiunto la riga in boot.ini c:\chain0="descrizzione"

Al riavvio mi esce il dual boot winzzoz e quello della descrizione ma va solo winzozz

se selezziono il secondo ritorna a loop nel menu del dual boot dove sbaglio :shock:

 

Grazie

Share this post


Link to post
Share on other sites

Allora nessuno mi da una mano per il dual boot

non ho Vista ma XP la procedura è la stessa o no?

 

Scrivo passo passo come ho fatto:

 

Ho montato L' HD STA II Seagate da 500 GB

Ho lasciato montato l' altro HD STA1 da 320 e levato l' HD IDE

Nessun problema apparente :D

 

Io ho fatto cosi al instalalzione HD Pulito ho partizionato con utility

disco del DVD di OSX In due partizioni uguali sul 500Gb STAII.

 

Sulla seconda partizione ho installato OSX Tutto Ok :D

 

Poi sono partito con il CD di XP

Ho dovuto eliminare la prima partizione perche la vedeva

come sconoscuta e non formattabile forse non digerisce

come crea la partizione l' utility di OSX

quindi eliminata prima partizione e formatata in HPFS veloce

e installato winzozz tutto Ok

 

Al riavvio parte solo Winzozz niente dualboot e quindi niente OSX :(

 

Da dentro winzozz abilito per vedere tutti i files e cartelle

nascoste apro con notepad il boot.ini situato in c:\ e gli aggiungo

in fondo la scritta c:\chain0="hackintos"

inserisco il DVD usato per installare osx e copito il files chain0 in c:\

Il nome era maiuscolo e anche nel boot.ini l' ho scirtto in maiuscolo

ho provato anche il cotnrario per sicurezza.

 

Al riavvio esce il dual boot windos o hackintos

Se selezziono windows parte tutto ok

Se seleziono hackintos ritorna al menu di dual boot :(

Quindi il dualbooot con il metodo chain0 non va

non vorrei installare Os Selctor di Acronis mi dite come altro posso fare

per questo dualboot?

 

Grazie

Share this post


Link to post
Share on other sites

La situazione si complica :thumbsup_anim:

 

Ho messo Acronis OS Selector tutto ok

Anche se preferivo non usarlo ma il multi boot con altra maniera

non sono riuscito proprio a farlo :)

 

Ho installato Ubuntu ed il suo multiboot faceva partire solo Winzozz e Ubuntu

Ripristino Acronis OS Selector e mi fa Solo Winzozz e Hachintosk

 

Allora come devo fare su Un HD con Tre partizioni

per avere un multiboot Winzozz Hackintosh e Ubuntu?

 

Grazie

Share this post


Link to post
Share on other sites

mega con xp nn ci sono mai stati problemi..

installi xp poi osx e poi attivi la partizione di mac...

Share this post


Link to post
Share on other sites

salve a tutti!

ho seguito la guida passo passo ma ho 1 problema.. mi parte subito la schermata con la mela del mac senza poter scegliere il s.o. all'avvio.

Cosa devo fare?? devo attivare il Darwin in qualche modo?? grazie

 

..scusate bastava premere f8 all'avvio o modificare il file del boot. ciao

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×