Jump to content
Guest Ramm

[How To] Delete a Faulty/Non-Working Kext

3 posts in this topic

Recommended Posts

Guest IanP

I wanted to post this because I just recently had this problem myself, and I have seen other people with the same problem.

 

How to Delete Kexts that Mac Doesn't Like

 

If you installed a kext that completely fried your system and you can't boot, here is what to do.

  • Boot in Single User Mode [-s]. If you are using Acronis, just keep pressing F8 when you click on Mac OS. Other wise, just press F8 after the PC diagnostics screen.
  • Enter:
    sudo -s	 <----- To make sure you are root (just in case)
    cd /System/Library
    rm -rf Extensions.mkext
    rm -rf Extensions.kextcache
    cd Extensions
    kextload [kextname]	 <----- To make sure the kext is found
    rm -rf [kextname(s), separated by spaces if multiple]
    reboot


There, good as before you screwed it up by installing that kext.

Edited by Ramm

Share this post


Link to post
Share on other sites
Advertisement

If anyone runs into the problem where they cannot delete the file due to it being a read-only file system just type this first:

 

mount -rw -a

 

This will mount the drive as writeable and you will be able to delete the kext files.

Share this post


Link to post
Share on other sites

Thanks for this - it helped solve one of my problems.

 

I had to boot the system from an install disk.

When I got to the install screen I went to Utilities and then into the command line app.

 

I tried to do sudo -s but it said it could not find the command.

 

I then tried to rm -rf Extensions.mkext

but it said that it is a read only file

 

so I did mount -rw -a

but nothing seemed to happen

 

I then tried again rm -rf Extensions.mkext

still said that it is a read only file

 

I then did rm -rf Extensions.kextcache

it worked.

 

I rebooted and luckily I was able to get into the system

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×