Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Strange graphics distortion X1600

2 posts in this topic

Recommended Posts

Hi, I'm sorry if this is something that was brought up before, but I couldn't find anyone with this same problem.


I am using a clean install of JaS 10.4.8 PPF1. I installed Natit_ATIauto.kext.zip and my card was recognized properly, but I have these boxes all over my screen (see attachment). Using JaS ATI Radeon X1000 kext, I get a kernel panic at boot, so I am using the original 10.4.8 kext. My video card is a PowerColor ATI Radeon X1600 Pro AGP 512mb. I am also using the latest build of AGPGart. I have also tried using the 10.4.4 kernel and have the same result (I'm currently using 10.4.8 kernel). I am also running an Athlon 64 3200+ SEE2.


After removing Natit.kext from my /System/Library/Extensions, I can still change resolutions, but my video card is detected as Display and 256mb. I would like to have QE/CI enabled, but I think I need Natit to do so. (The distortion goes away if I do not load Natit)


Is Natit the source of the problem or is ATIRadeonX1000.kext?

Is there a fix for this?


Thanks! I really appreciate the hard work in this forum!



Edited by Athlon64 OS X

Share this post

Link to post
Share on other sites

you seem to have gotten further than I


I cannot get past the black screen with pink squares all over it (I took a photo and uploaded in some other thread)


I have 512 PCI x1600 and experience same/similar issues

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.