Jump to content

Installation Troubles: Hard Drives Not Detected during Ventura or Sonoma Setup [ Asus Z490-P , I9-10900K , Radeon RX580 ]


11 posts in this topic

Recommended Posts

I can't install Ventura or Sonoma. In short, the problem is that the hard drives are not being detected.

The startup of the installation program from the USB drive is unusually slow, taking about 16 minutes to start (the USB drive is not broken because the same drive with the Monterey image boots in 10 seconds). The problem occurs during the installation phase: as soon as I get to Disk Utility, no hard drive is shown, only the USB drive.

I followed the official OpenCore guide, I've tried various settings, including activating AppleXcpmCfgLock, and then I also tried disabling SecureBootModel. But nothing...

I tried the latest version of OpenCore and then other EFI found online, but to no avail...

I believe the problem lies in the EFI configuration or in some new drivers/kext released after the distributions of Catalina and Monterey; these two distributions work fine on my setup...

I don't know what else to try. Can someone with my same setup help me?


Asus PRIME Z490-P
I9-10900K

Sapphire Nitro+ Radeon RX 580 8GB [currently with two monitors]

2* WD_BLACK SN850X 1TB M.2 2280
2*SSD crucial mx
2*HDD
...Various external backup hard drives and other devices

Link to comment
Share on other sites

Posted (edited)

Perhaps it won't make a difference, but... I tried to start the installation even without the RX580. But the problem remains. And... If it had been a BIOS settings issue, then at this point the USB drive to install Sonoma or Ventura wouldn't have started either. I don't know what to do anymore...

Edited by frankx86
+Details
Link to comment
Share on other sites

Posted (edited)

I removed the graphics card, reset, and then reconfigured the BIOS settings according to the guide, and now I find myself in this situation [see the uploaded image]

I always use the same EFI, but as I mentioned before, without the RX580:

https://github.com/AutismSuperman/Hackintosh-ASUS-Z490-P-i7-10700K-UHD630

Here is the complete boot argument:
"-v debug=0x100 keepsyms=1 igfxfw=2 igfxonln=1 alcid=1 gfxrst=1 alcdelay=500 shikigva=80 -cdfon -igfxmpc revpatch=sbvmm"

I have only added: "-v debug=0x100 keepsyms=1""

photo_2024-03-27_08-19-31.jpg

Edited by frankx86
.
Link to comment
Share on other sites

  • 3 weeks later...

Salve.

In relazione ad un tuo messaggio che solo ora ho visto, ti invio il mio EFI, se ancora mai può esserti utile.

La release OpenCore è la 1.0.0.

La scheda audio non è impostata per via del fatto che uso una FiiO esterna su USB. Le patch credo siano in parte ridondanti. Ho svuotato le Resources per il loro peso eccessivo.

Un cordiale saluto da Napoli.

Erice

EFI.zip

Edited by erice
to frankx86
  • Like 1
Link to comment
Share on other sites

I apologize.

It is the provincial ambition, fortunately only occasional, of thinking that one's dialect can be a language understandable by everyone.

Link to comment
Share on other sites

 Share

×
×
  • Create New...