Jump to content

Opencore Ventura stalls at setup screen

3 posts in this topic

Recommended Posts

Hi all,

Having a curious issue here. After installing Ventura on the system described below, only with an evga geforce gt730 graphics card, I ordered another graphics card(msi radeon rx 560) to hopefully take care of the lack of acceleration. So, after putting in the new card, when installing Ventura, it hangs right at the setup screen with a blank dark page. Not a black screen because something is there, its just not the desktop. Its blank and when I move the curser the curser image will briefly flash for a second or two then disappear. Also a brief glimpse of some desktop color which also disappears.

After trying some troubleshooting with no success, I decided to try to load in Monterey. This took me all the way thru setup to the desktop. I was able to use it flawlessly but then on reboot, the exact same issue occurred - no image. just a blank dark screen. Again when I moved the curser the curser image briefly flashed for a second or two then disappeared and again a brief glimpse of some desktop color which also disappeared.

This is just too strange that Monterey would completely load in with full functionality after install but do this on reboot.

So my conclusion is it must have something to do with the fx cpu not having AVX2.0 support?  But why would Monterey install and fully function if that was the issue??? Also the radeon card has Polaris 21 architecture. I didn't see that on the list on the opencore guide page but it lists the rx 560 as compatible. Another interesting fact is when I switch out the radeon for the old evga gt 730 I can boot into the fresh Monterey/Ventura installs but with poor acceleration.

Really am lost on this one. I hoping its just something silly I'm missing. Any help would be greatly appreciated.



My specs:


asrock 970a-g/3.1

amd fx8350

msi radeon rx 560

corsair ssd bootdrive

ripsaws g-skill pc17000 16gb


Using smbios iMacPro1,1 but tried different ones with the same results.

OpenCore 0.9.0, also tried older versions with no success.

Link to comment
Share on other sites


I got a suggestion to disable acceleration with the boot arg "-amd_no_dgpu_accel" to get it to boot(that worked) and then apply the polaris patch from OCLP.  Unfortunately that didn't work.  Same issues as before. 

Gonna try a polaris 10 card today when it gets here.  Hoping that does the trick.

Link to comment
Share on other sites

  • 6 months later...

  • Create New...