Jump to content

AMD R7 240 No Graphic Acceleration in Big Sur


heysahilsingh
 Share

8 posts in this topic

Recommended Posts

*Using Opencore*
 
Hi there, hope you're doing awesome!

 

Dortania's Guide, Whategreen's FAQ, and Other Forums are saying that AMD 7 240 is compatible upto macOS Monterey but I'm struggling to make graphic acceleration work in my Intel i5 8400 hackintosh machine via dGPU AMD R7 240.

 
I spoofed the R7 240 as R7 250X to make it compatible with macOS Big Sur, and installed the macOS. But somehow I'm unable to enable the graphic acceleration of my dGPU.
 
I don't want to use my iGPU UHD 630 because my motherboard's HDMI port has been damaged and I'm not getting display out from VGA.
 
 
I saw people are getting success in getting graphic acceleration work from AMD R7 240 dGPU. 
 
I have tried many fake IDs (suggested by some forums) but still no result.
 
My specs as follows:
CPU: Intel i5 8400 (CFL)
dGPU: AMD R7 240
MB: ASUS PRIME B360M-D
Ram: 16 GB
 
I'm not able to buy a new-cheap graphic card that's why to make it work. 
Please help me, thanks in advance.
 
 

 

Edited by heysahilsingh
Link to comment
Share on other sites

The whole theory of spoofing unsupported cards to be supported tells that you may spoof to same family or sometimes older family.

But you can't spoof it to modern card. In this case Monterey supported Polaris and up but you can't spoof the card to Polaris.

AFAIK R7-240 never worked in Monterey while worked fine in Mountain Lion (10.9.5) and in High Sierra.

I see success in Mojave Oland Family Graphics Card (like R7 240)  dunno how.

  • Like 1
Link to comment
Share on other sites

16 hours ago, pitrysha said:

Write the correct paths in SSDT-GPU-SPOOF.aml. For example .

https://github.com/linkua/OC_AMD870k_R7_240

This SSDT is also not working for me. Still no graphic acceleration.

13 hours ago, Slice said:

The whole theory of spoofing unsupported cards to be supported tells that you may spoof to same family or sometimes older family.

But you can't spoof it to modern card. In this case Monterey supported Polaris and up but you can't spoof the card to Polaris.

AFAIK R7-240 never worked in Monterey while worked fine in Mountain Lion (10.9.5) and in High Sierra.

I see success in Mojave 

Oland Family Graphics Card (like R7 240)  dunno how.

That says, I will not able to make it work?

Link to comment
Share on other sites

2 hours ago, heysahilsingh said:

This SSDT is also not working for me. Still no graphic acceleration.

Do not use someone else's SSDT, you must make your own as the paths to the device may differ

 

     External(_SB_.PCI0.PB21.VGA_, DeviceObj)

 

     Scope (\_SB.PCI0.PB21.VGA)

 

You must specify the correct path to your device (video card) here

  • Like 1
Link to comment
Share on other sites

3 hours ago, pitrysha said:

Do not use someone else's SSDT, you must make your own as the paths to the device may differ

 

     External(_SB_.PCI0.PB21.VGA_, DeviceObj)

 

     Scope (\_SB.PCI0.PB21.VGA)

 

You must specify the correct path to your device (video card) here

Buddy, I've also done this. I'm using the correct PCIe path for my dGPU and tried using R7 240's, 250's, 250X's device IDs. But as mentioned, nothing seems to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...