Jump to content

Legacy Nvidia PNY gtx 560 1 gig OC boot loader


snakeman
 Share

5 posts in this topic

Recommended Posts

I have tried everything even read the guide posted on their site.

 

I have tried everything nothing works, I am using smbios 14,2 on a haswell system with a PNY GTX 560 1 gig works great under clover trying to get this old bird working with opencore 0.7.8 for now!

 

Model      Dell Inspirion 3847 

Ram         8 gigs of ram

GPU         igpu intel HD 4600 Nvidia PNY GTX 560

OC           0.7.8

Clover     Works great just enable Nvidia graphics and we are off and running

 

I have added my rom file for my nvcap configuration 

 

GF114.rom

config.post.plist

Edited by snakeman
files
Link to comment
Share on other sites

Some nVidia-related settings look incorrect to me.

1) injected device properties:

nVdia_Properties.jpg

-> you should not need any NVCAP injection, at least initially unless you're using VGA output and getting black screen. DVI or HDMI outputs should work OOB.

-> you incorrectly inject VRAM size: for 1024MB (i.e; 1GB), it should be 00000040, not 00000040 00000000

-> this is how VRAM gets reported in IOReg for a fully natively supported 2GB (2047MB) Kepler card of mine (no injected properties whatsoever):

nVidia_VRAM.jpg

 

2) NVRAM settings:

NVRAM.jpg

-> that's for the nVidia WebDriver which is not required for Fermi cards. Remove this.

 

Once you've adjusted your OC config, reboot and reset NVRAM at OC boot menu.

Also check that your dGPU is indeed located at the IO location at which you inject your properties. Right now, I assume that in IOReg, you see it under a device GFX0@0 itself under a device of some sort (a PCIe root) like PEG0@1 or something similar. Check it out with apps such as IORegistryExplorer.

 

NB: Fermi cards are only supported up to El Capitan 10.11 and, some say, Sierra 10.12. No support beyond that. Haswell HD4600 iGPU is supported up to Monterey on the other hand.

Link to comment
Share on other sites

Posted (edited)

It does not even show up in the IORegistryExplorer when I boot OC!

When I boot clover everything works igpu and the DGPU just enabling Nvidia!

 

Will try your suggestions,

Thanks,

 

Maybe I missed something, it is a 1 gig card!

 

snakeman

Edited by snakeman
tired
Link to comment
Share on other sites

@snakeman I never injected any device properties when using the GTX 560 TI I had.

 

I just booted with nv_disable=1 initially so the sofware renderer was used.

Then I installed webdrivers, removed the boot-arg, enabled NvidiaWeb Option in System Parameters in Clover, rebooted and done.

But that was before OC existed and on Sierra/High Sierra. But I had to disable metal. since it's not supported by Cards of the Fermi Family.

Link to comment
Share on other sites

 Share

×
×
  • Create New...