Jump to content

MacPro build - i9 11900K Z590 Asus Maximus Hero XIII RX6900XT (XFX) build -


14 posts in this topic

Recommended Posts

So I started this build back at the end of October, I am current working as an IT specialist with a school here in Western Canada. Vancouver to be exact. 

I slowly started putting this rig together to replace the i7 3770K with Titan Black GFX  -  Korean Hackintosh build -  I built while working in the Republic of Korea back in late 2012, early 2013. 

Gone are the days of Clover and TonyMacX86 forum to discuss builds like this. Actually I was banned for mentioning Malden and giving credit to him which I am very pissed off at, though not surprised. 

I want to make sure I say this first before moving forward, the copy of the OS on my system comes off my work laptop, a MacBook Air 2017 and is a complete clone of my system. Therefore, It belongs to me! 

This drive has remote management tools on it that run flawlessly on my new system for remote management of my school network.  

I would like to thank member MaLd0n  for helping with the DSDT edits and plugin sets. for getting the system up and running. 



Performance wise:  I am getting a Geek Bench of 12400 without actually doing any serious overclocking.  

I am still within spec. I upped my multicore frequency to 4.6 Ghz. Single core is still set to 5.3Ghz


I'd like to take you through my hardware choices. 
















































What Works:   

Sound  ALC4082 100% working

CPU power management and speed stepping 100%

Thunderbolt ports x2. .. was working - getting some odd behaviour now.  No hot plug - Apple TB dongles not showing up like they should be. System seems confused with Extensible USB3.2 port at the front of the case.  ?? HELP PLEASE 

Sata3 ports  100% 

GPU and metal support 

Onboard Intel® 2.5 Gb Ethernet  - (finicky at times) 

Wifi Intel AX210  - Works at WIfi 5 (AC) speeds ONLY!  No Bluetooth 

Dual booting MacOS 12.2.1 and Windows 11 using OpenCore 8 


Work in progress:  

Bluetooth 5.1   Need to order a supported dongle ( Cypress branded chipset on order) **right now using a BT4.0 adapter by I/O Gear. **

Intel 2.5Gb switching ability - 

Screen cast ability to TV 

Wireless AX  ( not sure if this is possible) 







Issues encountered / points to note: 


  1. The 11th and 12th gen Intel processors are obviously NOT supported ( no apple products to date use them) unless you use a FakeCPUIID mask from the 10900K processor. The 11th gen Intel can use a mask from the 10th gen intel lineup as they behave relatively the same.
  2. The onboard graphics on 11th Gen Intel are not supported and it would be a wise move to turn them off. Set board Primary display - PEG.  This effectively disables the IGFX on the Intel processor
  3.   Intel Wifi while working is not capable of 802.11ax at the moment.  Bluetooth support no long works as of MacOS12 with the enabler KEXTs.  
  4.   Graphics card should only go in the first slot on the board, and the internal GFX should be turned off!   
  5.    When dual booting, leave the first 2 NVMe slot locations  and put your NVMe drives in slots M.2_3 and M.2_4. !!!
  6.    The first 2 NVMe slots share bandwidth with the GFX card!  Otherwise you'll bet getting half the performance from your card at x8. 
  7.     Everytime you make a change to the KEXT or .plist file, reset your NVRAM. You can get some oddities if you forget to do this!       


        The screenshots shown are done in OpenCore Configurator.  The actual editing has been done in OCAuxillaryTools. 



       Kexts being run on my build: 


  1.     AirportBrcmFixup.kext       
  2.     Airportltlwm.kext
  3.     AppleALC.kext
  4.     BluetoolFixup.kext
  5.     IntelBLuetoothFirmware.kext
  6.     Lilu.kext 
  7.     RadeonSensor.kext
  8.     ResistrictEvents.kext
  9.     SMCRadeonGPU.kext
  10.     WhateverGreen.kext
  11.      XHCI-unsupported.kext 


***I have attached both the DSDT.aml file with the .plist file for those of you with the same board I have. 

There is no s/n present in the file, so you'll have to generate your own board info using OCAuxiliaryTools***






Screen Shot 2022-03-23 at 8.09.45 PM.png

Screen Shot 2022-03-23 at 8.10.11 PM.png

Screen Shot 2022-03-23 at 8.10.52 PM.png

Screen Shot 2022-03-23 at 8.11.55 PM.png

Screen Shot 2022-03-23 at 8.12.38 PM.png

DSDT.aml config.plist

Edited by CJWKOREA
  • Like 6
  • Thanks 1
Link to comment
Share on other sites

If u banned from there ure a lucky guy. Tony is one of the big nab with non-sense tools, non-vanilla way and a bunch wrong informations about that. Just relax and enjoy here, this is the house of x86. ;) 

  • Like 7
  • Thanks 1
Link to comment
Share on other sites

Thank you for welcoming me to the forum. I will be posting more info in the above post shortly. 


Just doing a bit of system optimization - Below is a picture in Cinebench with a score of 13244, this is doing an XMPII Overclock with a base clock at 5.1Ghz and 4.6Ghz on all cores. 

I am pretty sure I can do more and go back up to my record thus far of ~16,200

Screen Shot 2022-03-24 at 1.24.55 AM.png

Edited by CJWKOREA
  • Like 2
Link to comment
Share on other sites

Today I thought I'd have a go at putting my build through processing various RAW video formats. While I can get 64FPS in RAW 8K 12:1, 8:1 it fails at 5:1 and 3:1. 

The GPU blows through all of these tests at respectable 231FPS at BRAW3:1.   


For a SBS comparison I'd like to see what this benchmark reveals about the Mac Studio with either M1 processor variants. 



- Today I went to the Apple store and did a Blackmagic RAW test against the Mac Studio Pro -- The results were interesting to say the least. 

The top of the line Mac Studio is roughly equivalent to a Nvidia RTX 3070 in terms of processing RAW video in terms of H265 and H264 processing. 

Processor wise the raw CPU score seems to max out around the 16,300 mark in Geek Bench. Roughly the same as a i9 7980X or AMD R9 5950 

I don't know where the 24,000 figure came from but the performance to me was rather lacklustre for a  $4000+ brick. 


hmm... Also none of the external TB3 eGPUs or audio processing devices will work on the Mac Studio...    Pretty silly.. but again we are dealing with control freak Apple here, one of the largest eWaste contributors going.    




Screen Shot 2022-03-25 at 9.52.40 PM.png


Without much effort getting a passmark of 24,884  -  Still more optimization to do. 



Edited by CJWKOREA
  • Like 2
Link to comment
Share on other sites

While running a Thunderbolt 3  adapter for a type 2 Gigabit ethernet to TB  adapter, I ran in to some odd reporting with the system.  The Thunderbolt ports are not reporting the TB2 adapter nor the Ethernet adapter.  

The front port which is a USB 3.1 port shows the adapters but warns me that this Mac is not Thunderbolt capable.  Odd since the device shows in the PCI list as a Thunderbolt hub. 


Anyone here experience this?  Vt-d is on and  thunderbolt security is disabled in the BIOS. 



Thunderbolt 4 Bridge  - Maple Ridge 4C 2020 


IOService:/AppleACPIPlatformExpert/PC00@0/AppleACPIPCI/RP05@1C,4/IOPP/UPSB@0/IOPP/DSB1@1. (This device is disabled)  








When in Windows 11,  The thunderbolt ports  (2 of them) show up as PCI Slot 8 , BUS 11, Device 0  




Odd, since a regular USB3.2 type C works fine. 



Link to comment
Share on other sites

Anyone have a solution to the Thunderbolt behaviour?

Link to comment
Share on other sites

I was under the impression that there was a firmware patch that changed the controller from passively detecting a TB device to enabling it into an always on state for Hotplugging like Apple hardware does. 


Edited by CJWKOREA
Link to comment
Share on other sites

On 3/28/2022 at 6:45 AM, Slice said:

There is a conflict between Thunderbolt by Intel specification and Thunderbolt by Apple specification.

Your hackintosh uses Intel hardware but Apple OS.

Both Apple and Intel co-developed Thunderbolt - the limitation is in the firmware and I see there is a patch to allow hot plugging which brings hotplugging to .  


17 hours ago, MaLd0n said:

for this option u need ssdt by KGP and bios/uefi config is: GPI03 enable and User Autorization  disable

SSDT-TB3HP.aml.zip 2.08 kB · 5 downloads


I tried the steps outlined here. The Thunderbolt device shows up in the PCI devices area of the system Report, but the adapter doesn't show in the network sections.  I am using an adapter Thunderbolt3/4 adapter with an Ethernet adapter at the other. IT should show up in the networking area as a Thunderbolt -Ethernet Bridge.   Nothing shows. 

I can confirm that his shows up under Windows 11 as Ethernet 4.  No issues what so ever. 



- Other things -- I have remapped my USB ports as there was an issue with the front ports no running at full speed.  I now have all ports working at their designated speeds. 

I used a tool called USB map master which runs a python script to generate a USB map kext. 

Worked beautifully ! 

Ethernet issues are now solved as well using IOPCIFamily.kext




USBMap-master.zip IOPCIFamily.kext.zip

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Just got a Laird connectivity BT5.1 Module from Digikey. So far I am unable to get it to communicate with MacOS. BL654 - It is supposed to be compatible with MacOS

though when plugging it in, there is no sign of the BT module in the profiler. 


 Anyone else using the same device? 

Link to comment
Share on other sites

  • 3 weeks later...

And after MacOS 12.3.1 was released I now have a brick.  The system update contains what I believe is a security update that purposely targets Kaspersky and causes a CPU and task error.  I did not have this with MacOS 12.2.1....  Very suspicious! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...