Jump to content

Help: The mystery of the inexplicable underscan (shrinking desktop)


1 post in this topic

Recommended Posts


I have a system (see profile) that runs flawlessly. I have two 4K monitors connected: 
• A Philips BDM4350UC 43" (main monitor) and an ASUS ProArt 32" display (secondary). Both worked like a charm at 4K.
• Both connected via Displayport

• Both running from the GTX1080ti

• Bootloader: Clover, updated yesterday by expert (not me)
• Webdriver ON

• Nvidia web driver: 387.


Yesterday I swapped my broken 43" Philips BDM4350UC with an identical, newer model.
The moment I plugged it in, the problems started.
The Philips monitor works fine, but the ASUS now has a black space/frame around the desktop. Looks like the desktop is too small for the display.
I believe the technical term is "underscan". 

What I have done so far:

• Fiddling with the Display settings in System Settings, but nothing changes.
• Used "option" when pressing the "scaled" radio button to access more resolutions, but I still can only get a max of 2560x1440 on the ASUS.
• Tried using the SwitchResX app, but that didn´t help either
• Unticking the "overscan" box for the Philips monitor creates all sorts of issues, like stretched screen, low resolution etc. It also makes the "overscan" function disappear and requires a reboot to get back
• Swapping cables only results in either both monitors suffering from underscan, or resolutions getting worse/lower
• I have tested other, new cables incl. HDMI. No difference

• Both monitors have an Overscan function you can switch off and on, but for some reason it´s greyed out and not accessible.

• Both monitors were reset to factory settings

After doing extensive research, I found out that the preferences could be the issue, so I deleted all files related to the display settings: 
• com.apple.windowserver.plist

• com.apple.windowserver.XXX-XXX-XXX-XXXXXX.plist
• Deleted them both from the Preference folder and "ByHost" folders.
• Rebooted. No change.

It seems the .com.apple.iokit is responsible for allocating screen sizes and placement, and also for underscan and overscan.
I have found both scripts and tips that potentially could help with the issue, but the lines of code I am supposed to change are not present in my particular com.apple.iokit file. 
The code/key in question is called "pscn" and the following integer apparantly controls the underscan/overscan of each monitor.
In my com.apple.iokit file it´s called "oscn" instead of "pscn", which (not sure) might refer to a TV instead of a monitor.
I believe the 43" Philips monitor is identified as a TV by MacOS, so maybe that´s part of the solution.


Either way, the code in my file looks like this:


When the key in question is called "pscn", the integer value should be 10000 for no over or underscan.
Any number lower than 10000 results in underscan (smaller desktop) and any number bigger than 10000 results in overscan (larger desktop).


My "oscn" key doesn´t use the same values, but instead 0 and 1, which I assume refers to overscan being off(0) or on(1).

I am afraid to start messing around with this file, since it´s not a pref file, and supposedly doesn´t automatically get generated after reboot, and I´m not very keen on making things worse.

Please let me know if anyone has some input that might be of help.
• Maybe SwitchResX will do the trick - I just couldn´t make it work, so input is very welcome
• Anything else?

Thanks a lot in advance :)

Edited by BauerMac
Link to comment
Share on other sites


  • Create New...