Jump to content

GA Z590M + i5-11600k: Sleep Issues


14 posts in this topic

Recommended Posts

Hi all.

This is my third build, the last two were perfectly smooth, but this one has been giving me a lot of headache (I saw it coming when I chose the parts…).


Current build:

* Gigabyte Z590M Gaming X

* i5-11600k

* Sapphire RX 580 Nitro

* Fenvi HB1200

* Crucial Ballistix (4x8GB)

* Corsair 4000D

* Master Cooler ML240L V2


Everything went pretty well so far, and sleep seems to be the only issue I’ve been having, otherwise the system is a monster, huge upgrade form my H170N Wifi + i5-7400.


What happens is: I put the system to sleep, wake up and it’s fine. When I put the system to sleep for the second time, as soon as I press a keyboard key to awake it, the system reboots (or maybe boots, don’t know) and get the Bios screen, and follows to load Opencore.


I’m using the iMacPro1,1 SMSBios, since it seems to be the most appropriate once I don’t have iGPU (no support for Rocket Lake so far).

What I have tried so far:


1. USB port mapping both with USBMap and Hackintool (both AppleUSBHostMergeProperties and USBMergeHub). Initially I had installed 11.6.1, and later downgraded to 11.2.3 just to make sure the ports were ok. Keeping below the 15 limit, setting my wifi/BT card as internal, usb-c as 9 and usb3/2 with the right config.

2. Fixed `pmset` configuration, using `hibernatemode 0`, `proximitywake 0`, `powernap 0`, `tcpkeepalive 0`.

3. Enabled/Disabled AppleALC (not audio without it), currently using layout-id 11 for the ALC897 my board has

4. Tried with/without CPUFriend and CPUFriendDataProvider. Tried with a few different combinations for low TDP.

5. Tried with/without RTCMemoryFixup.kext

6. Tried with/without CPUTscSync

7. Tried different combinations of the kexts mentioned

8. Tried a SSDT that changes the _PTS and _WAK method

9. Tried RehabMan _PTS _WAK SSDT patch

10. Tried with/without NVMeFix

11. Tried enabling/disabling DisableRtcChecksum

12. Tried different combinations of CpuCFG/XcpCFG lock


Bios seems ok: using F6 (last version), VT-d, CFG, CSM, Fast Boot etc all off. Handoff, AHCI, all on.


Every time, the same thing happens. As soon as I boot, I get 1 working sleep/wake cycle. The second always awake to a reboot.

My `pmset log` shows something like:


2022-01-21 01:13:04 -0300 Sleep                   Entering Sleep state due to ‘Software Sleep pid=163’:TCPKeepAlive=active Using AC (Charge:0%)
2022-01-21 01:13:07 -0300 Wake Requests           [*process=mDNSResponder request=Maintenance deltaSecs=6061 wakeAt=2022-01-21 02:54:08 info=“DHCP lease renewal”] [process=powerd request=UserWake deltaSecs=258729 wakeAt=2022-01-24 01:05:17 info=“com.apple.alarm.user-visible-Weekly Usage Report,319”]
2022-01-21 01:13:07 -0300 PM Client Acks          Delays to Sleep notifications: [com.apple.apsd is slow(2907 ms)]

 ## This is the moment I press a key to wake the system
2022-01-21 01:14:54 -0300 ShutdownCause           SMC shutdown cause: 5: Software initiated shutdown
2022-01-21 01:14:55 -0300 HibernateStats          hibmode=0 standbydelaylow=0 standbydelayhigh=0                                           0
Sleep/Wakes since boot at 2022-01-21 01:05:13 -0300 :0   Dark Wake Count in this sleep cycle:1
2022-01-21 01:14:55 -0300 Failure                 Failure during sleep: 0x0000001F : EFI/Bootrom Failure after last point of entry to sleep
Sleep/Wakes since boot at 2022-01-21 01:05:13 -0300 :0   Dark Wake Count in this sleep cycle:1
2022-01-21 01:14:55 -0300 Start                   powerd process is started
2022-01-21 01:14:55 -0300 Assertions              Summary- [System: No Assertions] Using AC
2022-01-21 01:14:58 -0300 Assertions              Kernel Idle sleep preventers: IODisplayWrangler


What I find really strange is that it is a “normal” software initiated shutdown. It seems that this code (5) is the one used by Apple when you click “Shut Down”, as if everything was ok. But then I get the error “Failure during sleep….”. When looking at the timestamps this actually happens only after I press the key on my keyboard, and not actually during sleep.


I must be doing something wrong somewhere, but I just can’t pinpoint where, and my investigations so far were not very helpful.


To make it worse, I can’t find much information on this board/cpu model, and much of the “traditional” sleep issues fixes don’t seem to work.


Any ideas on what I might be doing wrong?




ioreg.zip EFI.zip

Link to comment
Share on other sites

Thanks @MaLd0n


Is there any difference to the USB Mapping process? I just added the EFI you linked, mapped my USB ports, but it doesn't seem to be working - when removing the XHCIPortLimit / InjectAll / XHCI-unsupported, even with the USBPorts.kext enabled all ports stop working and I have to boot with an USB drive. I'm on 11.2.3. What seems to be weird is that USB2 get confused with USB3, even though the mapping correctly points to each one of them.

EDIT: Seems to work with the XHCI_Unsupported Kext (without the InjectAll) and the USBPorts. I wonder how will this behave with an update, but seems to be fixed for now.


Sleep seems to be working, still need more testing, but seems ok. It did got stuck in a black screen one of the times (even though the bluetooth mouse was working), but still too early to point it as an issue.

The other thing I noticed is that at every boot I get an AppleID error, still have to do more research on that.




Edited by lowercase00
Link to comment
Share on other sites

use ssdt uiac with USBInjectAll.kext and XHCI-unsupported.kext. with this way u can change smbios, etc and dont need change nothing

USBPorts and XHCI-unsupported.kext work good too

these kexts is updated and have support for tiger lake, alderlake, etc ;) 

btw generate new smbios with good serial for u

if need a good fine tune Post one Full Dump

Link to comment
Share on other sites

@MaLd0n thanks, this one also didn't work. I'm generating the serial and SMBios info from Opencore Configurator, I'll try a few more methods to see how it goes.

If you don't mind, any references you could point to, to help understand what's going on with the DSDT you sent? I did a DiffMerge, but I was curious on how did you know what methods to change, and what to change in each method.

I totally understand this is not a simple answer at all, so if you could just point to resources that could help me understand what's going on would be great.


Link to comment
Share on other sites

41 minutes ago, lowercase00 said:

If you don't mind, any references you could point to, to help understand what's going on with the DSDT you sent? I did a DiffMerge, but I was curious on how did you know what methods to change, and what to change in each method.

just one real vanilla with apple devices, unused devices is removed, etc. like one real mac. not a basic and generic config

i made it since 2006. i have all chipsets inside my brain 😝

a good way start here with us with dsdt editor and patcher, dsdt auto patcher and others


Link to comment
Share on other sites

23 minutes ago, lowercase00 said:

This is the error. Sometimes is iMessage, sometimes is iCloud, or FaceTime or something related to the iServices

The black mark is the iCloud email account.



One of the possible reason is your account solvency. Check it.

  • Like 1
Link to comment
Share on other sites

Hi @Mald0n


It seems that the iCloud message information is fixed after clearing bios, deleting files in preferences and changed serial.


So I ran some tests, and couldn't quite figure out the sleep behavior. The screen enters standby mode, but I noticed that at times the case fans and lights stays on, which seems strange.

I couldn't figure out when that happens, it would need more debugging.


I ended up finding an SSDT from a user on reddit, that completely fixed the issue. I'm not too sure exactly what the problem was, SSDTs and DSDTs are still very complex for me, but I'll try to learn slowly (thanks for the link btw!).

I'm attaching the current SSDT I'm using (the only one actually), that completely fixed the system.


Kexts and Plist is pretty much standard (Lilu, WEG, SMC, USBMap etc), so I'll leave it here if anyway finds this in the future.

Thanks a lot for you help!


Link to comment
Share on other sites

Have a two ways

1- Basic state with SSDTs to boot into windows. People like SSDTs, don't need knowledge about nothing. Just ctrl-c + ctrl-v.

1- Full solution with high level ACPI, etc with one good full DSDT patched, but with Opencore boot into windows don't work with this way. We killed all unused devices, etc and Windowsn need these devices, MacOs no.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...