Jump to content

[Catalina] Cannot connect to ethernet with Realtek adapter


E__Man
 Share

4 posts in this topic

Recommended Posts

Hello,

I know this is a common problem, but none of the solutions I found fixed it.
I can't get my ethernet adapter to work on Mac Os Catalina. It is working fine with Windows (installed on a separate partition and on other computers)

Adapter model: Realtek PCIe FE Family Controller VEN_10EC&DEV_8136&SUBSYS_1844103C

After install, the adapter was simply not detected at all. The ethernet interface was not available in network settings and the adapter did not appear in "system information".

LucyRTL8125Ethernet and Mieze's RealtekRTL8100 kext drivers had no effect.
I finally managed to get the adapter detected thanks to AppleRTL8169Ethernet.kext. An automatic Ethernet configuration was created in network settings.

BUT: I can't access to the internet. The cable is said to be unplugged. If I change the ethernet configuration, the message randomly changes to "Auto-assigned IP address", no matter whether the cable is plugged in or not.
I tried with several cables (all working on Windows).

During boot, white LEDs are on around the ethernet port (this is a normal behaviour) but they shut down at the end of the boot process (they should remain on).

I tried to enable or disable network boot in BIOS, to check/uncheck "allow the computer to turn down the device to save power" in Windows's device manager, but nothing works...
 
NB: Same problem with Hackintosh 10.8 Mountain Lion...
 
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...