Jump to content

How to hide Windows 10 in Bootpicker?


13 posts in this topic

Recommended Posts

I have found out that using F12 during boot-up is the easiest and safest way to select between OSx and Windows 10. If bootpicker boots into Windows 10 via OpenCore, this can really screw up Windows 10.

 

So is there a way to hide the Windows 10 item on opencore bootpicker? I think I have read something about scan policy.... is there a way to exclude scanning the Windows 10 disk? (I have Windows 10 on a separate SSD. NTFS).

 

 

Thanks.

@mengshi  The guide you listed earlier   https://kextcache.com/opencore-dualboot-guide/
is valid or you have entered the wrong path, or instead of entering   /\EFI\Microsoft\Boot\bootmgfw.efi    you have to enter like this
PciRoot (0x0) / Pci (0x17,0x0) / Sata (0x2,0xFFFF, 0x0) / HD (1, GPT, 0000014D-3110-1321-230C-D7019A020000,0x800,0xADE81) / \ EFI \ Boot \ bootx64.efi

 

to prevent OC from injecting values into Windows I set this in
Kernel> Quirks> CustomSMBIOSGuid> True (default is False)
PlatformInfo> UpdateSMBIOSMode> Custom (default is Create)

 

I boot with OC 3 systems in 3 separate disks with no problem, I promise I don't use DSDT

 

if you want to hide Windows from opencore bootpicker you can change the scanpolicy value https://oc-scanpolicy.vercel.app/
and use the f12 option to boot into Windows

 

at this point it no longer makes sense to use OC bootpicker

since you only have to start the hack you can disable it , from the plist ShowPicker = NO set the Timeout to 1  sec. set macos boot disk  as default  and you will have a direct boot  

Edited by antuneddu
9 hours ago, antuneddu said:

@mengshi  The guide you listed earlier   https://kextcache.com/opencore-dualboot-guide/
is valid or you have entered the wrong path, or instead of entering   /\EFI\Microsoft\Boot\bootmgfw.efi    you have to enter like this
PciRoot (0x0) / Pci (0x17,0x0) / Sata (0x2,0xFFFF, 0x0) / HD (1, GPT, 0000014D-3110-1321-230C-D7019A020000,0x800,0xADE81) / \ EFI \ Boot \ bootx64.efi

 

to prevent OC from injecting values into Windows I set this in
Kernel> Quirks> CustomSMBIOSGuid> True (default is False)
PlatformInfo> UpdateSMBIOSMode> Custom (default is Create)

 

I boot with OC 3 systems in 3 separate disks with no problem, I promise I don't use DSDT

 

if you want to hide Windows from opencore bootpicker you can change the scanpolicy value https://oc-scanpolicy.vercel.app/
and use the f12 option to boot into Windows

 

at this point it no longer makes sense to use OC bootpicker

since you only have to start the hack you can disable it , from the plist ShowPicker = NO set the Timeout to 1  sec. set macos boot disk  as default  and you will have a direct boot  

 

OK. I will try again. Do you mind teaching me how to use the Map command in Openshell to capture the display output into a text file?

 

Thx

 

10 hours ago, mengshi said:

I have found out that using F12 during boot-up is the easiest and safest way to select between OSx and Windows 10. If bootpicker boots into Windows 10 via OpenCore, this can really screw up Windows 10.

 

So is there a way to hide the Windows 10 item on opencore bootpicker? I think I have read something about scan policy.... is there a way to exclude scanning the Windows 10 disk? (I have Windows 10 on a separate SSD. NTFS)...

 

 1. If you set this 2 keys in config.plist, you can boot Windows safely from OpenCore:

Kernel > Quirks > CustomSMBIOSGuid > True (default False)
PlatformInfo > UpdateSMBIOSMode > Custom (default Create).

 

2. Red this: https://oc-scanpolicy.vercel.app (it's the same place that @antuneddu told you). You must pick a value that hides NTFS and EFI. Rest of choices, to your liking.

Edited by miliuco
56 minutes ago, miliuco said:

 

 1. If you set this 2 keys in config.plist, you can boot Windows safely from OpenCore:

Kernel > Quirks > CustomSMBIOSGuid > True (default False)
PlatformInfo > UpdateSMBIOSMode > Custom (default Create).

 

2. Red this: https://oc-scanpolicy.vercel.app (it's the same place that @antuneddu told you). You must pick a value that hides NTFS and EFI. Rest of choices, to your liking.

 

 

Part 1. - meaning I don't even have to add those PciRoot stuff in  Entries under Misc?

15 minutes ago, mengshi said:

 

 

Part 1. - meaning I don't even have to add those PciRoot stuff in  Entries under Misc?

that serves to not inject OC values into other systems

2 hours ago, antuneddu said:

that serves to not inject OC values into other systems

 

Hmmm.

 

Tried what you suggested. ( This is with Kernel > Quirks > CustomSMBIOSGuid > True;
PlatformInfo > UpdateSMBIOSMode > Custom ). This is what happens....

 

1. Using the Misc->Entries and entering the PciRoot....stuff, I named it Windows 10, on selecting it, Windows straight away says Preparing Automatic Repair which spells trouble. So I shutdown and restarted into OSX.

 

2. Without the Misc->Entries...PciRoot stuff but having Kernel > Quirks > CustomSMBIOSGuid > True;PlatformInfo > UpdateSMBIOSMode > Custom ->Using the Window entry automatically detected by Bootpicker -> on selecting it, there was a bring Windows spinning circular dot and then black screen.

 

 

What am I doing wrong?

 

 

 

  • Sad 1
41 minutes ago, mengshi said:

 

Hmmm.

 

Tried what you suggested. ( This is with Kernel > Quirks > CustomSMBIOSGuid > True;
PlatformInfo > UpdateSMBIOSMode > Custom ). This is what happens....

 

1. Using the Misc->Entries and entering the PciRoot....stuff, I named it Windows 10, on selecting it, Windows straight away says Preparing Automatic Repair which spells trouble. So I shutdown and restarted into OSX.

 

2. Without the Misc->Entries...PciRoot stuff but having Kernel > Quirks > CustomSMBIOSGuid > True;PlatformInfo > UpdateSMBIOSMode > Custom ->Using the Window entry automatically detected by Bootpicker -> on selecting it, there was a bring Windows spinning circular dot and then black screen.

 

 

What am I doing wrong?

 

 

 

if you want to try

in the entries you have to flag enable
secureboot set default
launcheroption set disable

7 minutes ago, antuneddu said:

if you want to try

in the entries you have to flag enable
secureboot set default
launcheroption set disable

 

launcheroption disabled will not prevent Windows from screwing up opencore? Or what should I be aware off in order not for Windows to screw up opencore? (I had the flag enabled to try out

@mengshi

It has nothing to do with Windows but you have USBMap.kext and XhciPortLimit=Yes, put XhciPortLimit=No.

 

It also has nothing to do with your problem but the Opencore developers currently recommend RestrictEvents.kexts (instead of CustomMemory) so that the memory in About this Mac is displayed correctly when using MacPro7,1. If you decide to change, install a recent version of RestrictEvents, set CustomMemory=False, and remove the Memory section.

 

What the 2 quirks that I have mentioned (CustomSMBIOSGuid and UpdateSMBIOSMode) do is prevent OpenCore from passing SMBIOS data to Windows, nothing more, it avoids problems that can happen when Windows starts from OpenCore but they do not influence the problem you have.

 

Regarding the Windows entry, the UEFI path that you have in config.plist seems fake, it is the same as the example that comes in Sample.plist

PciRoot(0x0)/Pci(0x1,0x1)/Pci(0x0,0x0)/NVMe(0x1,11-22-33-44-55-66-77-88)/HD(1,GPT,00000000-0000-0000-0000-000000000000,0x800,0x64000)/\EFI\BOOT\BOOTX64.EFI

You have to create your own UEFI path, the one that actually points to the device that has the Windows boot loader on your PC.

How? Keep reading :)

 

[HOW TO] Custom entry in OpenCore to boot Windows

 

Edited by miliuco
Posted (edited)

Thanks a lot for the help. (BTW, have installed Restricevents.kext. My USB mapping solution has already been posted in another thread. It works so I'm not changing this :))

 

Actually my path is correct. I wasn't using the one you pointed out. I just didn't enable it when it didn't work and sent you the config.plist

 

But it still doesn't work. Same issue as previously. Even with secureboot enabled or the launcheroption disabled.

 

Same problem - with the above option, selecting the option immediately puts Windows into Automatic Repairing Windows.

 

By the way, even without doing above, opencore automatically already detects a Windows boot option (https://dortania.github.io/OpenCore-Multiboot/oc/win.html) . So I was not using this entry by the way. Even if the above method works, I will end up having 2 windows options in bootpicker. LOL.

 

My Windows resides on a separate SSD and was installed using the GPT method via rufus.

 

Back to using F12.....

Edited by mengshi
×
×
  • Create New...