Jump to content

My TPlink WDN 4800 stopped being recognized by the system after 10.14.6 update


5 posts in this topic

Recommended Posts

Now I get the dreaded x inside the wifi icon with the message no hardware installed. To make things worse, my hackintosh has been running smooth and stable for so many years that I don’t remember anymore how I made the card work in the first place.

I tried a solution from the kext section of the site to no avail. Then I went crazy with hacks, trying to use high sierra’s that was in my time machine. And now I don’t even have the vanilla 10.14.6 IOUSBFamily.kext to try from scratch anymore. Btw if someone could upload it it would be nice.

I hazily remember (yes, it has been a long time since I had to tweak anything in my machine) that when messing with /S/L/E there were some procedures about prelinked kernels that should be performed: how do we install modified kexts in /S/L/E in mojave and get them to work for that matter? Is there a solution that doesn’t involve booting from recovery or another partition? By the way I set my clover Variables config to 0x67 - how do I check via terminal if it actually worked and SIP (another think I hazily remember) was disabled?

All in all, I use Clover, so please (and don’t take offense with me asking this, please) don’t suggest me LiLu or OpenCore or any “more modern” fix since I’d have to learn it from zero and I (currently) simply don’t have the time needed for it. The ideal solution would be a kext I could simply install on /S/L/E or /L/E without messing with my current bootloader and/or config plist.

Many thanks!

The manual process required to install kexts in /S/L/E or /L/E has been documented, published, listed and re-listed hundreds or thousands of times over the last decade on the numerous Hackintosh forums that exist:

sudo chmod -Rf 755 /S*/L*/E*
sudo chown -Rf 0:0 /S*/L*/E*
sudo chmod -Rf 755 /L*/E*
sudo chown -Rf 0:0 /L*/E*
sudo touch -f /S*/L*/E*
sudo touch -f /L*/E*
sudo kextcache -i /

The manual method is, in my opinion, better than old tools that can date back to old Snow Leopard days and therefore tend to be deprecated.

 

Your TP-Link wireless card appears to be based on an Atheros chip. Can't say which one specifically so you'll have to tell us from, say, IOReg. By now, you should know that Apple dropped all support for Atheros cards in Mojave and later. Updating Mojave to 10.14.6 would have re-instated the vanilla IO80211Family kext that you probably had replaced or patched in /S/L/E in order gain to support for your wireless card.

 

Once you know what Atheros chip/model you have, you may consider applying the usual fix consisting of installing the deprecated Atheros40.kext, knowing that you may also need to add your card's id to the kext or declare compatibility with a model supported by the kext. In order to save you the same trouble again with all future Mojave Security Updates, I recommend that you install the kext in /L/E as described here so that you avoid patching/replacing IO80211Family kext in /S/L/E and retain your wireless capability after any future Mojave update. Alternatively, you may install the patched kext available here in /L/E (ignore the part about min kernel, this applies too OpenCore). Normally, you would not require any injector kext.

 

You'll find out how to check SIP status with a little Google search.

 

Re: vanilla IOUSBFamily kext (or any other vanilla file to that effect), know that you can use Pacifist app to extract it from the last Mojave combo update available for download off Apple's web site. Just Google for it.

×
×
  • Create New...