Jump to content

Samsung Notebook Plus NT350XCR 10210u - Lidwake Not Working


1 post in this topic

Recommended Posts

Posted (edited)

Hi, a insanelymac newbie who just joined here.

I have successfully installed hackintosh on my laptop recently. I had to fake the cpu id from A0660 to 806EC to boot up the kernel.

 

But, opening the lid when the machine is sleeping does nothing. I have to press power button for 5 sec to wake it from sleep. If I lift the lid before the fans stop, screen turns on.

 

Also, before it goes to sleep, idle package power is near 1.4~1.6w.

However after waking up from sleep, idle package power is 2.5w+.. It goes back to normal when I perform a Hard Reboot.(Just turning the machine off and turning back on)

I don't know if this is related to my lidwake issue, but still I need to solve this too..

 

Idle power before going to sleep:

611510779_2021-05-265_31_56.thumb.png.c2177108a3af26e9339f4069ff282839.png

 

Idle power after waking up from sleep:

41850970_2021-05-265_25_48.thumb.png.804e167c97f2ca800e75f639ab617b87.png

 

What I tried so far:

 

  • Tried WEG's FBAlternatePWMIncrement1/2 flags with ACPIPoller.kext ->Did not work.

 

  • Tried adding _PRW method to the lid0 device with DSDT->Able to see lid wake option when pmset -g, but did not work either. 
Return (GPRW (0x69, 0x04))

This did nothing except showing lidwake when pmset -g.

Just copying _PRW method from Power Button made it wake up at pressing the power button once, but still nothing with lid waking.

Tried to copy from Sleep Key, but I don't have one in my DSDT.

 

  • Tried SSDT-GPRW.aml with GPRW to XPRW renaming-> Did not work, makes the machine randomly freeze

 

  • Tried PEGP to GFX0 renaming beacause the boot log always showed ACPI error about ^^RP05.PEGP-> Did not work, but I don't see those errors anymore. Is it okay to just use it?

 

Specs:

Model: NT350XCR (Samsung Notebook Plus)

CPU: i5-10210u CPUID A0660 faked to 806EC

SSD1: pm991 oem (Disabled via SSDT_NVME-Pcc.aml, Win10)

SSD2: MX500 (Hackintosh, Big Sur 11.4)

WLAN: AC9462

LAN: RTL8168

Audio: ALC256

RAM: 8GB DDR4 x1

 

My original DSDT from OpenCore SysReport

DSDT.aml

 

My EFI's OC folder (Removed SMBIOS infos, Removed all kext files due to upload size limit, version 0.6.9)

OC_upload.zip

 

Looks like it happens to other comet lake samsung laptops. e.g. GalaxyBook Flex, GalaxyBook Ion

Would be glad if someone could solve this.. :D

Edited by Nix_SH

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...