Jump to content

Voodoo HDA audio and screen lighting setting not working on BS 11.3.1


19 posts in this topic

Recommended Posts

Posted (edited)

Hello,

I have an issue after BS 11.3.1 installation from scratch. I use Clover R5133 on my toshiba satellite L50B : core i7 and Intel HD4400, Audio is connexan hardware who worked only with voodoo HDA, never succed to make it to work with apple HDA extension.

 

Both worked properly with Catalina and after i updated to BS, i went to BS 11.2.3 with updates, but had a reboot issue with 11.3.1 update, so i decided to clear all and installed BS 11.3.1 from scratch.

 

All is working properly, except Voodoo HDA audio, HDMI audio/video output and screen lighting setting who are not working anymore. (Night shift option is ok). Here is my EFI folder.

 

for audio, I removed voodooHDA 2.9.2 release i tried first and installed voodoo for clover R2.9.6, but same issue, same result with 2.9.7.

When i try to launch voodooHDA prefpanel, it says impossible to load panel.

 

Capture d’écran 2021-05-17 à 10.00.43.png

Capture d’écran 2021-05-17 à 10.01.46.png

Capture d’écran 2021-05-17 à 10.02.13.png

Capture d’écran 2021-05-17 à 10.03.07.png

EFI.zip

Edited by zazman

It's quite strange that your screen is reported as an external display and with 2 x entries in SysInfo->Graphics. Something's not right there yet I could not see anything wrong in your setup: you inject the right properties and the SMBIOS of a Haswell MacBookPro though I'd have used the MBP11,1 or MBA6,2 (both dual core/Haswell graphics) rather than MBP11,3 (quad core/nVidia + Haswell graphics).

 

HDMI output usually attaches to Azul framebuffer connector/port con1. You can check that in IOReg with apps such as IORegistryExplorer but this requires to be patch to avoid system freeze on HDMI cable connection/disconnection. By default con1 is defined as a DP port. See WEG user manual for details.

ID: 0A260006, STOLEN: 32 MB, FBMEM: 19 MB, VRAM: 1536 MB, Flags: 0x0000000F
TOTAL STOLEN: 52 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 116 MB, MAX OVERALL: 117 MB (123219968 bytes)
Camellia: CamelliaDisabled (0), Freq: 2777 Hz, FreqMax: 2777 Hz
Mobile: 1, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[0] busId: 0x00, pipe: 8, type: 0x00000002, flags: 0x00000030 - ConnectorLVDS
[1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x00000087 - ConnectorDP
[2] busId: 0x04, pipe: 9, type: 0x00000400, flags: 0x00000087 - ConnectorDP
00000800 02000000 30000000
01050900 00040000 87000000
02040900 00040000 87000000

 

Your config is missing the necessary properties injection that patch the Azul framebuffer for HDMI audio: you need to set con1 Pipe to 0x12 and con1 Type to HDMI 0x00000800:

framebuffer-con1-enable     1                           NUMBER
framebuffer-con1-alldata    010512000008000087000000    DATA

 

A few other things to adjust in your config would be:

  • ACPI section: the renaming of EC0 and H_EC to EC; those are deprecated and you should remove them in favour of a SSDT-EC table injected in the ACPI/patched folder of Clover.
  • Devices section: iGPU id faking not required, it's already in the injected properties. Remove this.
  • Devices section: ## lines for properties injection against your iGPU@2 are incorrect; only use one (1) # character only.
  • Devices section: you've commented out the layout-id injected for your HDEF device but ket injection of layout 3 (you'll see this if you open up your config with Clover Configurator app).
  • Graphics section: no need to Inject Intel and specify the Azul framebuffer here; you use Lilu and WEG kexts and they handle all that. Remove those settings.
  • Kernel & Kexts Patches section: I don't think you need those binary patches in KerneltoPatch sub-section. I'd 1st disable them, then remove them once proven useless.

Re: audio, are you sure this Toshiba is fitted with Connexant audio? If you have Windows, check the reported device id in Device Manager->Driver details. One thing worth trying for audio is apply the FixHPET Clover fix. Failing that, inject a patched HPET device in a dedicated SSDT and rename HPET to XPET in your config.

 

What's the exact model reference of that Tosh L50-B ?

Posted (edited)

Thank you for all explainations,

 

The exact reference of my computer is : Satellite L50-B-1N2, part number PSKTAE-09000QFR.

The second line of config/Graphics reports to the second internal GC, AMD Graphic chipset, not used, never been working in MacOS (no kext loaded).

The sound chipset is identified as Conexant in Clover boot menu/option/audio setup (tested and working with F7 key into clover).

 

I tried to manage other things in config.plist you mentioned, but same issue.

 

For HDMI, how and where can i modify this, is it possible to manage it in clover configurator app  ? :

 

Quote

Your config is missing the necessary properties injection that patch the Azul framebuffer for HDMI audio: you need to set con1 Pipe to 0x12 and con1 Type to HDMI 0x00000800:

framebuffer-con1-enable     1                           NUMBER
framebuffer-con1-alldata    010512000008000087000000    DATA
Edited by zazman

Ok, you never mentioned that dGPU before so could not know about it; you should disable it through BIOS or patched SSDT so that it does not drain your battery.

 

Sorry for I had assumed you had made up your own config and would know what I was talking about, at least after reading the WEG user manual. Anyway, these HDMI properties injection go along your existing injected iGPU properties in your Clover config (Devices section). Of course what I gave you is literally what you add in Clover Configurator app.

You're right, i do not manage a lot my configuration so i ask for advices for several years. I never succed to desable AMD GPU (not possible in BIOS) and yes it drains a lot my battery, so i more often use power adapter.

About location of the HDMI properties injection, I think someone sent me a config.plist file to test and i copied injection in my config file, but i have to admit i don't really know where injection taking place in clover configurator.

If we speaking of  fake ID in devices section (where is iGPU properties at Intel GFX), i don't read anything mentioning HDMI, except UseIntelHDMI in the right side's panel,  so i'm sorry to say i'm lost.

 

I cleaned my config.plist as you told me but i still having same issues, no sound, no screen lighting management. Maybe an older Lilu and WEG release may work ? Or i could try another SMBIOS, like MBP11,1,  i changed it to be compatible with MacOS BS as i moved from catalina.

 

It's weird my config did work well  with Catalina 10.7 and BS 11.2.3, what could explain that ? 11.3.1 install from scratch ?

Add the HDMI connector properties here in CC (Devices tab), once you've cleaned up your config as per my previous recommendations:

iGPU_Properties_CC.jpg

 

For audio, you're gonna have to identify the Conexant codec if you want get anywhere. Should be shown in Device Manager, Driver details->Ids if you still have Windows on that laptop.

 

Presumably, your CPU is i7-4510U and dGPU is AMD Radeon R7 M260. You should add your system's specs in signature.

OK thank you, i will inquire about conexant HDA, unfortunately no windows, but i will have a look with a linux live thumbdrive and add all in signature tomorrow.

I cleared config.plist file as you recommanded and put here in attachment.

I still having a problem about content of devices tab : i can't identify  what is GPU1 (HD4400) and GPU2 (AMD) and what is 3th entry in left tab :

firsr line : all about framebuffer con1 was commented, i enabled them, but if you look into config.plist, con2 existing too, i kept it commented it at it is.

437164252_Capturedecran2021-05-18a17_50_51.png.0e9b7c4467725ef226d85c35e1e1b927.pngMD) in left side of tab :

 

1259621869_Capturedecran2021-05-18a17_49_29.png.aac1a1cbd4e91e28e72a0f14faa28b52.png175667104_Capturedecran2021-05-18a17_49_53.png.ef838ef8c0b9935fe49f4cdc282e7469.png

config.plist.zip

Use IORegistryExplorer app to browse through your computer's IOReg and identify the various hardware components, their location in IO/on the PCIe bus, their PCI id, etc.

 

Intel chipset standard:

  • discrete GPU is located @1 (IO address 0x00010000)
  • integrated GPU is located @2 (IO address 0x00020000)

Properties injected for device @3 are audio-related so one would be tempted to say your HDEF device is @3 but it's not the usual location (@1B). Check it out in IOReg.

Properties injected @1B are commented out, so no effect.

 

Identify your hardware details, included location and clean up your config.

 

As far as your HD4400 iGPU is concerned, again, all you need are the following properties:

AAPL,ig-platform-id         0600260A                    DATA     -> mobile Azul framebuffer for HD4200/4400/4600
device-id                   12040000                    DATA     -> fakes id of desktop HD4600 0x0412
framebuffer-patch-enable    1                           NUMBER   -> enables framebuffer patching
framebuffer-cursormem       00009000                    DATA     -> sets Cursor Memory Size to 9MB
framebuffer con1-enable     1                           NUMBER   -> enables patching of framebuffer port con1
framebuffer-con1-alldata    010512000008000087000000    DATA     -> changes con1 Pipe to 0x12 and Type to HDMI 0x00000800
hda-gfx                     onboard-1                   STRING   -> declares audio capability (HDMI/DP)

That's it; just remove all those lines previously commented out (some erroneously so) with a #.

 

HDMI audio on Haswell laptops also usually requires to rename B0D3 ACPI device to HDAU, if your DSDT shows such a device. I expect it's what you have @3 (i.e. the entry at PciRoot(0x0)/Pci(0x3,0x0) in your config) and the only property you would need to inject against it would be:

hda-gfx                     onboard-1                   STRING

not any layout of any kind or anything else.

 

Device @1b (i.e. entry at PciRoot(0x)/Pci(0x1b,0x0) in your config) would be your main audio controller, i.e. HDEF. The comment for the layout-id property should therefore be removed.

 

All of this has been extensively documented and discussed for years on forums; Dortania's documentation also explains the settings to use in details and, when it comes to properties injection, there is no difference between Clover and OpenCore.

 

Good luck with the rest of your endeavour.

That's Conexant CX20756 codec. 'should work with Lilu + AppleALC + layout #3 or #13.

https://github.com/acidanthera/applealc/wiki/supported-codecs

https://github.com/acidanthera/AppleALC/blob/master/Resources/CX20756/layout3.xml

https://github.com/acidanthera/AppleALC/blob/master/Resources/CX20756/layout13.xml

 

You may need to patch ACPI HPET device for IRQs, that's pretty common for audio (FixHPET ACPI fix in Clover config).

Things going on ! HDMI video now working :) Thank you very  much !

i changed SMBIOS to MBA 6,2

still no screen lighting setting

 

i removed all files concerning voodoo HDA and installed AppleALC.kext (+ alc-verb +  AppleALC.kext.dSYM) in C/K/O, fixed FixHPET in clover configurator/ACPI  and put inject 3 (tried 13 too) in devices -> inject -> audio

I had a look at the xml layout files, but i don't know how to include #3 or #13 layout into config.plist. Is it the goal ? or maybe is there another way to inject xml audio layout ?

thanks

 

I meant you to inject layout 3 or 13 in your config against HDEF device @1B; I can only assume it is the correct device (i.e. the standard stuff) since you never produced an IOReg or an extracted DSDT of any kind...

PciRoot(0x0)/Pci(0x1b,0x0) -> layout-id    3            NUMBER
                           -> hda-gfx      onboard-1    STRING     // optional

When I wrote '#', I meant 'number' by convention, that's all...

 

Re: AppleALC, all you need is the kext, nothing else. It's a Lilu PlugIn so it only works with Lilu of course.

 

Brightness control requires SSDT-PNLF to be injected as pre-requisite and you may find default keys by trial and error; on my Tosh R50-B, brightness control works with [Fn-Ins] and [Fn-PgDn], not Fn-F2/Fn-F3. Try all the various combinations with all functions keys. I'm sure you'll find some that work.

Posted (edited)

Yeaa, sound working, better quality than with voodoo extension :)

i mean internal speakers/headphones (automatic detection) and integred microphone, i don't have hdmi audio out yet, i will check tomorrow, with brightness control.

Merci :)

 

Edited by zazman
Quote

HDMI audio on Haswell laptops also usually requires to rename B0D3 ACPI device to HDAU, if your DSDT shows such a device.

On 5/18/2021 at 6:39 PM, Hervé said:

 

Unfortunately B0D3 isn't in my DSDT patch list. I used rename device button  and tab in CC/ACPI to add B0D3 in the left column and HDAU in the right one. Not sure if it was enough, because nothing has changed after that.

 

But in fact, HDMI audio is not a real priority for me, internal sound now working well and i also use USB external sound cards for multitrack recording on this computer.

 

2 other things would be better for me to work properly :

 

into my device/properties PCI config :

#1 -> PciRoot(0)/Pci(0x02,0) = integred GPU (intel HD4400)

#2-> PciRoot(0)/Pci(0x03,0) = discrete GPU (ADM260) ->all lines commented

#3-> PciRoot(0)/Pci(0x1b,0) = HDA audio @ layout 13

 

What i want to do first is to disable discrete GPU to avoid it to drain battery :

What instructions should i inject for PciRoot(0)/Pci(0x1b,0) #2 to desable discrete GPU ?

 

The second important thing for me would be to make britghness setting cursor visible on the screen control panel in system preferences.

you spoke to me of keyshortcuts but I think keys shortcuts can't work if britghness setting feature isn't enabled into MacOS.

- I tried to change WEG release, actually 1.4.9 but tried also 1.4.8 and 1.4.7 without any succes.

- I tried to change SSDT-PNFL.aml : i was using yours, tried the old one i got before but nothing changed, so i put yours again.

- i put SSDT-PNFL.aml at second position in the sorted order tab in CC/ACPI, first one is SSDT-EC.aml

 

I was using Applebacklighfixup.kext in previous macos (Mojave or earlier) but no need to use it into Catalina, it woked by itself, so i don't think it may help into BS

Do you have another ideas about that ? Updates from Catalina to BS 11.2 let it to work, 11.3.1 fresh install broke it.

How long must we wait before you post a raw extracted DSDT and an extracted IOReg? This is getting kind of tedious you know. You can't keep trying things in the blind.

SSDT-PNLF is incorrect: GFX0 instead of IGPU -> rename

IOReg shows device HDAU; maybe you did not look... In your config, just uncomment the associated property mentioned above.

  • 3 weeks later...
Quote

SSDT-PNLF is incorrect: GFX0 instead of IGPU -> rename

Done, but no effect yet

Quote

IOReg shows device HDAU; maybe you did not look... In your config, just uncomment the associated property mentioned above.

That's what i have for B0D3 to HDAU ,  There isn't actualy  any comment regarding to HDAU in config.plist :

 

<key>RenameDevices</key>
        <dict>
            <key>B0D3</key>
            <string>HDAU</string>
        </dict>

×
×
  • Create New...