Jump to content

Why can't I repeat the same hackintosh?


10 posts in this topic

Recommended Posts

New user here. Sorry that I posted here, I couldn't post under Big Sur even after reading the guide.

 


 

You'll have to reach at least Newbies group level (at least having 10 useful posts) to get the ability to post in that area.

 

 


 

2 weeks ago I found out about OpenCore and read its entire manual word by word. I was able to install MacOs Big Sur on my PC on my first attempt. The system was so stable and performant that I decided to wipe Windows10 (yuck) and permanently move to MacOS. I was also able to update the OS via System Settings with no problem.

 

However, when I tried and erased my entire disk ( using the exact same USB stick that I used earlier, not touched since then ) and reinstalled, I was able to perform the first step of installation, but the system would keep restarting at the second stage.

 

I see the Apple logo, the mouse cursor, and then the text output kicks in and the system reboots.

 

I haven't touched my BIOS/UEFI settings. I didn't even go to bios since then. The USB stick was not used since the first installation.

 

I've attacked an screenshot of the verbose output, OpenCore's entire log and my entire EFI folder ( The serial number is replaced with a fake one ). I also have tweaked my bios settings to match the OpenCore requirements as much as it was available. This is really awkward as it shouldn't happen since no config has been changed. I also tried rebuilding the USB/config.plist from scratch. The output is exactly the same.

 

Here are my PC specs:

 

CPU: Core-i3 8100

MB: Asus ROG B360-F

RAM: 8GB ADATA

GPU: Integrated UHD630

Disk: 120GB ADATA SP600

 

Any help is greatly appreciated.

 

Here's a screenshot of my screen right before the reset.

 

OpenCore-Log.txt EFI.zip

Hi,

 

To be clear...I'm not expert...but three points

 

1: It may help if you take a better photo of the screenshot, very difficult to read any details.

2: Did you wipe and create a new partition on the old Windows disk during your installation process i.e. Disk Utility and then start the installation? I had issues when I hadn't done this correctly. It started to install then had disk permission issues.

Screenshot_from_2020-02-28_00-22-31.png

3: In your config.plist the last driver XHCI-unsupported.kext doesn't have an ExecutablePath set. I don't know what effect this would have but worth fixing.

1 hour ago, dz0rpw said:

Hi,

 

To be clear...I'm not expert...but three points

Hi, thanks! Sorry I was using an old phone, i'll take another screenshot.

Actually it doesn't matter how I format my disk. I tried wiping it entirely, creating new partition, etc. How did you solve it btw?

I'll fix the plist and see if it works!

I was moving from High Sierra to Big Sur in one go and it didn't like the APFS version or something like that. Once I used Disk Utills to remove then recreate it was fine.

 

It looks like it's already shutting down and unmounting the volumes. Maybe the screen before this may provide more insight. 

 

Your config.plist is very different to mine, what CPU/Motherboard do you have? A lot of the False/True options in the Booter section are set differently to me. DisableVariableWrite, RebuildAppleMemoryMap, DevirtualiseMmio are just a few.

17 minutes ago, dz0rpw said:

I was moving from High Sierra to Big Sur...

I did use diskutil to completely wipe the disk, create partitions, volumes, different filesystems, but didn't help. My pc specs are at the end of the post.

 

It's strange as the same config worked just fine the first time.

Well we learn more each day...

 

Ignore the executable path, that's just because there is no executable for that kext, unlike the others. It's just the info.plist.

 

I've just spent the weekend rebuilding my machine, all up and working now. Picked up the little nugget above as I was forced to remap my USB ports.

 

What I did come across was my BIOS almost randomly picking which EFI partition to use after a reboot. I don't think my old ASUS BIOS is great for this work. Anyway, having it use the wrong (USB) EFI while then booting from the NVME drive caused a few problems.

 

I hope you find a solution soon

Posted (edited)

Unless you did more than wipe the disk, have you verified that you created a GPT/GUID format hdd with a sufficiently large enough APFS container after wiping it?

Edited by HenryV

Ok, for some reason this has something to do with my EFI partition. I resized my EFI from 200MB to 401MB, and the installation continued successfully.

 

I'm not sure if this was an issue due to size of the partition, or some permissions.

14 hours ago, banklauncher said:

Ok, for some reason this has something to do with my EFI partition. I resized my EFI from 200MB to 401MB, and the installation continued successfully.

 

I'm not sure if this was an issue due to size of the partition, or some permissions.

You may have experienced some corruption of the partition table data, especially if using third party partitioning software.

 

Always good idea to have backup of partition table before making changes.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...