Jump to content

Power Option in System Preferences for Hard Drive Sleep Check Box


5 posts in this topic

Recommended Posts

Greetings,

 

Before all  updates in System Preferences Energy tab used to have Put Hard drive to sleep.  It has disappeared after a powernap.

So I changed the mac model to about 5 different ones to see if this option shows and then switched back to

the mac model I had. Then the option showed up until the first powenap then disappeared.

 

In pmset it does show up as disksleep,  just not in System Preferences any longer.  
What would cause this to happen?

I looked at kexts, SSDT's config.plist and it is possible that some SSDT conflicts.

 

Anyone else experience this? Can you share what you did to make it not disappear?

Thanks

on Big Sur it's not a issue,you plugin any usb drive it will show up "Put Hard drive to sleep" on energy saver if you only get SSD drive on your pc.

1 hour ago, 2886zhu said:

on Big Sur it's not a issue,you plugin any usb drive it will show up "Put Hard drive to sleep" on energy saver if you only get SSD drive on your pc.

ah, I see strange thing.

 

Yes I have SSD drive. 

 

Thanks good answer. But we want his on all the time so as to not be confused.  

 

@makk Nothing to worry about, the missing "Put hard disks to sleep when possible" in "Energy Saver" has become a "cool"  feature as it is superfluous in a build without spinning disks - which "hard disks" indeed are. NVMe's and SSD's have no mechanical wear and thus do not require this feature in order to extend their longevity. Why that missing option suddenly shows up when a memory stick is inserted into a USB port is beyond my comprehension, because it is also a non spinning data carrier -medium -, same as SSD's and NVMe's 

 

Greetings Henties

Screenshot 2021-05-05 at 8.44.30 AM.png

With memory stick inserted.png

Interesting.

 

Thank you!

 

It is funny to even think to have it.  But it would require it due to power going to the SSD drive.  should be similar to USB ports.

idle mode drop in voltage amps.  Sleep mode is funny word.  Should be reduced power. Makes more sense. sleep confuses

issues in the brain.  I want to sleep now do I sleep with lower voltage to my body? lol.... for another Sunday...

 

USB I would imagine because it requires port voltage.

Funny thing about this USB, when in powernap the port gets disconnected. have to pull it out. Same with USB mouse not always

but at times.  Intermittent.  Probably too many UIAC and USBX ec things? Confusing at times which one is working and isn't.

Consistency is what I'm looking for.


In Catalina the Disksleep checkbox remains regardless of plugged in or not. So in Big Sur they must have changed to detect USB ports

and HDD's.  Which then causes a problem with powernapping for USB ports.

 

Thank you ! Good to know so I won't freak out

 

×
×
  • Create New...