Jump to content

Updating OpenCore with LauncherOption = Full


3 posts in this topic

Recommended Posts

I have LauncherOption set to Full in OpenCore 0.6.7.

 

To update OpenCore, I need to disable LaucherOption first right and then Reset NVRAM right?

 

 

6 hours ago, mengshi said:

I have LauncherOption set to Full in OpenCore 0.6.7.

 

To update OpenCore, I need to disable LaucherOption first right and then Reset NVRAM right?

 

I think you only have to reboot removing OpenCore entries in BIOS and doing ResetNVRAM. Try and comment.

On 5/2/2021 at 6:52 PM, miliuco said:

 

I think you only have to reboot removing OpenCore entries in BIOS and doing ResetNVRAM. Try and comment.

You shouldn't do above. I had unrecoverable issues with boot requiring a BIOS reflash when I did that (Thank goodness I had a back up flash bios).

 

The safe way as I have found out:

 

1. Before updating, change LauncherOption to Disabled and use tools to clear NVRAM. Do not clear OpenCore from BIOS.

 

2. When you do the 'dummy' USB drive OpenCore update, make a point of having the BOOT folder in EFI

 

3. With 2. above working, then you can copy the EFI to the main drive/SSD.

 

4. So after booting in OpenCore on SSD/hard drive, you can then do LauncherOption=Full again.

 

It is a bit of a hassle and you can screw up by deleting OpenCore from BIOS or deleting the BOOT folder in the drive you want to boot (It will fail if you are missing either). I think it is safer to leave the BOOT folder intact (Although Dortania did say it is ok to delete it and I have - but the issue is with updating to the next version - you have to remember to do the above).

  • Like 1
×
×
  • Create New...